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New: Pop-up menu to creates a new IQBase from a template. Menu list all templates files, such as:

New Blank IQBase

New IQBase (with sample data)

Looks up in the current folder and in the AppFiles folder

Open: Shows the File Open dialog. If a file is currently loaded, the selected file will open in a new

InfoQube window

Close

Save as...: Save the current IQBase under a different name

Import from:

https://infoqubeim.com/drupal5/index.php/pierre


Text and Image File(s). Supports plain text, markdown, RTF, HTML, PDF and images. Option to

save the file location as a file reference and fill fields FileName and FilePath

Non-hierarchical data: Details: Delimited Text files (Excel, Access, Outlook, etc.)

Hierarchical data: Details: Tree-based / Outliner files Import

Ecco Pro file: Ecco Pro must be installed to successfully import items. Details: Ecco Pro

Import

Evernote export file: See Evernote Import

Export to

Text File(s): Select 1 or more items. Support export to a single file or one file per item. Plain

text or Rich text. Details here

Microsoft Excel: Export all items that meet the grid filter criteria to an Excel file. 

Same list as when the display mode is flat list Grid > Display mode > Source Items (Flat List)

Items in XML Format: Not yet implemented. Copy items in a grid in XML format and paste

into Notepad

Page Setup...: Shows the standard Windows Print Setup dialog

Print Preview: Shows a dialog of print types and options, specific to each view (Grids, Gantt,

Calendar, Surface, etc)

Work Offline: Turns off Internet related features (EmailToIQ, Google Connect, Web pages in HTML

pane)

Properties: Lists the number of items, fields, values, etc

Welcome to InfoQube: System provided file with sample data and the full online manual. 

Now with "See Also" links to related subjects

Recent file list:

Shows the list of recent files, with the current one checked

If a file is not available (USB or network drive, different PC, etc), the file entry will be shown

disabled

The maximum number of entries is set in Tools > Options > General

Selecting a file entry will switch to that file if it is already opened

Right-click > Remove to remove entries from this list

Exit
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Edit Menu

Undo

Redo

Cut

Copy: Split button with the following sub-commands

Copy as HTML Outline: Copies the selected item and all its sub-items + Doc pane content

as a Heading styles-based compound document. Details here: 2. Export Outlines (Print-

ready)

Copy as Hyperlink: Copies the current item in the form of a hyperlink. Paste elsewhere to

link back to this item

Copy Item IDs: Puts the list of selected items in the clipboard (plain text, comma separated).

Useful for filtering and linking

Copy Item URIs: Puts the list of selected items in the clipboard as a URI link. (IQ:// protocol).

See InfoQube Program Install and Set-up and Hyperlinks on setting up and using URI

universal links

Copy Special...: Shows a dialog of copy options

Paste: Split button with the following sub-commands:

Paste as Plain Text

Paste Special...: Shows the list of clipboard formats to paste

New Item...: Details: 2. New Item dialog

Edit Item...: Opens the Item Editor. See 5. Item Editor
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Delete Item: Removes the selected items from the IQBase. Warning, cannot be undone !

Edit (F2) and Popup Editor (Shift+F2): Details: 3. Popup Editor

Select All

Toggle Case

Renumber items... Shows a dialog to renumber cell values:

To use, select 2 or more cells (text or number), Edit > Renumber and set options.

The cell content will be replaced with the numbering, so do not do this command on the Item

column ! Use Edit > Undo to cancel operation

Re-Calculate: If the field has a row equation, it will recalculate

Touch: Simulates modifying a field value and so it will execute field auto-assignments if any are

defined

If the field-value is empty (or unchecked), will trigger the Erase event (E:), else the Modify event

(M:) will be triggered. Supports multiple items selected. The same can be done in the Properties

pane

Search: Opens the Live-Search tab. Details: 1. Live-Search. Split button with the following sub-

commands:

Advanced Search: Opens a floating pane to search: Details: 3. Advanced Search Pane

Search and Replace: Not yet implemented

The Omnibox can also be used to search. Details: 1. Omnibox
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Refresh: Most views refresh automatically. Some don't (by-design). A Refresh ensures that the

view shows the most updated information

Views: InfoQube items can be viewed using a set of different UIs, each with a distinct visual appearance

/ layout. These are:

Home Page: A customizable dashboard. Details: 8. Home Pages

Calendar: Details: 2. IQ Calendar

Surface: 2-D view of items. Details: 3. IQ Surface

Grids: Displays Grid related commands. Sub-menu can be detached and docked to anywhere

New Grid...: Show the Create Grid dialog

Manage Grids...: Details: 6. Manage Grids Dialog

Recent Grid: Dropdown menu divided into 2 sections: Loaded grids and other grids, each

sorted by last access

https://infoqubeim.com/3445
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List of Grids: Displays the list of grids that have Show checked (Manage Grids dialog)

Both grid lists have a context menu. Right-click to show these commands:

Unload the data is particularly useful for grids shown in panes and "dashboard" type grids

Card Views: Lists is divided in 3 sections:

Card views currently shown in tabs and panes (bold = loaded)

Other Card views that contain cards (i.e. items)

All other Card views (e.g. those that are currently empty)

Item Editors: Displays list of Item Editors commands:

Edit Selected Item

Floating Editors: Toggle between floating (i.e. "always on top") windows or regular windows.

Regular windows are shown on the Windows taskbar

List of recently edited items. Currently loaded items are shown on top of the list and in bold

text

Grid sub-views: Specialized views of a grid. There are 4 sub-views:

TimeLine: Similar to the Gantt chart, but more compact

Pivot Table and Pivot Chart: Details: Pivot Tables and Charts

Map View: Details: Map View

Card View: Experimental view, where each item is shown as an index card, with the item text as

subject and Doc pane content as card content

Panes: 

Properties: Details: 6. Properties Pane

Tags: Details: 7. Tags Pane

Document: Split button. Moves focus to the Doc pane (opens it if it isn't open). Details: 4.

Document Pane

New Document Pane: Opens a new document window

Close all Doc Panes

More Info: Details: 5. More Info Pane

Advanced Search: Details: 3. Advanced Search Pane

Go to Pane:

Grid <---> Document pane: Toggles focus between grid and the Document pane

Grid <---> Properties pane: Toggles focus between grid and the Properties pane

---> Grid: Moves focus to the grid

Other:

Favorite Items: Details: Favorite Items

History: Navigation history

Back
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Forward

Auto-log History: When checked, similar to how a browser records history. If unchecked,

user manually sets the history points

Item-View in History: When auto-log is off, adds / removes items in the history list

Loop History (enabled when auto-log is off)

Delete History

List of History items. Right-click to show:

Pin item in History: Pinned items are not deleted when Delete History is performed

Remove item from History 

Zoom: In / Out / Reset. Exact action is specific to each view

Layout:

Workspace Tabs: Change the position of workspace tabs from Top > Top (Fit All) > Right >

Bottom > Bottom (Fit All) > Left. Details: Working with Grids and Tabs

Maximize Workspace: Maximizes the Tabbed workspace by hiding all panes. 

Floating Pane: When in a pane, toggles between docked and floating

Load...: Load a previously saved pane layout (*.Dock.dat)

Save...: Save pane layout.   (*.Dock.dat). Saves the current layout of panes (Properties, HTML,

grid, notification, etc)

Reload Last Tab Layout: If the file is opened without auto-loading tabs, or if tabs are closed,

this restores the last saved layout

Image viewer: A built-in image viewer, which rotates to show constant size (portrait vs

landscape). Double-click on the image to lock the viewer on a picture. Multiple viewers can be

opened.

Tooltips: Toggles the display of tooltips in grids and the Properties pane. If turned off, hold Ctrl to

show tooltips. Command button tooltips are always shown

Status Bar: Toggles the display of the status bar, the bottom line of the main program. Details: 9.

Status Bar
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Display Mode...: See 1. Grid Display Modes

Context Parents: Select the number of context parent levels to display

Outline Styles: See 3. Outline Styles

Manage Styles...

Override Item Settings

List of defined Outline styles

https://infoqubeim.com/drupal5/index.php/pierre
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Sort: Sort settings. See 5. Sorting and Grouping Items

Filtering: See 2. Filtering

Column Filter

Alpha-numeric Filter

Date Filter

Hoist Items. See Hoist Filter

Gantt Chart: Show / Hide the Gantt portion of the grid. See 5. Gantt Menu

Pictures: Toggles the display of images in the grid. When turned off, the image file name is shown.

To view the image, use the Image Viewer. See: 8. Image Viewer

Source Bar: Show / hide the grid source bar. Details: Grid Source EditBox

Done Checkbox: Show / hides a checkbox on the tree column. Check to set the item as done

Auto-Search: Toggles Auto-Search mode. See: 2. Grid Auto-Search

Save: Saves the current grid configuration. Optional as closing the grid automatically saves it.

Sometimes useful, such as updating the Shown In column of Live-Search

Save as...: Save a copy of the grid under a different name. Having 2 nearly identical grids is useful

to have 2 views with different column sets or different sorting / grouping / filtering

Go To: Navigates in the grid:

First item

Previous page

Previous item

Next item

Next page

Last item

New item: Adds an item after the current item. Same as pressing Enter

External Link (ODC file): See 7. Live Links to IQ Grids from Word and Excel

Grid Properties...: Opens the Manage Grids dialog, showing the current grid properties. Details: 6.

Manage Grids Dialog
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Overview: Show / hide the Overview. The Overview is a re-sizable summary area on top of the

Gantt. Provides quick scrolling. Buttons may also display as preset Gantt scales

Histogram: Show / hide the Histogram. The Histogram is a pane below the Gantt. Provides

resource usage type information, in bar graph form

Non-Working Days: Toggles the display of days marked as non-working. Non-working days are

shown in grey

Critical Path: After defining task dependencies, this command will highlight (in red) the tasks

which determine the project completion. To finish earlier, focus on those tasks

Refresh Critical Path: After making changes, it will update the display to show the new

critical path

Optimize Schedule: Compress the tasks (within the constraints of task links and delays) to

find the earliest completion 

Also, if Can Move Started Tasks is not checked, tasks that have a non-zero % complete will

not be moved

Save Schedule: The Optimize Schedule doesn't actually change the task dates. Use this

command to save the optimized schedule as the current baseline, or turn off the Critical

Path to return to the current baseline

Task Links: Used to define constraints between tasks

Link Properties...: When a link is selected, displays the Link Properties dialog, to set link type

(FS, SS, SF, FF) and lag between task



Link Type: None: Links are visual only. Tasks dependencies are off

Link Type: Use Task Dependencies: Links properties (FS, FF, etc) are enforced

Link Type: Locked Relationship: All linked bars move as a block. Useful to move a whole

project

Is a Summary Task: Toggles the state. A summary task start / end dates is set from the earliest

start and latest end of all sub-tasks (i.e. sub-items). Select a bar / milestone to enable command

Save Selected Tasks: Saves the start / end dates of the selected tasks. This is generally automatic,

except

Can Move Started Tasks: If checked, prevents moving tasks that % Complete is not zero

Day is Non-working: When selecting a day (day header), toggles the Non-Working state. When

task span non-working days, the end date is adjusted to maintain the same number of working

days

Scroll to Today: Moves the Gantt to center on today

Auto-Scroll: Select from No Scroll, Scroll to view the bar start or end

Zoom: Move slider to change the Gantt scale

Gantt Properties: Opens the Manage Grids dialog, showing the current Gantt properties

 n.b. The advanced toolbar has a Gantt button with the same set of commands. Both the Gantt menu

and Gantt button are customizable.
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Column Menu

Details here: Grid Columns and Column Sets
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New Event...: Shows the New Event dialog

New Event uses: Shows a list of date fields. New events will use this date field. Default field is

Appointments

Edit Event...: Shows the Event dialog

Delete Event: Shows a dialog of delete options (event, event and date-value, item)

All details on how to use the Calendar: 2. IQ Calendar
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Main documentation page: 3. IQ Surface
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Background Color: Surface background color

Move Linked Items: If checked, linked items move as a group

Hide Linked Items on Collapse: Sub-items always hide when collapsing items. This controls if

linked items also collapse

Item

Auto-Size: If unchecked, item can be resized

Padding: When Auto-Size is On, sets the padding around the text

Text Alignment: Select from a list

Text Fore Color: Uses the ItemForeColor field

Back Color: Uses the ItemColor field

Border Color: Item box border color. Internal to the Surface (not available as field)

Link

Link Tasks...: Select 2 or more items to link them. If only one is selected, a dialog will list of

possible items to link to

Delete Link

Link Line Type: Select from a list

Link Shape: Select from a list

Link Color

Link Text: Extra label that can be shown on link

Show Hidden Items: When deleting items, you can choose to not delete but simply hide from the

Surface. This command shows hidden items

The difference between removing an item and hiding is that hidden items retain their Surface

specific properties (size, border color, link type, etc)
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Insert:

New Item: Inserts an item at the same indentation level as the current item

New Sibling: Same as New Item, except when the item has more than one parent. New

Sibling will have the same parents as the current item

New Sub-item

Current Date

Current Date and Time (using the Windows regional setting)

Long Date Format: Toggles the format of the above 2 commands, between short and long

date formats

Insert Tab: Only visible when editing

Move: Moves items up / down and left / right. (Alt + arrow). Up / down does not change the

indentation level. To move an item to another parent, either move it left or use drag-drop

Select Item: Split button to select the current item. Sub-commands to:

Unselect all

Invert Selection



Select Sub-Items: Selects the immediate sub-items. Hold Ctrl to keep current selection. On

the Surface, Hold shift to also select linked items (i.e. detached items)

Split Item, Join Items: See Item Join and Split

Sub-Items:

Collapse (Ctrl + Left arrow)

Collapse Parent

Expand (Ctrl + Right arrow)

Show Main Sub-Items: Sub-Items whose main parent is not this item will not be shown.

Useful in multi-parent scenarios. Shortcut: Shift + Click on the expand button (+)

Show All Sub-Items: Filters may filter out some sub-items. This command shows all sub-

items (i.e. same list as shown in the Properties pane). Shortcut: Ctrl + Click on the expand

button (+)

Show Levels...: Shows a dockable pane to expand / collapse items:

Select Sub-Items

Font: Split button to open the standard Font dialog. Plus the following sub-commands:

Bold, Italic, Underline, Strike-through: Works when editing and not

Grow Font / Shrink Font: When not editing only

When editing, the font property is embedded HTML tags, shown in all views

When not editing, the font is saved in the Item Font property. Effective in grids only

Text Foreground Color, Background Color: 

Dropdown to select from Named colors, Standard colors or the full color palette

When editing, the color is embedded HTML tags, shown in all views

When not editing, the color is saved by default in the ItemForeColor and ItemColor fields.

How these are shown depends on the view type and view settings

In Tools > Options > This file, the fields used to store / show colors can be changed. Hence,

by changing these, different color sets can be applied (for printing / reporting purposes for

example)

Mark as Done (Ctrl + M): Marks selected item(s) as done. If already "done", removes the Done flag.

By default, the "done" flag is a date in the Done field. This can be changed in Field Properties >

General > Is Done Field

Favorite: Checked if item is a favorite item. See Favorite Items

Locked: Checked if item is locked. See Locked Items
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Show in Calendar: Checked if an item is shown in the Calendar. An item is shown in the Calendar if

any of its date field-values is set to show in the Calendar

If only 1 item is selected, the New Event dialog is shown

If more than 1 item is selected, the event created will be current date and time

If in a grid and dates are selected (i.e. not the item column, but any date column), then the

actual dates in the grid will be used as event date and event type will be Unscheduled

See 2. IQ Calendar

Remove from Calendar: Removes events for the selected item(s).

If an item appears more than once (i.e. 2 or more field-values are set to show in the

Calendar), all instances are removed.

The actual date values are not erased, so the item field-values are not changed

On the Surface: Toggles between showing / hiding the selected item(s) on the IQ Surface. See 3.

IQ Surface

Show in Home View: See Item Home

Hyperlink... (Ctrl + K): Opens the Hyperlink dialog. See Hyperlinks

Remove Hyperlink

Index Linked File: Indexes the text content of compatible file types. Uses the FileRef fields or the

URL field.

Currently, the compatible types are PDF, RTF, HTM, plain text and web pages. This means that if

you drag/drop a set of files / URL onto a grid, their text content will be searchable within IQ.

Click on a hyperlink (in the Properties pane) to open the file in an appropriate viewer / editor: 

Mark Item (Replace) (Shift + Ctrl + M): Split button to set the Marked item list to the currently

selected items: Plus the following sub-commands:

https://infoqubeim.com/1215
https://infoqubeim.com/3883
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Tip: Add marked items as children support multiple items. That is, if you select two or more

items, each of these will have the marked items as sub-items

Item Properties: Shows the item in the Properties pane and moves focus to that pane
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Manage Grids...

Manage Fields...

Manage Forms...

Manage Database:

Backup
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Compact: Also does a database engine-level repair

Other...: Shows the Database Tools dialog where you can:

Repair an IQ Base: Does an IQ-level database repair (Fields, Views, Item hierarchy, etc)

Rebuild: Currently disabled

Mask Data: Scrambles all text field values. Useful to send it over to InfoQube's staff for

analysis and bug repair. Ensure you make a copy of the IQ Base first !

System Tables: Show / hides system table when viewed in a compatible general

database environment, such as MS Access

Set Password: Shows the File Password dialog. This password will be required to open the

file, both in InfoQube and in other compatible database environments

Encrypt / Decrypt: The content inside the IQ Base can be encrypted so Hex/Text editors

cannot read it. Combined with a File Password, this provides content security

Recalculate all date dependent fields: Does the same recalculation as when InfoQube

detects a change of day

Sync with external database: Details

Delete All Items

Delete All: Deletes all items, fields, grids, forms, etc

Visual Basic Editor

Google Connect

Evernote Connect

Internet Search using...: Shows a list of 4 user-defined search engines to send a search string to.

List defined in Tools > Options

Keyboard Shortcuts:

View All Shortcuts: Opens Notepad with the list of all shortcuts

Customize: Opens the Customize dialog. Details

View Custom Shortcuts: Opens Notepad with the list of user-defined shortcuts

Load Custom Shortcuts: Loads a list of user-defined shortcuts. Typically, this file was

generated with View Custom Shortcuts

Reset Shortcuts: Returns the shortcuts to the InfoQube's supplied list. Option to keep user-

defined shortcuts. This command most useful when system shortcuts have changed, when

new features are implemented, etc
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Check EmailToIQ Now: Shows a dialog to retrieve EmailToIQ message. Option to retrieve just

new emails or emails from previous days. Details

On-screen keyboard: Useful on a tablet with no physical keyboard attached

Dial...: Shows the Phone dialer dialog Dialer was removed

Send Emails...: Shows a dialog to send email to selected items. First select one or more items with

email address defined. Option to send a single email or individual ones (better spam filter

protection)

Help:

User Manual (local): Opens the InfoQube.chm file, stored in the AppData folder

User Manual (online):  

Options...: Sets all program options and options specific to the current IQ Base. Details
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The Document (or Doc) pane has a separate (and distinct) menu system, with its own commands,

toolbars and keyboard shortcuts. Customization is similar to the main InfoQube's menu. Right-click on

a menu and select Customize
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1. File Menu

File Menu

New: Clears the current document. Split button with the following sub-commands:

New HTML Document (stored in the IQBase itself)

New, from a Template: Select any html type file to copy it to the HTML pane. 

Combined with checkboxes linked to field, the HTML pane can be used as a data-based

customized data entry form

New HTML File: File named ItemIDXXX.htm will be created (based on the default). Any

change is automatically saved to this file

New MHT File: File named ItemIDXXX.mht will be created (based on the default). InfoQube

cannot edit MHT files directly, but supports external MHT editors. See Using MHT

Documents

New MarkDown File: File named ItemIDXXX.md will be created. See Using Markdown

documents

New Ink File: File named ItemIDXXX.slink will be created. Ink documents are used for hand

written notes (using an active pen / stylus) and a collaborative whiteboard. See Using Ink

Documents

New SVG File: File named ItemIDXXX.svg will be created. SVG documents are drawings. An

drawing program supporting the SVG format is required. Inkscape is a good option

Open: Dropdown menu with the following commands:

Open File: Select the local file to display in the pane. Any change in the pane will be saved to

this file

Open Folder: Select the folder to display in the pane

Open Web Page: HTML pane will show a live web page

Save: For MHT, SVG and Ink documents, Save will compute the document height and save it in the

field ItemHTMLHeight (used in HTML Export)

https://infoqubeim.com/2000
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Save As...

Save as default...: Defines the new html document content

Re-Index PDF file: Whenever the PDF file is changed, this command will read it and update its

index. Items created before v109 are not indexed, so use this command to index the content

Revert: Reverts the content to the last time it was saved

Use as Home Page: Toggles the use of this html document as a Home Page. See 8. Home Pages

Navigate:

In Browse mode, navigates forwards and backwards. When in Folder view, shows the parent

folder

Change the current grid focused item (previous, next). HTML pane will update

Add item / sub-item in the current grid

Change the current item text

Erase the current item

Open in browser

Page Setup...

Print Preview

Close: Closes the HTML pane
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Undo / Redo

Cut

Copy: If on image or  hyperlink, copies image source / hyperlink URL as plain text format and links

to these as HTML format

Paste: Will "smart" paste using the same clipboard format as the previous paste, provided it is

available. Use Paste Special to ensure a specific format is used

Paste Special: Shows a dialog of all clipboard formats currently in the clipboard. Select the

format to use

Select All

Find: Shows the Find dialog. Option to Highlight matches:

Replace: Shows the Replace toolbar:



Enter find text

Press the < and > button to move back and forward in the match list

Enter the replace text

Click Replace. Next match is automatically selected

Enclose Text with ...: Enclose the selected text with a tag or other code. Adds matching end tag

Cleanup HTML Tags: Cleans up HTML tags and removes embedded style attributes. The list of

tags to clean up is defined in the Options.ini file (HTMLCleanUpTags entry). By default the list

is: div, h1, h2, h3, h4, h5, h6, li, ol, p, span, table, td, th, tr, ul

Fix UTF-8 Encoding: Debug tool

Use DIV / Use Paragraph: Changes all DIV tags to P tags and vice versa. DIV tags provides a

more compact layout than P tags

Bullet spacing is also modified

Remove Outer Element: Useful to clean up the HTML code. It removes extra SPAN, P and DIV

elements that encloses the current selection

Delete database copy: For all file-based document types (MHT, HTML files, MD, etc), a local copy

is saved in the database (in case the actual file is not available). This erases this local copy

(a local copy is only saved if Tools > Options > This file > Data storage > Save a copy of the

HTML... is checked)
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3. View Menu

View Menu

https://infoqubeim.com/drupal5/index.php/pierre


Refresh: When in Browse mode, refreshes the page

Browse Mode: Toggles between edit and browse mode. In Browse mode, the HTML pane

functions as a browser. F2 and Ctrl + M shortcuts toggle between Edit and Browse modes

For read-only document types (MHT, Ink, Web), Browse mode is locked. Double-click on the

document to open the external editor

HTML Code: Shows the HTML code view. Can be used to edit the raw HTML code

Details: Toggles the display of some HTML codes (P, DIV, Span). Showing these code can ease

editing and cleanup. N/A in IE11 mode

Borders: Toggles the display of borders around images and table cells. N/A in IE11 mode

Zoom In / Out / Reset. Changes the Document Zoom. There are 2 of zoom settings. Both are

shown on the status bar:

Document Zoom: Specific value saved for each document. Applies to all view modes (edit,

browse, print preview)

These command control this zoom setting

View Zoom: Set using Ctrl + Mouse wheel or using pinch zoom (touch pad and touch

screen). Applies only to edit mode

(Browse mode also supports View Zoom, but it gets resets to 100% whenever it is refreshed

or a new item is shown)

Main Toolbar: For conciseness, the menu bar is actually a button on the main toolbar. As this

toolbar can be hidden, use this command (using the context menu) to show it again

Lock Item: Toggles the lock state for this item. If locked, the pane will keep showing this item, even

if the focus item (in the grid) is changed. 

(hint: you can open multiple HTML panes and have some locked on specific items, while others

update to show the focused item)
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4. Format Menu

4. Format Menu

Format Menu

Format: Shows the Format dialog:

It is a Split button with the following sub-commands:



Style

Font

Font size

Bold, Italic, Underline, Strike-through, Highlight Text

Alignment: Left / Center / Right

Indent / Unindent text

Numbered and Bullet Lists

Text and Background Color: Select from the list

Superscript / Subscript

Position: For images:

Floating: When floating, images can be placed anywhere on the page

Lock Position: When locked, images can no longer be moved

Snap to Grid: For floating images, will align on a 10 px grid
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Image: Shows the Insert Image dialog: 

Current Date / Current Date and Time

Hyperlink: Shows the Hyperlink dialog. See Hyperlinks

Remove Hyperlink

Insert Table:

Horizontal Line

https://infoqubeim.com/3972


Checkbox. Shows the Insert Checkbox dialog:

When linked to a field (Y/N type), any change in the Doc pane will update the field and vice versa

HTML Code: Inserts HTML content into the document:
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Workspace Tab Context Menu

Workspace Tab Context Menu

Tab Color: Select the Tab color. Shown for tabs showing grids. Supports named colors. See Item

Formatting

Close Tabs commands

Show in a New Tab: Opens a second copy of the current tab

Detach Tab: Views can be detached and shown as panes in the main UI. Once detached, panes can

be docked, stacked, pinned and hidden

Copy / Paste View: Use these commands to:

�. Add a view to an existing tab. View will be shown as a pane, which can be docked, stacked,

pinned and hidden inside the tab. See "Using Dashboards"

�. Paste the grid format (Font, Line style, Colors)

Calendar, Grids, Recent Grid

Manage Grids dialog

Tab Groups commands: Splits the main UI into 2 or more tab groups, either horizontally or

vertically

https://infoqubeim.com/drupal5/index.php/pierre
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Hints: The Workspace Tab context menu is also displayed for pane headers and in grids, on the blank

area below the items

Pierre_Admin 2018/04/15 00:25

14 views

Customizing Menus and Toolbars
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Customizing Menus and Toolbars

All menus and toolbars can be customized. This can be done in a number of ways.

(the menu system is a clone of what was used for Microsoft Office 2003, so the same tips and tricks

apply)

There are two distinct menu / toolbar sets. One for the main InfoQube window, one for the Document

pane. Commands cannot be move from one to the other.

1. Moving Menus and Toolbar

All menus and toolbar can be moved and un-docked (i.e. floating).

To move a menu / toolbar, move the mouse to the left side of it, the cursor will change ( 4 arrows ). Click

and drag to move it or undock it. Once undocked, you can dock it to any of the 4 sides of the IQ main

window

2. Show / Hide Toolbars

To show / hide a toolbar, right-click on any menu / toolbar to show the list of toolbars. Select which

ones you want to have visible:
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3. Add, Remove, Move Commands from Menus and Toolbars

Right-click on a menu / toolbar and select Customize. The Customize dialog will open:

In Customize mode, it is easy to make changes to menus and toolbars:

Click on any command button and move it to another location on the same menu / toolbar or to

another one

Move any command button just slightly to the right (or down) to add a separator bar

Drag a command to an empty space to remove it from the menu / toolbar

To create a copy of the command, hold the Ctrl key while moving. This is often the easiest way to

add commands to toolbars

Text entry commands (such as the Omnibox) can be resized. Click the command, a black box will

be shown around it. Press Ctrl and click on the right side to resize it



Press the Escape key to cancel the drag-drop operation (while still pressing the left mouse

button)

Select any command from the Commands tab and drag it to a toolbar / menu (see below)

3.1 Toolbars Tab

In the Toolbars tab, you can:

�. Show / hide toolbars

�. Reset a toolbar: If you've modified a toolbar, this will reset it to the default one. This is sometimes

required when new features are added

�. Create a new empty toolbar. As the standard toolbars may be changed with every new release, it

is sometimes useful to create your own. 

3.2 Commands Tab

Holding the Ctrl key while moving a command is an easy way to create a new command button.

Another way is using the Commands tab. It lists all (actually nearly all) commands, by category:

Drag-drop any command to a menu / toolbar to add it.

3.3. Keyboard Tab

Nearly all commands can be assigned a keyboard shortcut. See Keyboard Shortcuts for details
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Click on the Keyboard tab to manage shortcuts:
 

 
Notes:

If a shortcut is not working, most likely the same shortcut was assigned to something else. Use View All Shortcuts to
find what it is assigned to.
There are 2 menu systems in IQ. The main one and the one for the HTML editing pane. Each are customized
separately.
Some commands don't show in this dialog (split buttons for example). To assign a shortcut to these, right-click
directly on the button and enter the shortcut there. Use Shift+Ctrl+C for example: 

 

3.4. Options Tab



3.5 Modifying an existing command

Right-click on any existing command button will show a context menu to allow changes to be made:
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Keyboard Shortcuts

Using and Managing Keyboard Shortcuts

Nearly all commands can be assigned a keyboard shortcut.

Use Tools > Keyboard Shortcuts... to manage shortcuts:

�. View All Shortcuts: Creates a file All.Shortcuts.tab containing all shortcuts (System + User). Opens

it in Notepad

�. View Custom Shortcuts: Creates a file User.Shortcuts.tab containing user shortcuts. Opens it in

Notepad

�. Load Custom Shortcuts: Prompts for a Custom Shortcuts file

�. Reset Shortcuts: Option to keep user shortcuts or reset all

�. Customize: Show the Customize Dialog

Customizing Shortcuts

To enter Customize mode, show the Customize Dialog:

(Tools > Keyboard Shortcuts > Customize or right-click on a toolbar > Customize)

Notes:

If a system shortcut is not working do Tools > Keyboard Shortcuts > Reset Shortcuts > 1- Reset

System Shortcuts

Another reason a shortcut may not be working is that the same shortcut was assigned to

something else. Use View All Shortcuts to find what it is assigned to

The Customize dialog is not fully modal. That is, you can click on menus and toolbars to re-

arrange / customize these. Move, delete, copy (hold Ctrl key) commands can be done directly by

drag-drop



There are 2 menu systems in IQ. The main one and the one for the Doc pane. Each are customized

separately

The toolbar shown on Item Editors is not customizable

Some commands don't show in this dialog (split buttons for example). To assign a shortcut to

these, enter Customize mode and right-click directly on the button and enter the shortcut there.

Use Ctrl+Shift+C for example:

The process of assigning a shortcut  is different in the dialog and in the context menu:

Dialog: Click in the 'Press new shortcut key' text box and press the actual shortcut keys you

want to use (i.e. press the Ctrl key plus the A key to set Ctrl+A as the shortcut

Context menu: Click the 'Shortcut' text box and type the shortcut as text (i.e. type Ctrl+A)

The process is very similar to MS Office (pre-ribbon versions, such as XP, 2003).

To quit the Customize mode, close the Customize dialog

 IQ Calendar command buttons

The IQ Calendar has a series of command buttons at the top of the form. These can be customized

using the same dialog as other command buttons

The commands are in two categories:

Calendar

DateFilter
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Doc Pane keyboard shortcuts

HTML Pane Keyboard Shortcuts

 Shortcut  Comments

File

Save  Ctrl+S

Print

preview
 Ctrl+P

 Navigating

in the grid
F7, F8 Previous item, Next item

 Edit item

name
F2 Hit enter to save. Grid will update

 Delete

item
Ctrl+D Same shortcut as in the grid.

Edit

Undo  Ctrl+Z

Redo  Ctrl+Y

Cut  Ctrl+X

Copy  Ctrl+C

Paste  Ctrl+V

Paste

Special...
 Ctrl+Shift+V

Select All  Ctrl+A

Find  Ctrl+F

Replace  Ctrl+Shift+F

Open in

MS Word
 Ctrl+W

 Edit (MHT) in MS Word or other word processor. You

may have to add path to the word processor .exe file

under "Menu>Tools>Otions>Other>MS Word path"

 Open in

[Blocknote]
 Ctrl+Shift+W

 Edit (MHT) in Blocknote - a free WYSIWYG MHT editor.

You may have to add path to the word processor .exe file

under "Menu>Tools>Otions>Other>MS Word path"

Format

Bold Ctrl+B

Italic Ctrl+I

Underline Ctrl+U



Indent
Alt+Right

Arrow

Unindent
Alt + Left

Arrow

Insert

Hyperlink Ctrl+K

Other

Indent Tab

in HTML pane, tab indents, and shift-tab unindents.

This works for regular text, numbered items and bulleted

items.

Unindent Shift+tab

F6 F6 Open the HTML pane. Keeps the pane on autohide

Shift+F6 Shift+F6
Open the HTML pane. Does not keep the pane on

autohide. You need to press Shift+F6 again to close it.
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Grid/Items Keyboard Shortcuts

 Operation  Shortcut(s)  Comments Reference

Open a Grid Ctrl+Shift+O
Shows list of Grids, type in first letter of grid - 

 repeatedly if necessary - to find grid

Select an item

(fully, with all

columns/fields)

left click on

# field

Select/deselect

items (fully, with

all

columns/fields)

Ctrl + left click

on

# field
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Select/Deselect

multiple items

at once

Shift+left click

on

field/column

1- Shift+left click on one field AND

2- Shift+left click on the another fiel

(use the # column to select/deslect full items)

Select/Deselect

fields/columns

Ctrl-Right

click on

column header

(very useful when exporting certain items +

fields to HTML format)

Expand/collapse

items under a

selected parent

Ctrl +

(Expand)  Ctrl -

(Collapse)

Expand/collapse

items under a

selected parent

to level n

Ctrl+n
n=1 to 9. Expands only the current branch to

level n. 0 to expand all

Expand/collapse

all items to level

n

Ctrl+Shift+n

n=1 to 9. Expands the whole grid to level n. 0 to

expand all.

Windows may use Ctrl+Shift+0 to switch

language. If so, this shortcut will not work. See

this link on how to change this:

https://groups.google.com/forum/#!topic/leo-

editor/XqAQ48gE40Y

New item  Ins (Insert key)  (top level, start of grid)

New item (same

level, under

current item)

Enter

When item field has focus or when item is

selected (in other fields Enter acts as F2 -

toggles edit state of field)

New sub-item

(below current

item

Ctrl+Enter
When item field has focus or when item is

selected

New sub-item

(above current

item)

Alt + Enter

Edit / toggle

edit states
F2  

Enter also works in fields other than the Item

Field

When editing: Ctrl + arrows
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Move left and

right by word

Move items up

or down

Alt +

up/down  

arrow

Move items

"up" or "down"

the Hierarchy

Alt +

left/right  

arrow

e.g. select item, ALT + Right Arrow key will

make it a sub-item of the item above it in the

grid

Erase Item /

remove from

grid

Ctrl + E 

Delete (see

comments *)

If the grid context allows to only "remove" the

item(s) from the current Grid view (i.e., the

item's field corresponding to the Grid's source

will be erased) easily and without

compromising user data, a second option is

offered. Otherwise, it's only possible to

permanently delete the item(s) from the

database.

 * Delete will only work as CTRL + E if the full

item is selected. Otherwise, it will delete the

currently selected field's content

Delete field's

content
Delete

Focus has to be on the field(s) to be deleted

(possible to select multiple fields with

ctrl+click, shift-up/down arrows, etc. if the

"multiple columns" selection mode is on).

Important : if "full item" selection mode is on),

delete will work as CTRL+E (erase item)

Split item Shift+Ctrl+S
Split an item into 2 (at the current cursor

point), which is the same as in Ecco

Join items  Shift+Ctrl+J It prompts you for a delimiter to add when

joining the item's text. Use "CR" to get line

feeds.

It joins the item text, but does not delete the

merged items, so to not lose valuable field



values, if present. If desired, simply delete

them.

Popup multi line

editor
Shift + F2

Toggle case of

text
Shift + F3

Will cycle through Caps possibilities (4 states):

The brown cat > The Brown Cat > THE BROWN

CAT > the brown cat

Mark as done Ctrl + M

Switch grids

with assigned

Alt key + # (1

through 9)

Alt + 1...9

After assigning grid a shortcut per 6. Manage

Grids Dialog you may switch to this grid with

the assigned Alt+# key

6.

Manage

Grids

Dialog

#36
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Properties pane keyboard shortcuts

 Shortcut Shortcut Comments

Move to left / right column
Shift-tab Useful when one needs to quickly move

back to the left column to use the “search as
you type” functionality

Expand properties pane section / move to right column Right-arrow The shortcut works differently depending
on the cursor position in the properties pane

Collapse properties pane section / End field editing /
move to left column

Left-arrow

 

Shortcut works differently depending on the
cursor position in the properties pane

“Search as you type”

Any key while
in left column

If in left column, typing a field name will
find that field in the properties pane
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Grid / properties pane  : toggle focus F4 Will also show the properties pane if it’s
 hidden

Show / hide properties pane Shift-F4

Edit field/ End editing
F2
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