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InfoQube User Interface

The InfoQube User Interface is composed of a number of UIs to view items and Dialogs :
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Using Grids (Outliner with Columns)

Grids are the primary method to view and edit the information in your IQBase.

A grid does not "contain" any items (unlike a conventional document or spreadsheet), rather, it displays items, typically a sub-set of all the items

in the IQBase.

Items have a Home, which is where the item was created. If the item was created in grid XYZ, that will be its Home. Details here: Item Home

Grids have Properties:

Which items are displayed

If extra filters are applied (text, date, advanced SQL)

Which fields and tags are displayed as columns

How items are sorted and grouped

Display mode: Outline or flat list

Whether or not the Gantt portion is shown

Background color, tree and grid line types and color

How item fonts and colors are applied

Level-based labeling and formatting styles

1. Creating Grids

There are many ways to create a grid:

https://infoqubeim.com/drupal5/index.php/pierre
https://infoqubeim.com/3802


View > Grids > New Grid

Tools > Manage Grids. Right-click on the grid list and select New Grid...

Click on the + tab

The New Grid / Open Grid dialog will show:

Use the middle area to create a new grid. When creating a new grid:

�. Enter a unique grid name:

If a field of the same name as the grid doesn't exist, it will be created

If a field of that name already exists, the grid will show items with values for this field

�. (Optional) Click Options (...) to:

Set the grid to display existing items. Enter the name of an existing field or #Tag

Copy an existing grid

�. Click OK

2. Opening Grids

Opening a grid to view matching items can be done in many different ways:

View > Grids: Select from the list

View > Grids > Recent Grids: Shows recently viewed grids first

Click the " + " tab (above dialog will show)

Press Ctrl + F to access the Omnibox and enter the grid name

Open the Manage Grids dialog, right-click on a grid and select View Grid (or double-click)

In the Properties pane, click a Grid Group or on a Field that shows the grid link arrow: 

In the Tags pane, double-click on a tag. If a grid is set to show this tag, it will open (otherwise, the Scratch grid will open and show items with that

tag)

View > Home Page and click on a grid
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Grid Display Modes

InfoQube has many display modes to help you manage your information in the most efficient manner

Grids can display items using one of 3 modes:

�. Outline (Normal)

Shows the outline (or hierarchy) of items and sub-items. 

If a parent item does not meet the grid source, it can still be shown (for context) if Grid > Context Parents is set

�. Source items (Flat List)

Sometimes the hierarchy gets in the way. For example when sorting items. A flat list is then very useful. 

Only items meeting the grid source (i.e. source, filter, etc.) are shown. If items have sub-items, a + expand button is shown.

https://infoqubeim.com/3537
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�. Source items (Tree View)

This somewhat hybrid view shows the same list of items as the flat list, but arranged in a hierarchy whenever possible.

To set the grid display mode use one of:

Grid menu > Display Mode section,

Use the dropdown button on the standard toolbar:

The dropdown button icon shows the currently selected display mode

In addition, for each mode, context parents can be shown or not, making a total of 6 displays. We'll look into each of these and their typical use-case.

The sample IQBase has the following items in grids AdrsBook and Calls. To see the various display modes in action, do:

�. File > New > New IQBase with sample data

�. Save the file to a non-protected folder, such as the Documents folder

�. Open the AdrsBook grid (View > Grids > AdrsBook)

Consider the following items shown in the AdrsBook grid in Outline mode:

Notice that eCars AND some sub-items of it have the AddressBook field checked (second column). This is central to understanding the usefulness of

the different display modes



Flat List View

When viewing your address book, you sometimes want to see just your contacts. It is easier to find a contact if other information is hidden (calls,

meetings, notes, etc). 

To view just contacts, select Flat list. All contacts will be shown as top level items, even if they are at a different level in the Outline view. Notice for

example how Albert Sung is now shown at the same level as other contacts.

Another advantage of Flat list view is easy sorting and filtering. Use the Sort Bar to sort and Column filter buttons to filter.

Tree View

When dealing with lots of contact, or when working with many organisations, it can be useful to arrange contacts in hierarchy with companies as top

level item (TLI) and its employees as sub-items.

The flat view hides this hierarchy. To view the contact hierarchy, use the Tree View:

Context Parents

Let's now open another grid, which will show mostly the same items but from a different perspective.

The Calls grid is using CallDate as its source (see the screenshot below: "Items from CallDate").

As seen on the first sample screenshot, the CallDate field has a hierarchy equation and shows the most recent call to a given person and company.

This is convenient for CRM type applications. 

Assuming that CallDate did not have this equation, it would be more difficult to quickly see the call history and know when to call back, etc. This is an

example where context parents can be useful. 

So if you remove the hierarchy equation for CallDate and delete the parent's values, one would be left with CallDates for just the actual calls

Shown below is the Calls grid, in Flat View (which shows all items that have a CallDate value):

https://infoqubeim.com/drupal5/index.php?q=node/864
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This list is perfectly sorted, showing most recent calls first. What is missing is context information, that is "Who was called". To show this, the

ItemParent field could be added in the grid. The information is also available in the Properties Pane. Alternatively, one can show Context Parents:

In this view (Flat View with Context Parents), the list is still perfectly sorted (CallDate, decending) but with the immediate parent shown (Up to 9 levels

of context parents can be shown).

Notice that because of the sort, the same contact is shown more than once (e.g. John Doe is shown three times).

When actually calling John Doe, it would certainly be more convenient to see the calls to that person grouped together, such as shown here:

In this view (Tree View with Context Parents), calls to each person is still shown in the right order (most recent first), but grouped by person. The

person's phone number is shown to speed things up ! Multi-level Context parents are also shown since sometimes only the phone extension is

entered, so having the company main number is handy (e.g. see Mary Smith).

Each view is complementary and aims at helping you be more efficient at managing your information !

Notes:

�. Context parent displays the main parent. If an item has multiple parents, other parents can be viewed in the properties pane (and a single-

click on a parent will display it in the Scratch grid). 

The main parent is changeable in the properties pane by right clicking on a another parent (if available, in the parents section) and selecting "Set

as main parent".

If you change an item's parent, the changes won't be reflected in grids and other outline UIs. Press F5 to refresh the display

�. The Context parent is a dropdown. Choose between (none) and 9 level deep. Setting to 1 shows only the immediate parent for example

�. To view sub-items which may be hidden use: Item > Show all sub-items (or Ctrl + Click on the outline/hierarchy bullet in the grid)

Grid settings may hide "non-relevant" sub-items, such as those not meeting filter criteria (items marked done for example)

https://infoqubeim.com/drupal5/index.php?q=node/66
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Outline Labels

Outline Styles and Labels provides a quick way to automatically format your outlines.

With Outline Labels, heading items get numbered automatically based on the item hierarchy level (i.e. heading level) and any change in the hierarchy is

immediately updated:

1- Managing Outline Labels

The Manage Outline Labels dialog is used to define labels:

https://infoqubeim.com/drupal5/index.php/pierre
https://infoqubeim.com/drupal5/?q=node/3489


The left pane shows the list of defined label sets

Right-click to Add / Delete label sets

Click the down arrow to Add / Delete / Import / Export sets

Click OK to save or Cancel

The right pane is used to modify the properties of the current set:

Name

Format

1 or more items per level can be shown in the Live-Preview

2- Specifying the Labeling Format

The labeling format uses a simple defining string: 

Each level is defined using the following flags RP[F]S and separated by | (a space, vertical bar, another space)

R: Indicated the level is recursive, 1 character, optional

Uses the label of the parent level as a prefix to the current level

The suffix characters of the parent level are not included

P: Prefix before the numbering. 1 or more characters, optional. Can include formatting and icons.

[F]: Format code, optional, 1 of the following characters, enclosed in square brackets:

1: Numeric

a: Alphabetic

A: Alphabetic, capitals

i: Roman

I: Roman, capitals

S: Suffix, 1 or more characters, optional. Can include formatting and icons.

The format text box is similar to the Popup Editor. Right-click to format and add icons:

https://infoqubeim.com/drupal5/index.php?q=node/142


3- Using Outline Labels

Using outline labels is really simple:

Use Grid > Outline Labels menu (or toolbar dropdown button) to select the label or "(none)"

Use this to instantly switch between different types of labels (see section 5 below for sample)

3.1 Heading vs Normal Items

When using InfoQube as a writing tool, it is important to distinguish between Headings and paragraphs (i.e. actual content):

Use the H or N command buttons to toggle between the two states

(an item is either a heading or a normal text item, never both)

By default, all items are Headings

Adding an item after a paragraph (normal item) creates a new paragraph

How Heading / Normal items affect Outline Labels

The rule is very simple: Only Heading items get outline labels

Details here

4- Import / Export Outline Labels

Click the down arrow to import / export label sets

4.1 Export

https://infoqubeim.com/4335


A dialog is shown to select export of the current label set or all label sets:

Select the export file name as click Save

4.2 Import

Select the import file and click Open

Selected file must come from a previous Export, from the current IQBase or from any other one

If a label set has the same name as an existing one, the existing one will be replaced by the new one.

5- Sample Outline Labels





Notes :

Outline labels can be combined with styles. More info here on using Outline Styles

To make a copy of a label set, simply save it under a different name

The [F] format specifier is actually optional. If not present, the labels will be shown but not numbered, hence will be the same for all items (of that

level). 

This can be used to add bullets and other formatting (i.e. such as back color) to all items or items of any given level (such as red for level 1, blue

https://infoqubeim.com/3489


for level 2, etc):
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Outline Styles

REMINDER

InfoQube supports Rich-text formatting for grids, items and the HTML editing pane.

Editing in the HTML pane is similar to word-processors. See 4. Document Pane.

In grids, formatting is structured as a hierarchy. In increasing order of precedence,

these are:

�. Overall default font: set in Tools>Options>General>View: Grid font and Grid

font size settings

�. Grid specific font: set in Grid>Properties>Options: Default Font

�. Item format: Applies to the whole item or to specific columns. See Item

Formatting.

�. Outline style. See 3. Outline Styles

�. Embedded format: See Embedded Formatting

�. Conditional format. See Conditional Formatting

Outline Styles and Labels provides a quick way to automatically format your outlines.

With Outline Styles, the font face, size, bold, underline, color, etc are automatically set based on the item hierarchy level (i.e. heading level) and any

change in the hierarchy is immediately updated:

https://infoqubeim.com/drupal5/index.php/pierre
https://infoqubeim.com/64
https://infoqubeim.com/219
https://infoqubeim.com/3489
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https://infoqubeim.com/drupal5/?q=node/3825


Combined with Outline Labels, this provides great visual feedback when writing many types of documents.

1- Managing Styles

Styles are just regular items with the field OutlineStyles checked.

To manage styles, the simplest way is to create a grid with OutlineStyles as its source:

The OutlineStyles grid can be renamed Styles if desired. IQ will search for either of these grids to manage styles

If such a grid does not exist, it will open the Scratch grid and show the style items.

To create styles, create a hierarchy of items

The first level is the style name

For other levels, the actual item text is not used. Using Level x is a good choice

Use the formatting toolbar to format each level

All item level formatting are allowed:

Font face and size

Bold, italic, underline, strikethrough attributes

Text foreground color

Item background color

Using Copy / Paste, one can transfer styles from one IQBase to another

https://infoqubeim.com/drupal5/?q=node/3825


In this example, 3 styles are defined: First Level Bold, Standard and Fancy. 

2- Using Styles

Using styles is quite simple:

Use Grid > Outline Style menu (or toolbar dropdown button) to select the style or "(none)"

Override Item Settings allows to choose from:

Checked: Outline style is applied to all items. Grid and Item formatting are completely ignored. 

Unchecked: item format merges grid, item and style formats

2.1 Heading vs Normal Items

When using InfoQube as a writing tool, it is important to distinguish between Headings and paragraphs (i.e. actual content):

Use the H or N command buttons to toggle between the two states 

(an item is either a heading or a normal text item, never both)

By default, all items are Headings

Adding an item after a paragraph (normal item) creates a new paragraph

How Heading / Normal items affect Outline Styles

The rule is very simple: Only Heading items get outline styles

https://infoqubeim.com/4335


More details here: 2. Export Outlines (Print-ready)

3- Samples

Using such styles it is possible to switch between these 3 views in seconds !

(left: no style, middle: Standard, right: Fancy)

Notes :

Override Item Settings is useful to hide item specific formatting. Useful when printing or sending the outline to a colleague.

When using Outline styles, Zoom in / out may not do anything (if the style specifies the font size). 

Also, item formatting is possible, however if Override Item Settings is checked, the grid will not show the item format of course.

To properly manage styles, avoid applying an outline style to the OutlineStyles grid !

After changes to a style, switch to the grid which uses it and either (1) re-apply the style or (2) press F5 to refresh.

The same item hierarchy can generate more than one style. 

In the above example, if under the Fancy style, the Level 3 item has OutlineStyles field checked, it will also appear in the menu, and it's sub-items

will be used (rename it to something more meaningful if desired)
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Using Grid Columns and Column Sets

When an item is selected, in any of InfoQube's views, the properties pane can be used to view / edit item values and properties. It shows the

information for the selected item.

One advantage of a grid, is that it can show columns which can be used to display and edit item values.

The Column menu (or right-click on a column header) contains commands to work effectively with columns:



1- Column menu commands

�. Show Columns: Toggles the display of columns. When turned off, only the Tree column is show. Ideal when you want to focus on entering text in

the outline

�. Add Columns: Shows a dialog where you can add and remove fields shown in the grid columns.

Current grid columns are shown first, followed by an alphabetical list of all fields

Click Add New to show a column based on a new field

Tabular list supports auto-search, sorting and filtering

By default, only one field can be selected. Right-click to enable multi-select

Drag-drop to reposition columns in the grid

Hint: To add a column to a grid, you can also drag-drop a field to the grid, from:

Properties pane

Field Management dialog

�. Remove Column: Removes the current column(s) from the grid. Supports multiple column selection

�. Column Sets: See below for details

�. Hide Column: Hides the current column(s) from the grid. Supports multiple column selection. A hidden column is still part of the grid, but not

displayed. It can still be used to sort, filter and parameter in conditional formatting. To show a hidden column, use the Hidden Columns

command (below)

�. Hidden Columns: Shows the list of currently hidden columns :

Select a column in the list to un-hide it or "Show all Hidden Columns" to un-hide all

�. Column Header: Change the following column header properties :

Caption: Change the header caption. Headers can be rich-text formatted (bold, etc) and icons inserted anywhere in the text. (uses the

Popup Editor): 

https://infoqubeim.com/drupal5/index.php?q=node/66
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Alignment: Change the column header text alignment (left, centered, right)

Move Left / Right: Move the current column(s) left or right. Supports multiple column selection. Drag-drop can also be used to change

the order of columns in a grid.

Move the header Up / Down: Grids support multiple levels for headers. This is particularly useful for checkbox columns or columns with

long captions :

Group Columns: Select 2 or more columns to group them. Column groups have a + expand / collapse button:

(on the left, the column group is collapsed, hiding the End and Days columns)

If a column is grouped, the Group Column command button will be checked. Uncheck it to ungroup

Ungroup All: Ungroups all grid columns

Multiline Header Text: Header text can word wrap (up to 3 lines high) if the following 3 conditions are met:

�. Grid > Properties > Options > Multiline column headers is checked

�. All columns are at the same level (i.e. Header Up was not used to stack headers)

�. Columns are not grouped (use Column > Header > Ungroup All)

�. Alignment > Left / Center / Right: Sets the alignment for values in this column. This effectively sets the field alignment (Field > Properties), so

any change is reflected in all other grids. Supports multiple column selection.

�. Color: Sets the Field color. The field color is shown on the column header and / or the column cells. Setting in Tools > Options > General >

Grids. Supports multiple column selection. 

��. Width...: Sets the width of selected column(s). Shows the Column Width dialog:

��. Auto Column Widths: When set, the grid will adjust the column widths to fill the available horizontal space

��. Wordwrap: Toggles word wrap for text and dates columns. Setting is grid specific, so for the same field, grids can have a different setting

��. Is Tree Column: Normally, the Item column is used to show the outline. InfoQube however lets you choose any other column.

��. Use WYSIWYG Editor: For text columns, toggles the use of the WYSIWYG editor.



��. Select Column: Selects the current column

��. Show HTML Codes: InfoQube supports HTML-based rich text formatting.

Normally, these are shown in a WYSIWYG way, so codes are hidden, but sometimes it is useful to see the actual formatting codes.

Use this command in such situations. If the WYSIWYG editor is turned off (see below), you can see the codes when editing. Another way is to use

the pop-up editor which can also show HTML codes.

��. Nb of locked columns: Sets the number of locked columns. Locked columns do not scroll when grids are scrolled left and right.

To lock columns, place these on the left of grid and select one or more locked columns. Particularly useful for grids that have many visible

columns.

��. Sort items ascending / descending: Use this command to sort items / sub-items

��. Column Properties...: Displays the Manage Fields dialog. Use this to make changes to fields. Details here

2- Using Column Sets

Each grid has a set of columns, which are typically chosen to best describe the items in the grid. Sometimes however, one wants to see other item

values. The Properties pane can be used for this but as an alternative, it is also possible to load / unload column sets.

This allow a dynamic grid display with easily interchangeable sets of columns. Grid native columns are still available (for sorting and conditional

formatting purposes), but made invisible, except for locked and tree columns (which remain visible, no matter what).

Column sets can come from forms or grids. To learn more about forms, see this page. By default, grids are not shown in the Properties pane, to show a

specific grid, use Manage grids > Options > Show this grid in the Properties pane.

2.1 Loading a Column Set

Use Columns > Column Sets to switch column sets:

The columns in the grid will instantly change:

2.2 Unloading a Column Set

To unload a column set, do one of:

Select Native Column Set

https://infoqubeim.com/1068
https://infoqubeim.com/65


Close the grid

2.3 Saving a Column Set

After loading a column set you can set the grid to use it by default. To do so, do one of:

Click Save Grid with this column set... 

Click Grid > Save

Either way, a dialog will be shown:

�. Saves the grid with the native columns (i.e. before the column set command was used)

�. Saves the grid with columns as displayed. The native columns will be removed (except hidden columns, those stay hidden)

�. Combines both sets of column. The native columns which were invisible (after a column set command) will become hidden columns. Use

Columns > Hidden Columns to show these

2.4 Using the Properties pane to load column sets

Column sets can also be loaded / unloaded using the Properties pane

To load a column set, you can

Drag-drop a form to a grid, or

Right-click on the form or grid in the Properties pane:

Hints:

You can keep some of the grid's native column if so desired. Simply lock then before loading the column set (see below on how to lock columns).

To restore the native grid columns, right-click on the column set (or the Current Grid entry under the Grid heading) and select "Unload Column

Set".

Multiple uses, but in particular, when viewing items in the search or scratch grid, users can then load column sets to view pertinent information.
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Sorting and Grouping Items in Grids

Ordering, sorting and grouping information, so it appears just the way you want, is critical for effective information management. And how

information should be sorted has a lot to do with the type of information:

When writing the outline of a book for example, it is essential to be able to move chapters, sections and sub-sections around. One expects that

once set, the order will not change.

Dealing with an "in box" however is different. New items should automatically appear at the top of the list. Notes under an item should appear as

entered, unless there are many many notes, in which case, some automatic sorting is really useful.

Tasks and other date related items are also typically sorted unless they are tasks under a project.

In project management software, task order is important and somewhat but not completely related to the task date. Gantt chart bars and task

dependencies can influence what the optimal task order is.

For contacts, it must be really easy and quick to filter and automatically sort by name. Hierarchy of contacts (i.e. Company -> Employees) should

help finding contacts, not make it more difficult (See Grid Display Modes).

For accounting entries (revenues, spending, etc) it is important to be able to quickly sort by one or more columns. Filtering and Grouping are

also very desirable.

Sorting Modes

To achieve these seemingly conflicting needs, IQ grids have a number of sorting modes (Grid > Sort):

�. None (Manual)

�. Sort Bar

�. Source Items Sort

�. Group-By Bar

The sorting modes are mutually exclusive, so only one can be active at any one time.

Sometimes you want to sort items and all sub-items while in other situations, sorting should only for the selected level. This is controlled by this

setting:

Sort Items: When this is selected, only first level items will be sorted. Sub-items will not be sorted.

Sort Items and Sub-Items: When this is selected, all items are sorted (items, sub-items, sub-sub-items, etc). 

1. None (Manual)

In manual sort mode, items keep their position:

Only user intervention (commands, drag-drop) can change the order of items.

Clicking a column heading selects the column.

Switching to another sort mode does not alter the manual order. Simply select the Manual mode to the return to the original order.

To move items in the hierarchy, one can select one or more items and:

�. Drag-drop to the new position

�. Use the commands to move items > Move > (up, down, right, left). The keyboard shortcut is Alt + Arrow keys

�. Right-click on a column header and select Sort Items Ascending / Descending to sort items based on values in that column.

Remember that this is a sort command. Hence new items will not sort but appear where positioned. To have grids that automatically sort, use

any of the other 3 sorting modes (see sections 2, 3, and 4 below)

�. Right-click on an item and select Sort Sub-Items Ascending / Descending to sort sub-items based on values in that column

1.1. Moving Items by Drag-drop

https://infoqubeim.com/drupal5/index.php/pierre
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�. To drag-drop, first select items (1 or more)

To select, click on an item text (item column)

You can also select items using Shift and Up / Down arrows

To select non-contiguous items, use the Ctrl key + click

�. To start drag-drop, click anywhere in the selected text (item column)

�. As you move the over the grid, the cursor will show a horizontal red line between items. This is the position that the selected item(s) will be

moved.

Also, depending on where you are on the grid, the selected item(s) will be at the same level and the drop position OR as sub-items of these:

�. If dropped in the right half of the item column, these will be sub-items. The cursor reflects this

�. Anywhere else, these will be sibling items (default)

�. If over the selected items, a "No-drop" cursor is shown

�. Once drag-drop has started, hold the Ctrl key to leave the items where they are AND add a reference elsewhere in the grid or another grid. Use

this when you want to have multiple parents.

1.2. Moving Items using the Move Commands

�. Select items (see section 1.1 above)

�. Press Alt + Up / Down / Left / Right arrows to move items (or use the Item > Move commands)

�. The Item Move commands are in a detachable mini-toolbar. Drag the dotted line above the commands to rip it off the main menu. Once floating,

you can dock it anywhere if you wish

�. Move commands limit movements to the item's hierarchy level, so you cannot move an item to be a sub-item of a different parent. This is by-

design

Do do this, use Drag-drop, or :

�. Move it left (1 level up in the hierarchy)

�. Move it up / down, so it is just below the new parent, but at the same hierarchy level

�. Move it right

1.3 Using Column Sort Commands

Items can be sorted using the column menu or the column header context menu. Select Sort Items Ascending / Descending :

The list will sort based on values in the selected column

If Grid > Sort > Sort Items and Sub-Items is checked, sub-items will also sort (recursively, for all loaded sub-items)

If Context Parents are shown (Grid > Context Parents), these will be sorted too. If this comes in the way of the desired sort, turn context parents

off first

If the item hierarchy comes in the way of the desired sort, change to a different display mode. See 1. Grid Display Modes for details

If the Sort Bar is shown (see section 2 below), the Sort Bar sort is applied first, followed by the requested column sort (i.e. the Sort Bar has

priority)

1.4 Using Item Sort Sub-Items Commands

Sub-items can be sorted using the item context menu. Right-click on an item cell and select Sort sub-items Ascending / Descending :

Sub-items of the current item will be sorted based on values in the selected column. e.g. :

To sort sub-items by item text, right-click on the current item text column

To sort by "Priority", right-click on the "Priority" cell of the current item

If Grid > Sort > Sort Items and Sub-Items is checked, sub-items will also sort (recursively, for all loaded sub-items)

2. Sort Bar

The Sort Bar provides a familiar, quick and easy way to sort items:

To sort using the Sort Bar, simply drag a column header from the grid to the Sort Bar. A button will appear with the field name. The button is

visually identical to the column header

To change the sort order, click on the Sort Bar button

To remove the sort, drag out the sort button from the bar

https://infoqubeim.com/261


You can drag more than one column header to the sort bar:

When sorting on more than one field, sorting is done from left to right. So items are first sorted according to the left-most field in the bar.

If 2 or more items have the same value, these are then sorted according to the second field in the bar (and so on if sorting on more than 2 fields)

If Grid > Sort > Sort Items and Sub-Items is checked, sub-items will also sort (recursively, for all loaded sub-items)

When sorting using the Sort Bar, users can still manually move items. However, order is not saved

When the Sort Bar is shown, a single click on a column header will sort items. This is a quick way to sort items. By design, this is a temporary sort

and will not persist the next time the grid is opened

You can also perform multi-column sort by pressing Shift while clicking on a column header. Note however than using the Sort Bar simpler to

use if you want to do multi-column sorting 

It should not be used for grid showing hierarchies of text items, such as a book outline, but if you do, and the item order was changed, simply

switch back to None (Manual) to view the original outline

Hint:

At any time, one can manually move items for a specific need, using the methods given in section 1 above

Context parents are great for giving context, but they can sometimes be in the way for proper sorting. Turn off Context Parents or changing the

parent level shown if need be. See 1. Grid Display Modes for details.

You can use the build-in Order field to achieve custom sorting. Simply show this field in the grid and enter values for each item. You can then

sort by this field. To quickly enter values, you can use the Edit > Renumber Items command

3. Source Item Sort

The Source Item Sort can also be used to sort items. In many situations, it will have the same result as using the Sort Bar. But there are times when the

two will differ, which can be very useful. Specifically:

�. The Source Item Sort is done at the database level (as its name implies)

�. If sorting by a text field, such as the item text, embedded HTML code are part of the sorting (so items starting with bold text will appear first, due

to the <b> tag)

�. Sorting is done before context parents are added. This ensures that context parents do not affect the sort result. The Sort Bar will always be

impacted by context parents

�. The sorting fields do not need to be shown in the grid. The Sort Bar requires the sorting field be part of the grid (it can however be minimized or

hidden)

�. Sort strings can be named and support different sort for sub-items. Format: SortName: Sort string | Sub-Item Sort string

�. For each grid, the history of sort strings is saved and can easily be re-used. See section 3.1 below

3.1 Using the Source Item Sort

�. Source Item Sort is done though the Sort Box, which is part of the Source Bar. Grid > Source Bar shows / hides the bar.

�. To sort, enter a comma separated list of fields.

�. For multi-field sorts, sorting is done from left to right (same as described in the Sort Bar section). e.g. Field1, Field2, Field3

�. After each field, the order can be specified: ASC or DESC, for ascending or descending order. e.g. Field1 ASC, Field 2 DESC

�. If no order is specified, ASC is assumed

�. Just left of the Sort Box, is a button to control the Sort Box behavior. These mimic the corresponding sorting menu commands:

�. Sort On / Off

�. Sort Items

�. Sort Items and Sub-items

�. The Source Item Sort command button shows the list of recently entered sort strings for this grid. You can select an item from this list to quickly

apply a specific sort:

Select an item from the list to quickly apply that sort.

�. Examples
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�. Sorting Priorities with empty ones at the end: The default IQBase uses descending priorities (1=lowest), partly because this sorts blank

ones at the end (as it should). If you prefer using 1=Top, use this source sort string instead:
[Priority] is not null, [Priority]   

4. Group-by Bar

The Group-by bar is similar to the Sort Bar (section 2 above) but goes a step further by grouping similar items. Group items can be expanded /

collapsed, just like regular items.

Consider the following grid:

By showing the Group-by bar and dragging the Reviewer column to it, one gets:

Notice how reviews are now grouped by Reviewer.

Notice also that John Dow's reviews are now collapsed. This is useful to hide some items and focus on others. Use Item > Sub-items commands to

open / close items

Of course, similar things can be achieved with filters, but having more ways to slice and dice your information is what InfoQube is all about !

Tips:

�. You can combine a couple of sorting methods to ease the process. For example, use column sort or sub-item sort to do the bulk of the work and

Item Move to make minor adjustments

�. By using a "myOrder" column (text or numeric), you can quickly apply a sort.

If you have more than one such column, you can toggle between 2 sorts instantly. 

To populate such a column, you can use the Renumber Items command

Pierre_Admin 2009/07/05 16:46

56 views

6. Manage Grids Dialog

6. Manage Grids Dialog

Manage Grids Dialog

The Manage grids dialog is used to view / edit / delete grids.

To open the dialog, you can:

Use Tools > Manage Grids...

Right-click on a workspace tab and select Manage Grids...
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The dialog is divided into left and right panes:

1. The Left Pane

Left pane shows the list of grids, also shown are:

The grid source (i.e. which items are shown in this grid)

Keyboard shortcut key (Alt + number)

Whether to show or not the grid in the grids list toolbar

Date the grid was last opened

Grid ID, a unique number identifying the grid

The tabular list allows auto-search, sort and filtering of the list:

Auto-search: In the Name or Source columns, start typing to find a grid

Sort: Click any column header to sort

Filter: Click on the column header filter button to filter the list of grids shown

(e.g. to filter out system fields, enter ">200" in the ID column header fitler)

Drag-drop grids from one position to another

Right-click on items in this list to:

Create a new grid

View the selected grid (i.e. open the grid)

Copy the grid. Once copied, you can:

Paste it as a pane (dashboard-type grids)

Paste the grid format, from one grid to another

Paste hyperlinks to grids

View the list of columns

Save the list of columns as a form (see 4. Forms)

Delete the selected grid

Save the order of grids
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The left pane support multiple selections. This is useful to

Open multiple grids at once

Delete multiple grids

Copy multiple grids. In a grid, do Edit > Paste Special > IQ View to create items that will be hyperlinks to grids

At the top there is a Filter button and text box. Enter text to field list. Shortcuts are Ctrl+F and Ctrl+G

2. The Right Pane

The right pane shows the properties of the selected grid (left pane).

The pane is divided into the following sections:

�. General

�. Data

�. Gantt Chart

�. Options

2.1 General

�. Grid name: 50 characters max. All characters are valid except  " . | ~ * !  ̀? [ ] . Cannot start with a number

�. Description: 255 characters max.

�. Groups: Enter the list of groups this grid belongs to (comma separated). See 7. Grid Groups for details

2.2 Data

�. Source: Field or SQL defining the items to show in the grid

�. Auto-assign field list for all top level items: Based on the grid source, this give the (read-only) list of fields that will be automatically assigned

a value for all Top Level Items (TLI) in the grid

�. Keep source field values when demoting TLI: When an item is moved from TLI to a sub-item, should the automatically assigned value be kept

or not

Date fields always keep their value

Number and Text field always keep their value unless they have were automatically assigned (" " for text and 0 for number fields)

�. Auto-assign field list for all items added in this grid: Comma separated list of fields

�. Tag inheritance Depth (0-9, -1=All): When tags are used in grid source and/or filter, sets the tag inheritance depth. See 3. Tags

Defining the Grid Source

Together, the Grid Source and the various filters specify what items are shown in the grid. Items displayed in the grid will be those that meet both the Source and the filters. See 2.
Filtering for detailed information on filtering. The following helps understand how grids determine what items are shown:

When a Grid is first created its Source is set to be the field that matches the Grid's name (unless specified otherwise in the New Grid dialog)
When the Source has only one field then any new top-level-items created in the Grid will automatically have a value for this field. The grid is said to have a "Simple Source"
If the source field name(s) contains spaces or other special characters, it needs to be enclosed with [  ]

Source and Filter are kept separate so you can keep the Source constant as you tweak the Filter. Also, the Filter can be turned On / Off which is not the case for the Source 
 

Sample Grid Sources

[Address Book]: All items with the field Address Book checked

[Address Book] AND Archived is Null: Shows un-archived contacts

Project = "Somiro": All items that have the value "Somiro" in field Project

Item like "*InfoQube*": All items with the text InfoQube somewhere in the item text

More examples here: Source Filter Editbox

2.3 Gantt Chart

See Gantt Chart Properties for details

2.4 Options
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�. Tab Color: Color of the tab. Same as right-click on a Tab > Tab Color

�. Grid Background Color: Overrides the setting in Tools > Options

�. Default Font: Grids use the font specified in Tools > Options unless specified here. Format: Font Name | Font Size

�. Grid Line Properties: A set of grid line settings. Overrides the same setting in Tools > Options

�. Maximum item height: In pixels, 0=none

�. Show Done Check Mark: Show / hides a checkbox on the tree column to mark items as done

�. Show Hierarchy on the # column: If checked, the # column will show the item hierarchy (i.e. 1.3.2), otherwise a flat list of numbers

�. Shortcut (Alt + ): Enter shortcut key. Valid is 1 through 9

�. Multiline column headers: If checked, the grid header caption will word-wrap (up to 3 lines high, and only if columns are all at the same level

and not grouped)

��. Column(s) showing the text font/color: By default the item font is applied to all columns. Enter a comma separated list of fields to limit this

(use # for the first column)

��. Column(s) showing the item color: By default the item color (i.e. background color) is applied to all columns. Enter a comma separated list of

fields to limit this (use # for the first column)

��. Is the XXX grid: There are 3 special grids in InfoQube. Scratchpad, Search results and In-Box.

��. Grid auto-updates: Grids auto-update is improving with every InfoQube version. Currently:

Grids automatically update on item field values changes and on item deletion

This flag only affects items added elsewhere (in another view or in another instance of this grid). If the flag is set and the new item meet the

grid criteria, it will be added

If auto-update is checked, the grid will also background load sub-items under collapsed items (when the display mode is Outline)

��. Grid visible to other applications: IQ uses Microsoft Jet 4.0 as its database engine. If this flag is set, a visible query will be generated which

enables other applications, such as MS Word or Excel to view the items in the grid (read-only).

What these applications will see is however not the outline (since they do not support this), but rather the same list as the Grid > Display Mode >

Flat List

��. Show this list in the Properties Pane: If checked, the grid and its columns will be listed in the Properties Pane, under the Grids heading.

With the grid columns visible in the Properties pane, it becomes like a form (see 4. Forms for details)

 3. Saving changes

Changes to grid parameters are buffered, so nothing is saved until you press the "Save" button. If you close the dialog without saving a dialog

appears:

n.b. When grids are created, a matching field is often created and used as the source of items (i.e. determines what items are shown in the grid).

�. If the bottom checkbox is checked, this field (i.e. the field with the same name as the grid) will be deleted. It will not be possible to re-create a

similar grid with the same items (unless some other property is common to all those items)

�. If the bottom checkbox is unchecked, the field will not be deleted. It is then possible (and easy) to re-create a new grid showing the same items

as the deleted one
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Gantt Chart Properties

Grids that show a Gantt chart have an additional section in the Manage Grids dialog:

1 Start Date Field
Date field for the start of the bar. May be empty if the End Date field is not empty, in which case, all bars will be

milestones

2 End Date Field
Date field for the end of the bar. May be empty if the Start Date field is not empty, in which case, all bars will be

milestones

3 Duration Field Calculated duration (End - Start) will be saved in this field

4 Percent Done Field
If not empty, a Percent Done bar (black line, vertically centered) will be available. To change, either edit value or

hover near the bar start until tbe icon changes to %>

5 Bar caption field
If not empty, a text string will be shown just right of the bar and move with it. Could be any text field, typically it is a

note field or the item field

6 Effort (in days) Field Used to compute the histogram

7 Bar color field Field to save item bar color (custom color)

8 Bar default color Color of all bars that don't have custom colors

9
Overview shows

Gantt bars

The Overview is a re-sizable navigation pane, shown above the Gantt. Select this to show miniature Gantt bars in this

pane

10
Overview shows

Gantt date range
Toggles the display of the current Gantt viewing window

11 Show Histogram Toggles the display of the Histogram. The Histogram is displayed below the Gantt and can display resource loading

12 Non working Days
Picklist of days which are non-working. Non-working days are used in duration calculation, so if non-working days

are Sat and Sun, a 3 day task which starts on a Friday will finish on Tuesday

13 Non working hours Similar to non-working days
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7. Grid Groups

Grid Groups

As your information in InfoQube grows in size, so will the number of grids (typically used to show this information).

It is possible to group grids and show these groups in home pages and the Properties pane. 

Examples of groups could be:

Projects at work, each project specific grids, plus some general ones can be grouped

Home related info

If the IQBase is shared with other family member or office co-workers, users can select which grids are pertinent to them
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1. Grouping Grids

Groups are easily managed using the Grid management dialog:

In General > Grid Groups, enter the list of groups that each grid belongs to (comma separated list)

For example, grid Invoice could have the following groups: Somiro, Projects, John

For every grid that you want in a group, enter the group name in the grid properties

For example, if you want group Somiro to include grids Invoices, Projects and AdrsBook, ensure that these 3 grids have Somiro (along with other

groups if desired) in Other > Groups

That's it. Groups are automatically generated, based on the values entered.

2. Using Grid Groups

Grid groups can be used in home pages and in the Properties Pane

2.1 Grid Groups in Home Pages

As described in here, to list grids in a group, enter the following token:

[GridGroup:Somiro]: All grids that belong to grid group Somiro

You can also show all grid groups, using the token [GridGroups]

2.2 Grid Groups in the Properties Pane

Grid groups are listed under the Grids section of the Properties pane:

Click on a grid to open it

Right-click to show the context menu to (1) Open all grids in a group or (2) Close all grids in a group

Hints :

Dashboards can also be used to group related grids in a single view, the advantage being that all UIs (grid, surface, calendar, etc) all open at

once

It is also possible to create a "Grids" grid, where each item is a hyperlink to a grid. This provides endless possibilities to arrange grids in

hierarchies. To quickly create such items, do

�. Tools > Manage Grids > Select one or more grids > Right-click > Copy Grid

�. In a grid, add a new item and do Edit > Paste Special > InfoQube View
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Sub-Views

IQ also has other means to view your data. These views are called sub-views as they are alternate display of grids. That is, one typically opens a grid

and then selects an alternate view:

�. Card View

�. Map View

�. TimeLine View
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�. Pivot Table View

�. Pivot Chart View

These sub-views are linked to a given instance of a grid. This means that if you have 2 instances of a grid opened, showing different sets of items (with

say different filters), each sub-view use the items in those grids. For Pivot tables and charts, note however that to have multiple pivot for the same

grid, the source of items must be set to "Use Items displayed in the grid" (and not "Use items from the grid source")

Pierre_Admin 2017/03/24 01:42

74 views

Card View

Card View

Using Card View

Card views show items as familiar 3 x 5 index cards on a large desk-like 2-D surface

1. The UI

Card view is an infinitely sized surface

The view shows items as resizable cards

The view is divided into 4 quadrants

Commands can be performed for a specific quadrant or for all 4

Right-click to select commands

Each grid can have a Card view

By default, the view opens as a workspace tab. The tab can however be detached and turned into a floating pane 

(as shown in the above screenshot)

2. Items as Cards

To add existing items on a Card view, simply copy / paste them from any grid or other view

Items can also be added using drag-drop by dropping items on the large + button

To create new cards, click on the large + button or press Insert

Items shown on the Card view are loosely linked to items shown in the corresponding grid:

Items created in Card view are automatically added to the grid
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Items added to Card view using copy / paste are not added to the grid

Items created in the grid are also added to the Card view but only if the Card view is not empty

This means that opening a new Card view will be empty, e.g. not show items in the grid

Copy / paste those items you want to see

3. The Cards

Cards have two sides:

Side 1 shows the Doc pane content

Side 2 shows the item text and selected item values (Notes, URL)

Press the space bar to switch sides

Side 1 has Preview and View modes:

Preview mode shows the text content of the Doc pane

View mode shows the actual Doc pane content (WYSIWYG)

All document types are supported (HTML, MHT, PDF, XLS, etc)

Press F2 to toggle view mode

When in switching from Preview to View modes, card size is increased by 50%

To edit Cards, use the Item Editor (Ctrl+E), the Doc pane (F6), or the Properties pane (F4)

To resize cards, drag a border or use Ctrl+Arrows

To move cards, click the header and drag or use Alt+Arrows

Item back color is shown on the card caption

4. Using Card View

Cards can be piled (i.e. stacked) or spread on the surface

Piled cards are shown so the card title (i.e. the Item name) remains visible

Click on a card to bring it to the top of the pile

To move the view point, click and drag an empty space or use Left/Right/Up/Down arrows

Spread cards will auto-arrange cards in the selected quadrant

When moving cards, the view can move other cards depending on the Overlap mode:

If Overlap is On (default), moving a card will not move other cards

if Overlap is Off, moving a card will move other cards

Press Ctrl+Shift to toggle Overlap mode

To select multiple cards, use one of:

Hold Shift and click-drag

Ctrl+click on cards

Right-click > Select All / All in this quadrant

Press Ctrl+A: Will first select all cards in the current quadrant. If these are all selected, it will select all cards. If a filter is applied, only non-

filtered cards will be selected

Copying cards from one Card view to another is as simple: 1- Select cards  --> 2- Copy --> 3- Switch to another Card view --> 4- Paste. Similarly,

items from any view (grid, calendar, etc) can be copy / pasted to the Card view

Zoom in / out using commands and touchpad gestures

Home key moves the Card view to show all quadrants and sets the zoom to 100%

End key zooms to show all items

Shift+Home/End sets the zoom to 100% (but does not move the view point)

Delete key removes cards from the view. Items are not deleted

When removing cards, if some items are locked, a dialog will show. Lock items to quickly clean up your Card view while leaving a set of items as

"permanent" cards

Ctrl+D deletes items (and hence cards) permanently

4.1 Context Menus

On one of more cards, the context menu shows the following commands:

�. Toggle Preview / View: View is a WYSIWYG display of the Doc pane content

�. Flip Card: Flips between side 1 and side 2

�. Edit Card: Open an Item Editor for each of the selected cards

�. Pile Cards: Pile selected cards

�. Copy

�. Remove Item: Selected items are removed from the Card view. Items are not deleted from the IQBase. Use Edit > Undo to undo this command

�. Set Default Size: Current card will be the default size for new cards (new item or pasted items)

 On a blank area of the surface, the context menu shows the following commands, for all cards or just those in the current quadrant:

�. Pile cards
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�. Spread cards

�. Select all

�. Switch all cards back to Preview mode

In addition, the following commands are also shown:

�. Move Selected Cards to this Quadrant: Use this command to group cards spread over the surface into a neat pile

�. Paste (enabled if there are items in the clipboard, do Edit > Copy to put items in the clipboard)

Pasted items will appear as cards in the current quadrant

If a pasted item is already in the view, in another quadrant, a dialog is shown to move it or not to the current quadrant

�. Remove items. If some cards are filtered out, the dialog lets you choose what cards to remove

�. Sort Cards by: When piling / spreading cards, determines the order of cards

Enter a field name or leave blank to manually arrange cards in each quadrant

�. Background color

5. Filtering Cards

Press Ctrl+G to show the filter text box

Enter keywords in the filter text box (top-right corner) to only show matching cards

Match includes both sides of the card

Match count is shown

Show / Hide the filter text box (Ctrl+G) also toggles the filtering

When filtering, press Esc or Enter to move focus back to the cards

Filtering can also be by tag: Enter #TagName

 6. Managing Card Views

Card views are sub-views of grids. This means that each grid can have a card view. To get the list Card views:

Use the View > Card Views command

Menu will show a list divided in 3 sections

�. Card views currently shown in tabs and panes (bold = loaded)

�. Other Card views that contain cards (i.e. items)

�. All other Card views (e.g. those that are currently empty)

To create a new Card view, first create a grid with that name and then do View > Sub-views > Card View

7. Tips and Tricks

Ever wanted to view many folders at once? Simply create a few items, set the Doc pane to point to a folder and put these items on a Card View.

Select the cards and press F2 to enable view mode and voilà !

Notes:

�. Having too many cards will show down scrolling, in particular if many are shown in View mode (WYSIWYG)

�. If using Enhanced Scaling (to improve font quality, options > 1.6.18), Zoom needs to be 100% (or close to) to properly display card content
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Map View

Map view is an alternative display to grids. Open a grid, select an item and do View>Map View:

Grid View Map View
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Map View shows a central item, its parents and it children (sub-items)

Layout is automatic (as opposed to the IQ Surface, which is more of a 2-D free-form sheet where items can be placed)

Double-click to open the Popup Editor to edit the item text

Shift+double-click to explore from the selected item

Item parents are shown above the explored item.

Right-click on an empty to select overall layout to toggle between Horizontal and Vertical layouts

Right-click on an item to toggle between Normal Fan-out and Vertical Tree layout:

Normal Fan-out Vertical Tree

Properties and HTML panes are enabled to view / edit other item information

Icon shown to indicate that the item has HTML content or linked to a web page (separate icons for each)

Item rich-text is shown

Item backcolor is shown

The Item dropdown menu is available to add / remove / modify items and sub-items with the same keyboard shortcuts as grids, namely:

Insert key to add a first level items

Enter to add an item at the current level

Ctrl + Enter to enter a sub-item

Supports Drag-Drop to move an item from one parent to another

Ctrl+Wheel: Zoom in / Zoom out

See also: Concept Maps
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Using Pivot Tables and Charts
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If Microsoft Office 2002 and up is installed, InfoQube can use the built-in Pivot Tables and Charts.

For Office 2007 and up, please install Microsoft Office Web Components from here.

(more to come !)

Other resources:

Great video on using Pivot Tables and Charts in Excel: https://www.youtube.com/watch?v=9NUjHBNWe9M
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Dashboards

Dashboards

Dashboards are grids which have a fairly large number of panes. They can serve many uses:

Window showing all aspects of a project

Multi-view of most common information, all in a single window

Kanban-style task management

GTD task management

1. Kanban-style task management

In a Kanban board, activities revolve around dragging items from one pane to another

Dragging items from one pane to another automatically sets field values, such as Active, Next, Done (date)

Grids support sorting, either manual or based on field values (such as DueDate, Priority, etc)

InfoQube makes it easy to drag-drop items and even supports dragging many items at once

2. Book review process example

Read all about it here
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Gantt Charts and Project Management

When it comes to Project Management, InfoQube is not as sophisticated as specialized tools like Microsoft Project or Primavera, but it nevertheless

provides extensive project management tools. One of which is sophisticated Gantt charts:

Being fully integrated with the rest of InfoQube, its Gantt Charts are in some ways even move useful than those of the "big guys" !

1. Gantt Specific Features
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�. MS Project look

�. Multiple Gantt charts per IQBase (related or unrelated)

�. Customizable time scale, from hours to years

�. Configurable to use "stock" fields or your own set of fields

�. Task Start, Task End, Percent Done fields

�. Option to use Bar Caption, Task Effort, Bar Color fields

�. Optional Overview to show the whole project, for easy navigation

�. Optional work load profile below the Gantt

�. Non-working days support. Either shown in grey or hidden from view.

Tasks duration is maintained (So a 3 day task will take 5 calendar days if it crosses a week-end for example)

��. Arbitrary non-working days: Set any day as a non-working day (i.e. statutory holidays)

��. 3 bar types: Task, Milestones, Summary

��. All standard Task Link types (dependencies): FS (default), SS, FF, SF (See Wikipedia def.)

��. Full support for Lags between tasks (+ve and -ve lags). So a task can be set to start 2 days after another one completes, or 3 days prior

��. Inside-Zoom and Zoom-on-Fly to show more details for certain tasks:

��. 3 modes to manage linked tasks: Visual display only, Enforce Task Dependencies, Locked

��. Show / hide link lines

��. Option to freeze started tasks, so they cannot be moved

��. Automatically rearrange tasks based on tasks, links and lags to calculate the earliest delivery (PDM / CPM optimization)

��. Critical Path display: Find where the bottlenecks are to deliver on-time:

��. Compact TimeLine view to quickly see what should happen when:

2. It's a Grid too, so...

Being a standard grid, all of these can also be used to optimize project management:

�. Unlimited number of columns
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�. Unlimited number of sub-items

�. Multiple Parents

�. Filter by any column

�. Hoist specific items

�. View tasks in other grids

�. Print Preview

�. Save as PDF, Image

3. Tasks are items

Each task is just an IQ item, so like any other item, you can:

View task start and task end in the Calendar, color coded (green=start, red=end)

Late or near late tasks can change color (see the built-in Urgency field). This color code is shown everywhere in IQ, not just in the Gantt

Add associated rich text notes, Web pages, Drawings, Ink documents, etc. in the Doc pane

Perfect for brainstorming, design notes and other handwritten content. Details here: Using Ink Documents

And the Ink editor now supports real-time remote multi-user collaboration (web server based)

View the whole project, or sections of, on the new 2-D IQ Surface !

4. Multi-User and Dropbox Sync Ready

Finally, IQ is multi-user ready when used in a LAN environment, so it supports team work.

And with Dropbox-sync, you can have your projects at work and at home.

5. How-To:

Create a bar: 2 ways:

On an existing item, enter a value for the task start and / or task end fields

In the chart area, click and drag from the start to the end date. If done on a blank area of the chart, a new item will be created

Create a milestone: Clear the task end date or set it to the start date

Create a summary bar: Right-click on an existing bar and select "Is Summary Bar"

Link 2 tasks: 2 ways:

Enter a taskID in the NextTaskID field
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Click on the first bar and move down to the second bar. A dialog will be shown:

Select the link type and lag

Uncheck "Show this dialog" to automatically created a FS type link

Delete a bar or a milestone: Click to select 1 or more bars / milestones. Right-click and select Cut (or press Delete)

Move bars: Select 1 or more bars and:

Click and drag to a new position

Press Alt+Left/Right arrows to move by 1 day

Delete a link:

Delete the value for the field NextTaskID

Right-click on the link and either select Delete Link or use the Link Properties dialog and click Delete

Change the bar color: Right-click on a bar and select "Bar Color"

Change the Gantt Scale: Any of:

Drag the Zoom scrollbar in the Gantt menu

On the Overview bar, click on one of the scale button

Ctrl + Mouse wheel while over the chart

Drag the top level separator line left / right (=zoom out / zoom in)

Show the Zoom-on-Fly window: Press Ctrl and Shift and hover over a bar

Set a day as non-working: Right-click on the day in the chart header and select "Is a non-working day"

Move the focus between the Grid and Gantt panes:

Shift+Alt+Right arrow moves focus to the Gantt

Shift+Alt+Left arrow moves focus to the Grid

Scroll the chart: Use any of the following methods:

Shift + Mouse wheel while over the chart

On a precision touchpad, two-finger swype left / right

If Gantt > Auto-Scroll is On, simply select the task. The chart will scroll to show it

Double-click in the chart area of a task. Chart will scroll to show it

With focus on the chart, use Left/Right arrows to scroll

With focus on the chart, use Ctrl+Left/Right arrows to intelligently scroll from task to task in chronological order

A vertical line is drawn in green for task start and in red for task end

The status bar show the number of days between tasks

Press Escape to return to the blue vertical indicating the current date

Bar start and end dates, duration information:

Shown on the main status bar. Click a bar to view it

Shown as a tooltip on mouse over while holding the Ctrl key. 

6. Notes

InfoQube also supports non Gantt-based task dependencies. See 2. Task Dependencies for details
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2. IQ Calendar

Using the IQ Calendar

The IQ Calendar is like no other because of its feature set and deep integration with other InfoQube's components.

With it, you'll be able to view and edit date related items and tasks in the familiar calendar metaphor.

The Calendar provides you with day, multi-day, week, month and year views.

The left panel show a mini-calendar, current events and the list of available calendars:

The IQ Calendar Concept

The IQ Calendar concept is similar to other calendars. This is essential to ensure fluid exchange between IQ and other calendar applications (Outlook,

Google Calendar, etc):

Events can be all-day or have start / end times

Events can span more than 1 day

Events can be repeating

There are however important differences:

Events can be scheduled or not. Non-scheduled events are shown in the upper part of the Calendar, along with the all-day events.

An unscheduled event has a duration but no associated time:

Event duration of the item in hours

Moving the event from the scheduled to the non-scheduled areas preserves the event duration value

The event / item duration field is handled like any other item field values (can be shown in a grid, be used in equations, etc)

Any date field can be shown shown in the Calendar. (by default, the Appointment field is used)

Show Anniversaries and birthdays

Show task due dates

Show project milestones

Show both Task Start and Task End in the calendar, in different colors

etc.

Event date and duration can be modified using grids and the Properties pane

(in addition to drag / move and other Calendar specific actions)

Calendar events are like regular items, so they can:

Have any number of field values

Have rich text content (Document pane)

Be shown in other views (Grid, Gantt, Surface, Map view, etc)

Be arranged in hierarchies:
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Have any number of sub-items

Have multiple parents

1. The Calendar UI Elements

The Calendar UI is divided in three sections:

Top toolbar: Contains command buttons to:

�. Show / hide the left pane

�. Add / edit / delete events

�. Today button: Scrolls the Calendar to ensure that today is shown. Appears checked whenever today is shown

�. Choose the Calendar date (day / month / year dropdown buttons)

�. Set the display options

Number of days shown: One of 1, 2, 3, 5, 7 days, month and year

Display type: Month view, Horizontal and Vertical scrolling lists

Show / hide the time scale (unless auto-show is On)

Left pane:

�. Mini-calendar: Dates currently shown in the calendar will be highlighted. Click to select specific dates, weeks and month

�. Current events (today, tomorrow, shown). Double-click an event to view / edit its details

�. List of calendars in this IQBase. Each calendar can be shown / hidden separately or use the main toggle to show all

�. List of Google linked calendars. Each calendar can be shown / hidden separately or use the main toggle to show all

�. Drag the splitter bar to resize the left pane

Right pane:

Day time scale

Main Calendar window

See section 3 below for more details

In addition, other IQ components can be used:



Grids to view / edit date item text and date values

Grids, namely the AdrsBook grid, can be used to drag an item, such as a contact, to the Calendar to create an appointment for this contact.

Appointments will appear under the contact, as sub-items.

Gantt Chart, typically for project related items

Properties pane to view / edit item text and date values

Document pane can be used to associate rich text content to any calendar item

Fields can operate on calendar items (through equations and auto-assigns)

VB Script can also operate on calendar items

2. Navigating the Calendar

Navigating inside your calendar can be done in a number of ways:

�. Mini-calendar

�. Top toolbar

�. Cursor keys

�. Direct Calendar interactions: mouse click, mouse wheel, touchpad, screen touch

The mini-calendar selection (i.e. highlighted dates) are always updated to reflect dates currently shown in the main Calendar window

2.1 Using the Mini-calendar

Selecting dates in the mini-calendar will show these in the Calendar. For example, click on:

a day

a day and drag to select multiple days

(hold Ctrl to select a rectangular region)

a week number

a day header

the month header

The Calendar will automatically set the display type based on your selection

In above example, Tuesdays and Wednesdays are selected and 2 weeks will be shown at a time.

2.2 Using the Top toolbar

The top toolbar is another way to navigate the calendar:

Press Today to show the current day, while keeping the current display scope

Navigate using the up / down arrows for day, month and year

Press the day, month, year buttons for dropdown selection

You can set the number of days shown: 1, 2, 3, 5, 7, month or full year

Select from one of the 3 display modes, each optimized for a particular use-case. See section 3 below for more details

2.3 Using Cursor keys

The up / down / left / right / page up / page down keys will scroll the calendar. The exact effect depends on the display mode and can range from one

day to one month scroll

2.4 Direct Calendar interactions

Unlike say Google calendar, IQ's calendar supports direct interactions to move and zoom the display

Scroll in any direction:

Click on a blank area and drag

On a touch screen, touch and drag



Scroll up / down:

Mouse wheel

Two finger up / down swipe on a touchpad

Scroll left / right:

Shift + Mouse wheel

Shift + two finger up / down swipe on a touchpad

Two finger left / right swipe on a precision touchpad

Zoom:

Ctrl + mouse wheel

Mouse wheel press and drag

Ctrl + two finger swipe up / down on a touchpad

Pinch zoom on precision touchpad

View > Zoom > Zoom In / Out / Reset (or equivalent toolbar command buttons)

3. The main Calendar window

The main Calendar window is where events are shown. In addition it can be used to create events, navigate and set display options

3.1 Calendar Display Modes 

The Calendar has 3 display modes. All 3 modes are touch-screen friendly.

�. Normal

In this mode, days are arranged in a grid with days of the week as columns and weeks as rows.

This is similar to other calendar's month view, except that one can zoom in and out and show / hide the time scale.

�. Horizontal scroll

In this mode, days appear as an endless horizontal scrollable list

Typically, a time scale is shown on the left side and all-day / unscheduled events are shown on top

Visually, the area is divided into working and non-working hours and days (settings in Tools > Options).

This is similar to other calendar's day view, except you can scroll to arbitrary positions and that events that are outside the view port

(earlier or later than visible) are shown on top, with all-day events

If zoomed out, vertical scrolling (mouse wheel, etc) will perform horizontal scroll
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�. Vertical scroll

In this mode, days appear as an endless vertical list. The mouse wheel can be used to scroll in this list.

Time scale can be shown or hidden, depending on the number of days in view.

This is similar to other calendar's agenda view, except that it is live and scalable, not "print-only".

This is very useful when the Calendar in a narrow tab group or in a pane

3.2 The Time Scale

The Calendar can display a time scale, to the left of the Calendar.

When displayed, events are shown according to their start and end time. This is similar to other calendar's day view

When hidden, events are shown one below the other. This is similar to other calendar's month view.



The time scale can toggle between 3 ranges. To switch between ranges, simply click on the time scale. The ranges are:

�. Day-view start and end times ("Day-view" is defined in Tools > Options > This Database > Calendar, see section 9 below)

�. Day-view + evening

�. Full 24 hour view

When the time scale is shown, the Calendar is divided into 2 zones:

All-day and unscheduled events are shown in the upper zone

Scheduled events are shown in the main (lower) zone

Note that scheduled events which start outside of the time scale range are also shown in the upper zone. This ensures that all events are shown

without the need to scroll up / down

To show / hide the time scale:

Click on the toolbar command button

Right-click on the Calendar and select Show Time Scale

Changing the Calendar scale may also automatically toggle the display of the time scale

The time scale can auto show / hide depending the the day view height

Set the toggle height in Tools > Options > This File > Calendar > Auto-show time scale when the day height exceeds X pixels (0=disable)

4. Creating and modifying Calendar Events

Calendar events can be created in a number of ways:

�. Double-click a blank space

�. Right-click on a blank space and select New Scheduled Event, New Unscheduled Event or New All-day Event

�. Calendar > New Event

�. Top toolbar > New Event command button

�. Left pane > New Event... link

�. If the time scale is shown, click and drag while holding the Ctrl key. The Event dialog will open with the correct date and time

�. Press the Insert key. The Event dialog will open with the current date and time

�. Copy / paste existing events:

�. Select one of more events > Copy.

�. Right-click on the calendar date for the new events > Paste

�. In a grid or in the Properties pane, edit any date field-value and check "Shown in Calendar"

��. In any view, Item > Show in Calendar will create an events (1 for each item / date selected). If a single item is selected, the Event dialog will be

shown.

If the selected cells are dates, these will be used to create the event, otherwise the current date field is used (Calendar > New Event uses...)

��. If a date field has "in Calendar by default" checked, all dates added (e.g. in grids) will create calendar events.

If the date field is used in a Gantt chart, then creating a Gantt bar will also create an event

��. Drag-drop an item to the Calendar (from any views,or from the Properties pane)

If the Ctrl key is pressed or Tools > Options > This File > Calendar > Show dialog ... is checked, a dialog will be shown to choose between:

�. Show the item in the Calendar

�. Create a sub-item named "Appt for xxx" and show it in the Calendar

To edit an existing event, use one of:

�. Double-click on an event

�. Right-click on an event and select Edit

�. Calendar > Edit Event

�. Top toolbar > Edit Event command button

�. Double-click on an event in the left pane

�. In a grid or the Properties pane, on a date field, edit any date field-value and  and click on the Edit button

4.1 The Event Dialog

Events can be modified in a number of ways, one of which is the Event dialog. It gives access to all event properties, including the repeat pattern:



Events can be of one of three types

Scheduled: Has a starting date / time and an ending date / time:

Unscheduled: Has an event date and a duration. The actual time for the event is not set:

All-day: Event lasts all day:

Events repeat pattern can be set to Daily, Weekly, Monthly or Yearly:

Recurring events will show one of 3 icons in the bottom right corner   :

�. Master event

�. Regular recurrence

�. Exception to the recurrence pattern

4.2 Adding Events using the Date Editor

While in a grid or anywhere else using the Properties Pane, it is possible to show an item in the Calendar by editing a date field value and checking

"Show in Calendar" in the Date editor.

For example, say you want to show that a given task was done, and you want to see this in your calendar. While on the Done date field, press F2 to

enter edit and then F2 again to show the Date editor:



Use the "Show in Calendar" checkbox to add / remove the item in the Calendar.

All 3 types of events can be created this way:

If a time is specified, a scheduled event will be created.

If a time is not specified, then the ItemDuration field determines the type of event:

If the ItemDuration has a value, an unscheduled event will be created

If the itemDuration field is empty, an all-day event will be created

4.3 Adding Events using the Item Events Command

Whenever the Item top menu is visible, it is possible to add / remove items in the Calendar :

4.3.1 Create Event

The command has 2 modes of operation, depending what is currently selected:

�. If in a grid and 1 or more date cells are selected, events will be created for each dates. These dates can be from different items (if multiple items

are selected) and / or multiple date fields (if more than one column is selected)

In this example, you'll have 6 events. The 3 tasks will appear 2 times each, once when the task starts and once when it will complete:

Note that if one or more of these are already in the Calendar, the number of events created may be less. The actual number of events created

will be shown in a pop-up message on the Windows Taskbar.

�. In all other cases (i.e. other views, or if a date field is not selected), the events will be created, one for each selected item, using the Calendar

default date field (see below about the Calendar default field). If the Calendar default field is other than the Appointment field, a dialog will be

shown, letting you choose which field to use.

4.3.2 Edit Event...

Opens the Event dialog (section 4.1 above) for each selected event

4.3.3 Event List

List the current event(s) for the current item. Click an event in the list to show it in the Event dialog

Right-click on an event in this list to view the event in the Calendar or to Delete the event (the actual date values are not erased)

4.4 Adding Events using Drag - Drop

This method is typically used to create appointments for your contacts. To create a appointment item, simply drag-drop a contact to the Calendar, in

the time slot for the appointment.

In this example, we'll create a appointment with Sam Simon on November 12th, 8h30:



If the Ctrl key is pressed or Tools > Options > This File > Calendar > Show dialog ... is checked, a dialog will be shown:

If option 2 is selected, the AdrsBook and Calendar will show:

Notice how a new sub-item appears under Sam Simon containing the appointment event. The event is shown in the Calendar. The item color was

changed to purple. See Event Colors below for details.

5. Selecting, Moving and Deleting Calendar Events

5.1 Selecting Events

The IQ Calendar supports selecting one or more events. To select events, use any of the following methods:

Click on an event. Unselects any previously selected events

Ctrl+Click to select an event keeping previously selected events (i.e.toggles the event select state)

Hold the Shift key and Click and Drag to select events in an area 

5.2 Moving Events

Calendar events can be moved in a number of ways:

�. In a grid or in the Properties pane, deleting a date field value will delete the associated event if it exists

�. In a grid or in the Properties pane, in the Date editor, changing the date and/or time

�. In a Gantt, by moving / resizing a Gantt bar or group of bars

�. In the Calendar, using drag and drop:

Select one or move events. To select multiple events, hold the Ctrl key and click on events.

Click any selected events and move the new date / time

Moving events can change their type:

Dragging an all-day or an unscheduled event to the time zone (lower zone) will change it to a scheduled event



Dragging a scheduled event to the upper zone will change it to an unscheduled event

(to change a scheduled event to an all-day event, use the Event dialog)

5.3 Deleting Events

Calendar events can be deleted in a number of ways:

�. In any views, deleting an item will delete the linked calendar event(s)

�. In a grid or in the Properties pane, deleting a date field value will delete the associated event if it exists

�. In a grid or in the Properties pane, in the Date editor, uncheck the Shown in Calendar checkbox of the associated date field

�. In any views, the Item > Remove from Calendar will remove associated event(s). See above for details

�. In the Calendar, select one or more events use the Calendar > Delete Event (or right-click)

When in the Calendar, deleting an event shows a delete dialog:

If the event is a repeating event, you are given a few more options:

Delete just this event

Delete this event and all following

Delete all events of the series

6. Date Fields and the Calendar

We've already seen that using grids and the Properties pane, it is possible to create events for any date field (using the Date editor or the Show in

Calendar command).

When creating events directly in the Calendar, these will by default use the Appointments field. This can easily be changed using the Calendar > New

Event uses... :

In this case, any events added using the Calendar will use the CallDate field instead of the default Appointments field.

The use of specific fields for events is the equivalent of multiple calendars in other applications.

7. Event Colors



InfoQube events have 3 color attributes:

�. Text Color: Event text color matches the item text color as seen elsewhere in InfoQube

�. Fill Color: Event fill color matches the item color

�. Frame Color: Event frame color is set by the field used for the event (see next section)

To set the event text and fill color, use the Item color menu commands:

8. Date Field Properties and the Calendar

2 field properties influence the Calendar

�. Event color

�. in Calendar by default checkbox

To set the event frame color, open the field properties and set the Event Color:

9. Calendar Options

Use Calendar > Calendar Options to view options (or use Tools > Options > This Database > Calendar (section 2.2). Settings are:

�. Font face and size, Bold

�. Weeks starts on: Choose the first day of the week, used whenever a calendar is shown

�. Work day start / end: Defines the working hours

�. Day view start / end: Defines the hours visible in the Calendar, when the time scale is shown

Remember that clicking on the time scale toggles between 3 scales (see section below)

�. Day time scale increments

�. Non-Working Days: Used in the 5-day day view (working days). Non-working days are shown with a grey background )when the time scale is

shown)

�. Auto-show time scale

�. Zoom step size (%)

�. Show dialog when dragging an item to the Calendar

10. Synchronization with Google Calendar

See Google Sync for details on setting sync with Google services
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The IQ Surface

The two-dimensional IQ Surface is an infinitely-sized sheet that can be used to show items.

It is an innovative way to view outlines, combining the free-form 2D layout and linking of concept maps with the expand / collapse features of grids:

Surface View :    vs Gantt View: 

In a nut-shell:

Use View > Surface to open the Surface

Unlike grids, where the number is unlimited, there is currently only one Surface. Multiple Surfaces support is of course planned

The Surface displays all items that have the Surface1 field checked

All child items are also shown

A child item is shown in one of 2 ways:

As a sub-item, immediately under the item

As a linked item, with a line joining it to the parent item

To switch between the two:

Drag out a sub-item to have it shown as a linked item

Drag a linked item back to the parent item to remove the link line and have it shown as a sub-item

Right-click from an item to another to create a parent - child link

Surface items are like any other item, and can be viewed in other views (Grids, Gantt, Calendar, Properties pane, etc)

The Surface will update to reflect changes to items done in other views, such as adding a child item, adding / deleting a parent

New: Auto-Arrange  !

1. Adding Items

To add existing items, open a grid, the Calendar, or another view. Select 1 or more items and:

Do Item > On the Surface

Check the Surface1 field (show the field in a grid or use the Properties pane)

Adding child items to an item that is already on the surface is automatic. You can do it in any grid and these will show up on the Surface

When existing items are added to the Surface, these are initially placed at the Origin, with child items collapsed. Press the Home key to quickly move

to the Origin

To add new items, use any of the following methods:

Right-click on a blank area of the Surface and select New Item

Double-click on a blank area of the Surface

With no item selected, press Enter or the Insert key

 To add a new sub-item, you can:

Right-click on an existing item and select New Item

Select the parent item and press Enter or the Insert key

1.1 Editing Item Text

The item text can be edited in all views and in the Properties pane. To edit it within the Surface:

Right-click on an item > Edit

Double-click the item

Select an item and press the F2 key
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The Pop-up Editor will open:

The Item Editor can also be used to edit the item text and other item properties (field values, tags, Doc pane content). Use Edit > Edit Item...

(Ctrl+E)

2. Removing Items

The Surface is not as dynamic as a grid, in that the source cannot be changed. It is set to the system field Surface1. And, as it does not support filters, it

becomes essential at times to clean it up.

To remove items, select 1 or more and do one of:

Press the Delete key

Edit > Erase Item (or right-click)

A dialog will be shown with the following options:

�. Erase will remove the items from the database (Surface, Grids, Calendar, etc)

�. Removed item remain in the database but all Surface-specific properties will be deleted

�. Hidden items retain all their Surface-specific properties (box size, border color, link lines types, etc). 

If a hidden item is shown again, it and its child items will be shown exactly as it was before hiding

It is the equivalent to un-checking the Surface1 field

�. Hidden items can be shown using Surface > Show Hidden Items

To have these show in the normal view, either do Item > On the Surface or check the Surface1 field

3. Formatting items

Items on the surface are shown as a rectangular boxes. The following system-wide properties are shown for items on the Surface:

ItemColor: shown as the box background color

ItemForeColor: shown as the text foreground color

Embedded HTML codes (font, size, bold, italic, color, images, hyperlinks, etc)

ItemFont is NOT shown for items on the Surface, all items are shown with the same font

The following are Surface-specific formatting::

Box size: Auto-size or Sizable

Box border color

Item text alignment and padding

Note that:
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When 1 or more items are selected, the above commands are applied to these items

When no item is selected, the following commands sets the default for new items created: AutoSize, Padding

When no item is selected the remaining commands are applied to items that have the default value. For example:

The BackColor command sets the box color for all items that do not have a value for ItemColor

Text Fore Color and Border Color behave the same

4. Linking Items

Links on the IQ Surface are nothing more than regular parent - child relationships (i.e. seen in a grid as an outline).

Being a two-dimensional view, the Surface excels at creating links with more control on how links are shown:

Easy link creation, in particular for multi-parent links

Link line color, line type and shape can be set, globally or for specific links

Links can have text (shown half way along the link line)

Children can be shown as sub-items or as a linked item (with a connecting line)

Expand / collapse can hide all children or just those shown as sub-items

4.1 Creating Links

To create links: 

Right-click on the parent item and drag to the child item

Drag out a sub-item

Select the parent item. While holding the Ctrl key, select 1 or more items. Do Surface > Link Items. Links will be created between the parent item

and all other selected items

Select the parent item. Do Surface > Link Items. A dialog will show all items on the Surface:

Select one of more items and click OK

4.2 Removing Links

To remove a link:

Hover over the link text (half way on the link line). The mouse pointer will change to a hand. Right-click and select Delete Link

Select the two items that are linked. Right-click and select Delete Link

To delete all outgoing links, select the parent item, right-click and select Delete Link. A dialog will be shown to confirm action

Select the child item and in the Properties pane - Parents section, right-click on the parent and select Delete Parent Link

4.3 Setting Link Text

To select link text:

Hover over the link text (half way on the link line). The mouse pointer will change to a hand. Right-click and select Link Text

Select the two items that are linked. Right-click and select Link Text

Select the parent item. Right-click and select Link Text. An input box will be show for all outgoing links. The link text can include icons, using the

syntax <img>IconName</img>



4.4 Formatting Links

The following properties can be set for each link:

Line Color

Line Type (dot, dash, etc)

Line Shape (straight, curved, etc)

Note that:

When the 2 sides of the link are selected, the commands will be applied to that link

When only 1 item is selected, the commands will be applied to all outgoing links

When no item is selected, the commands will be applied to links with default properties

5. Working with the Surface

Users can move the view point, zoom in / out, move items and expand / collapse items and links

5.1 Surface Options

The Surface menu has the following commands:

Background Color

Move Linked Items: Behavior when moving an item: Should linked items move with it or stay put

Hide Linked Items on Collapse: Behavior when collapsing an item: Should linked items be shown or not

Auto-Arrange...

Show Hidden Items

Show / Hide Grid Lines

Snap to Grid

5.2 Moving the Surface

Click on an empty area of the Surface and drag the mouse (or Tap and drag)

On a touch screen, touch the Surface and move

To move up / down, roll the mouse wheel (or 2-finger up / down)

To move left / right, hold the Shift key and roll the mouse wheel

Press the left / right / up / down keys

Press PgUp / PgDn keys (hold Shift for horizontal)

Press the Home key to move to the Origin and set the zoom to 100%

Hold Ctrl and Alt and roll the mouse wheel to toggle between viewing all items and setting the zoom to 100% centered on the item under the

mouse pointer. This is a great way to navigate in a large surface

When Auto-Arrange is On, clicking on an item will center it if it is not in the central area

5.3 Zoom In / Out

Hold the Ctrl key and roll the mouse wheel

Pinch zoom in / out on a touchpad

View Zoom commands: In / Out / Reset

Ctrl + Home to view all items

n.b. Pinch zoom on a touch screen does not currently work

5.4 Expand / Collapse Items and Links

When an item has 1 or more sub-items, an expand button is shown to the left of the item box ( +, - ). Click on this button to expand / collapse

sub-items

For links, the behavior is set with Surface > Hide Linked Items on Collapse:

If checked, linked items will hide when you collapse the parent item

If un-checked, linked will not hide when you collapse the parent item (only sub-items will hide). 

This is useful when the parent has many children. Simply pull-out some sub-items and collapse the parent. It effectively does a hoist

To quickly expand / collapse a multi-level hierarchy of items, use the Ctrl + 0-9 shortcuts:

Ctrl + n: Expand to level n where n=1, 2, ... 9

Ctrl + 0: Expand completely



5.5 Moving Items on the Surface

�. Select 1 or more items

�. Click and drag to the new position (mouse, touchpad, touch screen)

�. Drag to another item to create a link (Auto-Arrange Off)

�. Drag to a blank area to move the selected items

�. If Auto-Arrange is On (see below), other items will move when the selected items are moved

6. Auto-Arranging Items

Items can Auto-Arrange either automatically or using the Auto-Arrange command

6.1 Automatic Auto-Arrange

Item automatically move when the Auto-Arrange command is checked.

With no item selected, do Surface > Auto-Arrange to toggle the state. Alternatively, press Ctrl + Shift to toggle

The Status bar will show the Auto-Arrange state

When Auto-Arrange is On, links are shown as extended links (i.e. outgoing links are not combined into one)

Dragging items will move other items so items never overlap

As a consequence, when Auto-Arrange is On, it is not possible to change the parent-child relationships by drag-drop. Do this in a grid or set

Auto-Arrange Off

When Auto-Arrange is On, selecting an item will move the Surface so the item is roughly centered

6.2 Manual Auto-Arrange

To manually Auto-Arrange:

�. Select 1 or more items

�. Do Surface > Auto-Arrange... :

�. Select Layout:

Horizontal: Sub-items will be to the right of the parent item

Vertical: Sub-items will be below the parent item

Attached: Will reattach all sub-items that were detached

�. Select options:

X and Y item spacing

Detach sub-items. If checked, sub-items will be detached from their parent

�. Undoing the Auto-Arrange: 

After an auto-arrange, a pop-up notification is shown (bottom-left corner). Click this notification to cancel the auto-arrange

On auto-save and on closing the Surface, a confirmation dialog is shown. Use this to cancel the auto-arrange

Tips and Tricks

Create a grid named Surface1 (or set the grid source to that field) and then all actions on the Surface will be seen there too. Conversely, all

changes in this grid will be reflected on the Surface



You can quickly hide items by unchecking the Surface1 field

Item font is not shown on the Surface. You can however set the overall font using the Grow Font and Shrink Font commands

Press Ctrl+Shift to toggle how multiple links are shown (combined or separate). This also sets Auto-Arrange On / Off

The Surface layout auto-saves every 60 seconds

To know if an item was added to the Surface or just shown because it is a child of a Surface item, check the lower left of the item box. Surface

items have a green check-mark
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Document Pane

The Doc Editing pane is accessed :

1- using the View menu -->  Document

2- using the keyboard shortcut F6 or shift-F6

The Doc editing pane... is used to:

Enter "rich text" content (HTML). Each item can have a separate document. There is no limit to the amount of text that an item can contain. The

text is saved as part of the IQBase file.

the pane supports HTML and MHT storage (meaning that these formats can be stored inside the DataBase or as linked files and text can be

searched from inside IQ).

The advantage of MHT is it can save images and style sheets from web pages locally (they are saved in a folder in the same directory as the

database).

The disadvantage of MHT is that it cannot be edited within the HTML pane. You need to use MS Word or BlockNote (a Free WYSIWYG

editor). See Install MHT Editors for a local copy of BlockNote.

Both Word and BlockNote need to have their respective program paths added to:

   - Tools > Options > 1. Program > Document pane > MHT Editor path: On 64-bit windows systems, the path for MS Word is usually

C:\Program Files (x86)\Microsoft Office\Root\Office16\WINWORD.EXE

   - Tools > Options > 1. Program > Document pane > Alternate MHT Editor path

Provide a link to an HTML file. Editing will automatically save to this file

Link to a web page

Drag content from the web. See also 1. Clipping Content from other Apps

Display and edit Ink Documents: Using Ink Documents

Display and edit MarkDown Documents: Using Markdown documents

https://infoqubeim.com/drupal5/index.php/pierre
http://blocknote.net/
https://infoqubeim.com/drupal5/?q=node/697#install_mht_editors
https://infoqubeim.com/120
https://infoqubeim.com/3457
https://infoqubeim.com/3781


In Browse Mode, you can use the HTML pane as a browser window and surf the web. (You can input web addresses in the URL Toolbar which

also has Back/Forward buttons. Not to be confused with the Item toolbar also has Back/Forward buttons.)

Display different file type content (and in certain case, edit them :  *.aspx *.EML. *.PDF. *.DOC. *.XLS

Note that in certain cases, if “Browse in same window“ is disabled in Windows Explorer. You need to enable that feature. To do that, follow

these steps (example is for MSWord, windows XP):

�. Launch Windows Explorer.

�. Select “Folder Options...“ from the Tools menu.

�. Select the “File Types“ tab.

�. Scroll down the list of “Registered file types“ until you find “DOC - Microsoft Word Document“ and select it.

�. Click on the “Advanced...“ button at the bottom of the dialog.

�. Check the “Browse in same window“ checkbox.

To display PDFs in the HTML pane, Adobe Acrobat Reader must be installed. Version X 10.1.16 works fine. Steps are:

Open Acrobat Reader

Edit > Preferences > Internet: Check Display PDF in browser

Edit > Preferences > Reading: In Screen Reader Options > Page vs Document, select Only read the currently visible page (Ref link)

Paragraph spacing:

There are two ways to make the html "return" go to the next line without creating a space between the lines:

�. Shift+Return

�. Click on the DIV button (menu>Edit>Use DIV) which will use DIV tags, instead of <P> tags  

Default template for HTML and MHT documents:

To change default font (and other format settings) in the HTML pane:

HTML Documents:

�. Create a new item

�. In the HTML pane, switch to code view (Menu > View > HTML Code)

�. Edit the HTML code. The section you most likely want to edit is between <STYLE>...</STYLE>

�. There are lots of resources on the web, one good one is this: 

http://www.w3schools.com/html/html_css.asp

�. Switch back to normal mode (Menu > View > HTML Code again to exit HTML view)

�. Test out by typing in sample text

�. Menu > File > Save as default... The dialog offers you to save for this IQ session or as a permanent change

MHT Documents:

�. Close IQ

�. Find the NewHTML.htm and NewMHT.MHT files in :

Portable version: YourIQFolderWhereYourProgramResides\Users\YourName folder in the installation folder.

Installable version:

XP: Documents and settings\YourName\Application Data\InfoQube

Vista and up: C:\Users\YourName\Roaming\InfoQube

�. These files serve as a templates for all new content. Open in a text editor (Notepad etc. - Right-Click>Open With> ).

e.g. to change the font, change the two instances of "MS Sans Serif" to the font name of your choice.

�. Modify the NewHTML.htm and/or NewMHT.MHT files (open them in notepad or your favorite text editor).

�. Re-start IQ

Sample HTML file:

<HTML><HEAD> 
<META name=GENERATOR content="InfoQube 0.9.70a"> 
<META charset=UTF-8> 
<STYLE> body {font-family:Arial Unicode MS; font-size:13;}table {font-family:Arial Unicode MS; font-size:12;} 
ol, ul { margin: 0.5em 3em;  } 
</STYLE> 
</HEAD> 
<BODY style="ZOOM: 1; bottomMargin: 0" leftMargin=2 rightMargin=2 topMargin=2 bgColor=#ffffff> 
<DIV>&nbsp;</DIV></BODY></HTML>

Note : 

The default files (i.e. system provided ones) used for new users is located in:

App folder\AppFiles

https://helpx.adobe.com/acrobat/kb/message-content-preparation-progress-opening.html
http://www.w3schools.com/html/html_css.asp


Note that these default files are overwritten on program installation.
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Document Pane Content Types and Associated Storage

The Document pane can display a wide variety of content:

�. Rich text

�. HTML file

�. Markdown file

�. Other local files (such as PDF, images, doc, docx, xls, xlsx, etc)

�. Web page

�. MHT / EML file

�. Ink document

�. SVG document

�. Folder view (Explorer-like)

Of these, only the first is embedded in the IQ base:

1: Embedded, editable in the Doc pane, searchable

2, 3: File storage, editable in the Doc pane, searchable. Editable in an external program too.

4: File storage, viewable in the Doc pane, PDF files are searchable, others not. Excel files allow some changes to be made in the Doc pane

5: Web storage, viewable in the Doc pane, not searchable

6, 7, 8: File storage, viewable in the Doc pane. Edit > Edit Document (or click on the Editor command button) to edit in its own app. The Doc pane

will auto-update when the content changes. MHT (6) is searchable, others not

9: Not embedded, not searchable, just the display of a local folder

Content can be created in a number of ways, and this affects where it is stored:

�. Text entered directly in the Doc pane (internally, it is stored in HTML format)

�. Web content pasted in the pane

�. Local Image pasted in the pane

�. File > Open to view a local file

�. File > Open Web page

�. Ctrl + N, Win + N or Edit > New Item (Main IQ menu):

a. “Save as MHT” unchecked

b. “Save as MHT” checked

�. Select content + (Win + C) (Universal Clipper)

a. “Copy URL content” and “Save as MHT” unchecked

b. “Copy URL content” checked

c. “Save as MHT” checked

�. EmailToIQ (see 2. Send To InfoQube using EmailToIQ for details)

Of these:

1, 2 ,6a, 7a will be embedded. For 2, images are not locally saved (so will link back to the web)

4 will use the local file, where ever it is

5 will link to a web page

3, 6b, 7b and 7c will create one or more local files

3 will create an image file for each image pasted, named ItemIDXXXX.jpg

6b and 7c (MHT option) will create a single ItemIDXXXX.MHT file

7b will create a single ItemIDXXXX.htm file and support files in ItemIDXXX_files folder

For 8, see 2. Send To InfoQube using EmailToIQ for details

Finally, at any time, you can convert content in the Document pane to MHT. This will create a single file, named ItemIDXXXX.MHT

Once in MHT, you can convert it back to htm, which will create a single ItemIDXXXX.htm file and support files in ItemIDXXX_files folder

Local files can come from anywhere. When IQ creates a file, it will create it in the YourFile.SNDB.Files folder. When using the .Files folder, the main file is

saved in the root folder. If an item has support files, such as 1 or more images, these are put in the item specific folder (ItemIDXXXX_file)

https://infoqubeim.com/drupal5/index.php/pierre
https://infoqubeim.com/2952
https://infoqubeim.com/2952


Note:

IQ is able to display emails in the Doc pane when these are saved as EML. If these are not displayed correctly, see 3. Importing Emails into

InfoQube
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Using Ink Documents (handwriting)

Through the use of a free Ink Editor, InfoQube can handle Ink documents (i.e. handwriting) in a Doc pane:

The Ink Editor has exceptional support for ink, making it into a true handwriting word processor:

Insert / remove words

Reflow of words on a page

Support for columns, with reflow in each column

Bookmarks to ease navigation

Clippings pane (drag-drop to and from the document)

Multiple undo / redo

Multiple select tools

Handwriting hyperlinks to web pages

Handwriting hyperlinks to items and views. Use the same syntax as in the Hyperlink dialog (i.e. ItemIDs, comma separated, grid name, calendar,

surface)

Combine sketches and text

Drag-drop images

Resize / rotate text and images

Customizable pen (tip size, highlighter mode), paper

Split view to show 2 sections of the document

Export to PDF and HTML

Uses Internet standards (SVG)

Real-time collaboration on the same document (Google Doc-like)

Demo video here

To use this feature, first install the Ink Editor. Details here: InfoQube Program Install and Set-up

1. Creating Ink Documents

To create an Ink document, do Menu > File > New > New Ink Document (or use the toolbar button):

https://infoqubeim.com/119
https://infoqubeim.com/drupal5/index.php/pierre
http://www.styluslabs.com/
https://infoqubeim.com/drupal5/index.php?q=node/3972
https://youtu.be/eWyxTKa2tZ0
https://infoqubeim.com/697


The Doc page will now show a blank sheet of lined paper:

To edit, double-click on the page or click on the Ink Editor icon on the main toolbar.

Using the Ink Editor is quite self-explanatory. See this Ink document and / or the above video for details.

2. Printing / Sharing Ink Documents

Ink documents use W3C standard format SVG and as such can be viewed in any modern browser.

The Ink file itself (i.e. file with .shtml extension) can be associated with your browser so a simple double-click will show it.

When sending the file by email, you can change the extension to .html. Most recipients should be able to view the .shtml file, but changing it to

.html increases the chances it will work

Ink documents can be printed

Ink documents can be part of an HTML Export:

The export process uses the field ItemHTMLHeight field to determine the document height.

Enter a value in this field to control the ink document height during export.

Do File > Save to automatically compute the ItemHTMLHeight value

Also, while editing, Write can directly export your document in PDF or HTML formats:

Finally, through File > Print Preview, you can combine Items, field values with rich text and Ink documents into a single HTML document.

Use the ItemHTMLHeight field to control the height of the Ink document when exported.

3. Syncing Ink Documents with Android Devices

Write is available on Android devices. All devices should be compatible, but those with active pens offer the best experience, such as Samsung's Note

phones and tablets:

�. Download the App on Google Play. Recommended is Write 2.0 Beta

�. Once installed, configure the Android Write as described in InfoQube Program Install and Set-up

When Dropbox is installed on the PC and on the Android device, it is possible to sync content between InfoQube and your device.

When properly done, any Ink document created can be viewed and edited on your mobile device. Changes are synced back to IQ.

https://infoqubeim.com/downloadarea/InkDocumentHelp.html
https://play.google.com/store/apps/details?id=com.styluslabs.writeqt
https://infoqubeim.com/697


In InfoQube:

�. Configure InfoQube to use Dropbox as described in 1. Synchronization between computers using Dropbox

�. If full Dropbox sync is not desired, you should at least place your .Files folder under a Dropbox folder. This is set in Tools > Options > This file >

.Files path (2.4.12)

e.g.  .Files folder (MyIQBase1.SNDB.Files) needs to be a Dropbox folder, such as in \Dropbox\IQBases\MyIQBase1.SNDB.files

�. Create Ink document in IQ

�. Rename it to something more meaningful than ItemXXXX.shtml

On your Android device:

�. Open the Dropbox app

�. On some versions of the Dropbox app, it is essential to force it to do updates quickly otherwise changes on the phone/tablet are not sent back

to your PC for a long time.

To do this, tap Settings then select Manage Notifications and select the last option (Files I download...)

�. Navigate to your .Files folder (e.g. IQBases > MyIQBase1.SNDB.Files). All your IQBase related files will be there

�. Sort the list by date. The new Ink document should be near the top

�. Click on the ... menu and select Available Offline and / or Add to Favorites

�. Tap on the file. Write for Android should open

�. If step 2 above was not done, click the save button (assuming save button was added during setup)

�. Close Write

�. IQ should detect the change and update within seconds

��. 

4. Real-Time Collaboration

While still a beta feature, multiple users can now work on the same Ink document in real-time.  Ideal for brainstorming. Kind of like Google Doc for

handwriting / sketches !

To enable this feature you must first create an account with StylusLabs here: http://www.styluslabs.com/account

Mark down your user name and password. Note that the user name is currently case sensitive, so copy it exactly as entered.

4.1 Sharing an Ink Document

To share an Ink document you must create a Whiteboard:

�. In the Doc pane, double-click on the Ink document to open it in Write

�. In Write, click on toolbar to Create Whiteboard (or do (...) > Document > Create Whiteboard)

�. Note the proposed ID or change it to something more meaningfull

�. Send the whiteboard ID to other users

4.2 Connecting to a Shared Ink Document

Other users can connect to a shared Ink document to view / edit it:

�. Open Write

�. Click on toolbar to Open Whiteboard (or in Document view, click on Open Whiteboard)

�. Enter the whiteboard ID from step 3.1 above

�. Enter your StylusLabs user name and password

�. The shared Ink document will show

4.3 Using a Shared Ink Document

When shared, the file name will have a "cloud" icon (top left of the window)

All users can write on the document

Changes are sent as soon as a user lifts the pen from the surface

Undo / Redo is specific to each user

While sharing an Ink document, there is an additional menu item: (...) > Whiteboard:

Sync View: If checked, the position / zoom of the document will sync with other users

View Master: If checked, the user will control the display of users that have Sync View checked

https://infoqubeim.com/3066
http://www.styluslabs.com/account


5. Tips and tricks

Ink documents work best on a touch screen PC/Tablet with an active digitizer (Wacom, N-Trig or Synaptics), such as those from Microsoft

(Surface line), Acer, HP, Lenovo, Dell and Toshiba (list here). A Wacom tablet is also a good option.

You'd like to have a grid which contains all your Ink Documents. Easy, create a grid (such as InkDoc) and set it's source to: ItemHTMLFile
like "*.shtml"
The following settings generally help the writing experience: Menu > Prefences > Input: Mouse Input=Pan, Single and Multi-touch=Ignore,

Smoothing=10

Use the square brackets to quickly change the stroke width ( [ to decrease, ] to increase )

When moving content, move snaps to the paper lines if Insert Space tool is set to Ruled Insert Space

The Insert Space tool, when moved up / down acts on the whole page width unless a section is selected, in which case, it only acts on the

selection

The Insert Space tool, when moved left / right will wrap the text on the page (or column). If you find that the wrapping cuts words or moves

group of words, change the Minimum reflow word break setting (default=0.30)

Each ink stroke is date / time stamped. Move the mouse over handwriting to find the exact date / time of each stroke

The blank Ink document is supplied with InfoQube and a copy is placed in your user files folder: NewInk.shtml. To use a different blank Ink

document, open this file in Write, configure your document (line type, page size, etc) and save. Restart IQ

Write has excellent palm rejection. Best is to have it open full screen so touching with your palm will not bring another window in focus

The toolbar customize UI is missing Zoom In/Out commands. These can nevertheless be added by editing the Write.xml file: In the toolbar

section, add actionZoom_In and actionZoom_Out
Write defaults to saving files with images down sampled (to reduce file size). So if you later on increase the image size, you'll notice significant

image quality degradation.

You can change this by adding this setting in the Write.xml config file:

<int name="savePicScaled" value="0" />. The file is typically located in c:\users\YourUserName\AppData\Roaming\Stylus Labs
In version 2.09 (most recent, download link), Write can rotate text and images. Each time an image is rotated and saved, the image quality will

however degrade unless the "savePicScaled" setting is turned off

Write has an option to save as a single file or as multiple files. To the user this is fairly transparent except for these two issues

If set to multiple files, double-click on the page in InfoQube does not work. Use the Ink editor button instead

If set to multiple files, Dropbox sync with Android is a bit more complex as there are multiple files. One needs to set all related files (.svg) to

be available off-line. Only then can a tap on the Ink file will Write (Android) open correctly

If set to single file, version 2.09/2.10 (the current, for Windows and Android) has a bug when lines are shown: The page height and width is

set to a huge number. Use previous version instead

Write is available in 2 versions:

Current version has a useful clipboard and can rotate text and images

Previous version saves as single file correctly
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Stylus Labs Write DemoStylus Labs Write Demo

http://www.umpcportal.com/tablets-with-digitizer-pen/
https://infoqubeim.com/downloadarea/Write209.zip
https://infoqubeim.com/drupal5/index.php/pierre
https://www.youtube.com/watch?v=eWyxTKa2tZ0


Using MHT Documents

MHT can save images and style sheets from web pages locally as files (or as part of the database)

MHT cannot be edited within the Doc pane, but can be edited with MS Word or other editors, such as Blocknote and WizHtmlEditor

As shown, "Edit with MSWord" is being used on ItemID10534.MHT, with the content now editable in the Word program

After editing and saving in the external editor, the Doc pane will refresh to show the edited content

MHT, mhtml and EML are identical file formats, some browsers / devices do not read MHT and EML files however, so it is best to use the .mhtml

extension

In Android, free app MhtViewer allows Chrome to view MHT files (but not EML). Once installed, you can erase it, as it seems to just add a file

extension to Chrome
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Using Markdown documents

Each item can have a rich text document, which is typically shown in the Doc pane. That pane supports a number of different formats, one of which is

Markdown documents.

https://play.google.com/store/apps/details?id=com.tflare.mhtviewer&hl=en
https://infoqubeim.com/drupal5/index.php/pierre


To create a new Markdown:

Doc pane: Menu > File > New > New MarkDown file

Item Editor: New > New MarkDown file

You can then enter text using the Markdown syntax. Whenever the document is saved (or focus is moved to another item), IQ will generate the HTML

version of the document

If you structure a large document into a hierarchy of small-sized items, use HTML Export to get a single HTML document. An obvious advantages of

this approach is easier section / item manipulation and organisation

To view the formatted output:

Press F2 or switch to Browse mode (Ctrl + M)

The generated HTML can be fine-tuned using a CSS Stylesheet file. See below for details

If editing using the Item Editor, the Doc pane will auto-update each time the document is saved

Editing Markdown documents

Editing can be done using :

Doc pane

Item Editor

External editor

There are a large number of Markdown editor programs. Some very simple (Notepad could even be used), some very specific.

One such one is Markdown Monster which sets itself apart from the rest for these features:

Spell-check

Built-in screen shot capture

Paste HTML as Markdown, a.k.a. HTML to Markdown conversion

Publish to a Weblog

Themed Previews (e.g. Github)

Add-ins (e.g. Automatic Table of Content generation)

The rest of this page describes the Markdown syntax and the use of the included editor.

1. Headers

Headers are marked with one or more #. IQ will expand header levels so entering # 4 (no space) will be converted to #### which is a H4 header

A header (level 4)

2. Paragraphs and character formatting

Paragraphs are separated by a blank line.

Paragraphs which are not separated by a blank line are combined. So this second line will actually be shown with the previous one.

To add a carriage return, add 2 spaces at the end of the line.

So this text is now on a different line

Font attributes can be Italic, bold, and monospace. To format, enclose the text with:

* for italic

** for bold

 ̀for monospace

Underline and strikethrough are possible by enclosing the text with the HTML codes (<u> … </u> and <s> … </s>)

3. Lists

To make a bullet list, add a blank line and start the list with either - or *:

this one

that one

the other one

or for numbered lists, start the line by 1. :

https://markdownmonster.west-wind.com/


�. first item

�. second item

�. third item

To add a carriage return, add 2 spaces at the end of the line.

�. One last item

(no need to enter the correct number for numbered list items, items will auto-increment)

To create nested lists, add 1 or more Tab character:

Level 1

�. Level 2

�. Level 2 again

Back to Level 1

One more

4. Hyperlinks

Hyperlinks are entered using one of:

the following syntax: [Link text](Link URL)

Insert > Hyperlink (Ctrl + K) to show the Hyperlink dialog. All the standard IQ hyperlinks are allowed:

Web page URL

Local file

Item or list of items

Grid

All items in a field

etc.

Details here

5. Images

Images handled like hyperlinks except that the link is preceded by !:

To insert an image, use one of:

![Optional image text](Image URL)

Insert > Image

With an image in the clipboard, Edit > Paste

6. Tables

Use Insert > Table and select the number of rows and columns

Format is :

| | Grouping | |
| Header 1 | Header 2 | Header 3 |
| :------------ | :-----------: | -----------: |
| Line 1 | **Bold** | Cell |
| Line 2 | *Long Italic Cell* ||

There can be any number of header lines (2 in the above example)

The line below the last header is used to set cell alignment:

:------- for left

:-------: for centered

-------: for right

To merge two cells, delete the spaces between the | | (Long italic cell in the above example)

In the above example, the table would look like this:

Grouping

Header 1 Header 2 Header 3

Line 1 Bold Cell

Line 2 Long Italic Cell

https://infoqubeim.com/drupal5/index.php?q=node/115


7. Other Formatting

Quotes

Start the line with > for quotes:

Block quotes are written like so.

They can span multiple paragraphs, if you like.

Code

Code can be formatted in 2 ways:

Tab (or 4 spaces) at the start of each line

Add `̀̀ at the start and end of the block (easier to copy / paste code)

Tab:

Let me re-iterate ...   

for i in 1 .. 10 { do-something(i) }

Delimited by `̀̀:

define foobar() { 

      print "Welcome to flavor country!";   

}

Footnotes

To create a footnote enter [^1]. The footnote text will be shown at the end of the document.

e.g. Here’s a footnote [1].

Definition lists

Definitions are automatically formatted. To enter a definition enter the Word on a blank line. Then for each meaning, enter : followed by a Tab and the

meaning:

Word

Definition 1

Definition 2

e.g.

Apple

Pomaceous fruit of plants of the genus Malus in the family Rosaceae.

An american computer company.

Orange

The fruit of an evergreen tree of the genus Citrus.

Again, text is indented 4 spaces. (Put a blank line between each term/definition pair to spread things out more.)

Oher codes:

H1 and H2 headers can be created by adding 3 or more = or -

Use 3 dashes for an em-dash: —

Use 2 dashes for ranges (ex., “it’s all in chapters 12–14”).

Three dots will be converted to an ellipsis: …

Three underscores to draw a horizontal line

To prevent characters from being interpreted, precede it with \. e.g. \** will not bold text but this will be bold

8. Style Sheets and other header information

The Markdown document uses the MultiMarkdown syntax which is an extension over the standard Markdown. Of the enhancements, the format

supports a header section:
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CSS: Full path to the style sheet file

Title: Document title

Base Header Level: X : Offsets the Header level (i.e. for 3, a # generates an H3

The CSS file is particularly useful since it allows full control over the HTML generated from the Markdown
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Converting between HTML and MHT

Converting between HTML and MHT

Convert MHT document to HTML: If you click on the new HTML document icon, it will prompt you if you want to convert the existing MHT document

into HTML:

 --

Convert HTML document to MHT

--

--

Create a new MHT document from existing HTML or MHT content:

--
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--

Create a new HTML document from existing HTML or MHT content:

 --
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Embedding other content

Embedding other content

Embedding other content

The Doc pane can show content from other app / web sites. As it is based on Internet Explorer, there are sometimes some limitations

1. Embedding a Google Sheet

Set the Doc pane IE version to 11 (Tools > Options > 4.1.4 Internet Explorer version. Restart IQ

Open the Google Sheet and get a public shared link (read-only)

Create a new item

In the Doc pane (blank), do File > New > New HTML File

Insert HTML Code and paste the Google link in the dialog

Switch the Doc pane to Browse mode. Sheet should display
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5. Item Editor

5. Item Editor

The Item Editor

 The Item Editor is an always accessible window to view / edit an item. This includes:

Item text (or item name)

Doc pane content (long-form content associated with each item)

Commonly used fields (Notes, URL, Inbox and Due Date)

Yes/No fields (i.e. folder-type fields)

Tags

https://infoqubeim.com/drupal5/index.php/pierre
https://infoqubeim.com/drupal5/index.php/pierre


The item information is available in other UIs, such as grids, and panes. For example, the Document pane shows the rich text content, and tags can be

shown in grid and in the Tags pane. However:

The Item Editor is the only UI that combines all these in a single window

Many Item Editor can be opened at once, hence providing an elegant way to have multiple Doc / Properties / Tags panes

1. Showing Items in the Item Editor

To show items, select one or more items and do Edit > Edit Item... (Ctrl+E). An Item Editor window will open for each selected item.

2. Using the Item Editor

2.1 Item name

The top section is a WYSIWYG editor to edit the item, or item name (i.e. the Item field value)

To resize the text box, drag-drop the separator immediately below the text box

The toolbar shows the same commands as the main UI formatting toolbar used in the grid WYSIWYG editor

Details here

2.2 Doc pane content

The second section is a WYSIWYG editor similar to the Doc pane supporting most of the same commands:

If an edit is not possible in the Item Editor, you can save the changes and continue editing in the Doc pane.

2 such cases are (1) inserting a table and (2) editing the HTML code directly

To do so, either move the focus to that item in the main UI or else check the "Sync" checkbox on the lower part of the Item Editor

All documents types are supported. Click the New Document icon to change the document type

The Item Editor is particularly useful for Markdown documents as the Doc pane can be used to show a live preview

(auto-updates when the Markdown file is saved)

2.3 Common fields

Click the Options button (left of the OK button) to reveal the optional fields section:
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2.4 Tags and Fields pane

Two additional panes can be used to assign tags and fields:

These panes can be shown or hidden and docked to the left or right edge of the window

The Tags pane is identical to the one used in the main UI (Flat or Tree view, filtering, etc)

The Fields pane is unique in that it shows a alphabetical list of yes/no fields

The Fields pane also supports some features specific to the Tags pane, such easy filtering.

You can also show items that match some field criteria. To do this:

�. Select two or more fields

�. Right-click > Show Items to open the Scratch grid with items that either have all fields (AND) or at least one field (OR)

3. The Item Editors command

The View > Item Editors command shows a dropdown divided in 3 sections:

�. Edit item and floating / non-floating windows setting (see the Hints section below)

�. List of items currently shown in an item editor

�. List of items recently shown in an item editor

Right-click on an item gives these options:

Show in Home View, if defined. Details here

Close Item Editor / Close All Item Editors

Remove from item from list

Clear list

4. Customizing the toolbar

The Item Editor toolbar can be customized. To do so:

�. Open a Doc pane

�. Right-click on a toolbar and select Customize...
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�. In the toolbar list, find the ItemEditor entry and ensure it is checked

�. Customize that toolbar as you would any other toolbar. Details here

�. Click OK when done

�. Close any existing Item Editors

�. New Item Editors will show the new toolbar setup

The Doc pane has some commands which are not implemented in Item Editors. The ones currently available to Item Editors are:

Font and Styles

Bold, Italic, Underline, Strikethrough, Super/Subscript, Remove format

Text and Background colors

Bullet and Numbered lists

Indent, Un-Indent

Undo, Redo, Copy, Cut, Paste, Paste special

Alignment (left, right, center, full)

Hyperlink, Insert image / icon

New document (all types)

Save

 5. Tips and Tricks

The list of recently editing items is a convenient way to remember context as to what one was working on

(similar to View > History)

If you close the IQBase and later on re-open it, the program will re-open the same items in an Item Editor

If some of these Item Editor windows were minimized, these will be re-opened as minimized windows

(in such cases, the window content is not actually loaded until the window is shown

When the Item editors are floating, they are linked to the main IQ window and will be hidden when the main IQ window is minimized

When the Item editors are not floating, they are not linked to the main IQ window and can therefore be shown independently of the main IQ

Window.

This is useful to take notes when viewing other programs, such as web browsers
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6. Properties Pane

6. Properties Pane

The Properties Pane

The Properties pane is used to view / modify information about items:
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1. Properties Pane Sections

The Properties pane is divided into the following sections:

�. Item Properties

�. Marked items

�. Grids

�. Forms

�. All Fields

1.1 Item Properties

The Item Properties section shows everything there is to know about the current item:

Nominal information, such as unique Item ID, when it was created / modified and by who, font and lock properties and its Home

Created and modified dates and Created By can be edited (right-click > Edit value > Confirm action)

Tags: List of tags assigned to the selected item. Details here: 3. Tags

Values: List of field values assigned to the selected item

Parents: List all parents of a selected item

An item can have multiple parents

Parent list is shown as an inverted tree. This is in particular very useful when items have multiple parents

Each parent is a hyperlink. Click on the link to move focus to that parent

Siblings, Children: List of such items

Related Items. Details here: Related Items Links

Shown in: Grids where the selected item was recently displayed. An arrow is shown after the grid name:    . Click this arrow to open it

1.2 Marked Items

This section shows currently marked items. Marked items are a persistent list of item used in many places within InfoQube.

See Marked Items for details

1.3 Grids

Lists grid related information:

Current Grid: This section is dynamic and shows the columns of the current grid. Values can be edited

Use Alt + Up / Down arrows to rearrange grid columns

All grids that are set to be visible in the Properties pane.

Click the grid name to expand and show its columns (and use it a simple data entry form)
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An arrow is shown after the grid name:    . Click this arrow to open it

Grid Groups: List the Grid Groups. Click to show the grids in each group. Click on a grid in a grid group to open it

Details here: 7. Grid Groups

1.4 Forms

List all forms. Forms are a user-defined ordered list of fields

Forms can be loaded as column sets. Details here

Drag-drop and the equivalent keyboard shortcut (Alt+Up/Down) can be used to add and move fields in forms. For more extensive changes to form,

use the Manage Forms dialog. Details here: 4. Forms

1.5 All Fields

List all fields in the current IQBase

Flat view or tree view. Click the icon on the right to toggle between the two views

In tree-view, fields can be arranged in hierarchy using keyboard shortcuts or drag-drop. See section 3. below for details

If the field has the same name as a grid, an arrow is shown after the field name:   . Click this arrow to open it

2. Using the Properties Pane

The Properties pane shows the values of the currently focused item

If using a view that supports multiple selections (most do), only one item of the selected items has the focus and it is that one that is shown in

the Properties pane

Adding / Editing / Deleting a field value is performed on ALL selected items

The left column supports Auto-search. So to find a field, simply start typing. Press F3 to find the next occurrence 

2.1 Context Menus

Right-click on a line in the Properties pane to view a context menu. Each type has a specific context menu:

Tags

Field

Parents header

Parent item

Sibling / Children item

Related Items header

Related item

Marked items header

Marked item

Grid and Grid Group

Forms header

Form

All Fields header

3. Field Hierarchy

Fields in the All Fields section of the Properties pane can be arranged in a hierarchy

To turn on it On, click on the button to the right of the All Fields section
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There are 2 methods to arrange fields :

�. Keyboard

�. Drag-drop

3.1 Using the Keyboard to arrange fields

You can use the same keys that you use to arrange items in hierarchy :

Alt + Up / Down

Alt + Left / Right

Tips :

Only one field can be moved at a time

To move multiple fields, move these under a parent field and move the parent field

The Item > Move command buttons are enabled, so they can also be used

3.2 Using Drag-Drop

You can arrange fields using Drag and Drop. Do make sure though when dropping that the mouse pointer changes to "sub-item"" : 

4. Tips on using the Properties pane

You can drag the Tags section to a grid to show tags as a column in the grid

You can drag a field from the Properties pane to a grid to show it there

You can perform bulk operation (i.e. on multiple items) using the Properties pane. e.g. on Field2, entering =[Field1] + 4 would execute that

function for all items selected.

If Field2 is not set to automatically parse equations (Field properties > Properties), right-click on the equation > Parse Equation

F4 moves the focus between the Properties pane and the active view. This works even if the Properties pane is in auto-hide mode

F7 / F8 works even when the focus is on the Properties pane (to select the Previous / Next item). It is therefore possible to view the properties of

other items without going back to the active grid

All item-type entries (parent, children, marked items, etc) can be edited in the Properties pane. Right-click > Edit (or F2) to edit

All field-type entries support double-click: Double-click a field will open the grid that has this field as a source if it exists, otherwise, the Scratch

grid will open

In Tools > Options > Program > Other > 1.6.13 there is an option to show the checkbox to the left of the field, instead of right of it (in the values

column)
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7. Tags Pane

7. Tags Pane

Tags pane

(See the main Tags page for an overview of how the tagging system is implemented)

The Tags pane is where most of the interaction with Tags is typically done. There a 3 basic functions:

�. Manage the list of Tags (add, edit, delete, rearrange)

�. Assign Tags to items

�. View items having a given Tag (or set of tags)

The Tags pane has a number of additional features:

Search, Sort and Filter Tags, useful as the number of Tags increases

Display options (flat list view, tree view, auto-sort, item count, archived tags)

Tag Inheritance

1. Adding / Editing / Deleting / Rearranging Tags

To create a new Tag, press the Insert key (or right-click > Add Tag)

Double-click on the blank area below the tag list can also be used to create tags

To create a child Tag, select the parent Tag and press Ctrl + Insert (or right-click > Add Child Tag)

In both cases, an input box is shown to enter the Tag name

Tag names should be unique but do not need to be (Tags are identified by a unique numerical ID, not by their name)

Tag names cannot contain the following characters: , ; # [ ] tabs and spaces
Tags that have the same name have a  !   icon after the name

Multiple tags can be created (enter a comma separated list of tags in the input box)

To edit tag names, press F2 (or right-click > Edit Tag)

To delete tags, select one or more tags and press the Delete key (or right-click > Delete Tag)

In tree view, tag hierarchy can be modified using cursor keys (up / down / left / right) while holding the Alt key

2. Add / Remove Tags to items

The Tags pane is the primary method to add tags to items. To tag items:

Select one or more items. Some UIs allow multiple selections (Grid, Calendar, Surface), other only allow single selection

Find the tag in the Tags pane and toggle the check-mark using the mouse or the space bar key

To help you quickly find tags, the pane supports filtering (see next section) and Search-as-you-type. Press F3 for the next occurrence and Esc to

cancel search

3. Using the Filter text box
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The top of the Tags pane shows the Filter text box.

Hit Ctrl+F or use the up cursor key to scroll to it

Enter some characters and the tag list will automatically filter

In tree-view, the list maintains the tags hierarchy, so parent tags are shown, even though they do not match the filter

In tree-view, the tags hierarchy will automatically expand to show matching tags. 

The pre-filter expand state is saved. So removing filter will show the tree as it was before filtering

Child tags of matching tags are hidden when inheritance is set to None

While focus is still in the Filter text box:

If more than one tag matches the filter, use the down arrow to move focus to a tag and press Space to toggle the tag state

If only one tag matches the filter, press Enter will toggle the tag state

If no tag matches the filter, press Enter to show the Add Tag dialog

Click the Filter icon, just left of the text box to clear the filter 

4. Showing Items

Of course, the whole purpose of a tagging system is to show items that have a given tag or set of tags. That is, out of all the items in the IQBase, show

only those that have certain tags.

Single Tag

In this simple scenario:

�. Select one tag (click on the tag text, not the check-mark)

�. Double-click on a tag or hit Enter (or right-click > Show Items)

�. If a grid that has this tag as a source, it will open, otherwise, the Scratch grid will open. The grid will show all items having the given tag

Multiple Tags

When selecting 2 or more tags, the items shown can be:

All items that have all the selected tags, or

All items that have one of the selected tags

Right-click > Logical AND / OR to select the output mode. 

When the grid opens, notice how the grid source reflects that choice. The source can be manually edited to do more fancy filtering, using multiple

AND, OR, NOT. 

You can also filter the result to only items that are also shown in a given grid. To do so:

�. Open the grid

�. Switch to the Tags pane

�. Select tags

�. Right-click > Show Items (Grid Subset)

5. Tag Inheritance

Tags have a major feature that fields do not: Inheritance. This means that a parent tag inherits the state of a child tag.

Consider this hierarchy of tags

Animals

Mammals

Feline

Lion

Cat

Canine

Dog

Wolf

Invertebrates

Frog

Pets

Cat

Dog

Wild



Frog

Lion

Wolf

Now, lets assume these items, and tags:

Lassie: Dog

Snoopie: Dog

Garfield: Cat

JackTheWolf: Wolf

Simba: Lion

Notice how tags Cat, Dog, Frog, etc are under 2 parents: under Animals/../.. and under Pets. This means that assigning the tag Cat to Garfield, also

assigns it to Feline, Mammals, Animals and Pets

The Tags pane reflects this inheritance, showing a small check-mark for inherited tags. When the focus is on the item Garfield, the Tag pane shows:

Hint:

At times, Inheritance can get in the way and return too many items. In such cases, it is possible to set the Inheritance Depth (None, 1 through 9,

All)

When set to None, IQ Tags function like most other tagging system, returning only the items explicitly tagged

The Tags pane reflects this Inheritance depth setting

Inherited tags are also shown in Flat-view

See the Tags Grid section of  main Tags page  to find out how to set a tag under 2 or more parent tags

Using Inheritance

With Inheritance, the search can show items that have not explicitly been tagged with the selected tag, but with a sub tag, sub-sub tag and so on.

In the above example:

Selecting Feline should give Garfield and Simba (even though neither of these items have the Feline Tag explicitly)

Selecting Pets should give Garfield, Lassie and Snoopie

Selecting Feline and Pets should give Garfield

Selecting Wild and Canine should give JackTheWolf

6. Copy / Paste Tags between IQBases

It is now possible to copy tags from one IQBase and paste it in another:

�. Set the Tags pane to Tree View (Copy / Paste does not work in Flat View)

�. Select one or more tag branches or press Ctrl+A to select all tags

�. Right-click > Copy Tags

�. Switch to the other IQBase

�. Right-click > Paste Tags
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7. Viewing Options

Tree-view shows a hierarchical list of all tags. If a tag has 2 or more parents tags, it will be shown under each

Flat-view shows an alphabetical list of all tags. Tags that have sub-tags have nevertheless expand buttons to reveal the sub-tags. 

This means that the same tag can be shown more than once: In the main list, and under each of its parents

Item count for each tag can be turned on/off. When off, they still show on mouse-over when holding the Alt key

Tooltips displays information about the tag under the mouse pointer. Use View > Tooltips to turn On / Off. If Off, hold the Ctrl key to display

tooltips

To quickly get to tags, there are commands to Expand a branch, Expand all and Collapse all

The Tags pane has column headers. Click on a header to sort (by name or by number of items)

Locked at the top of the tag list, are the current item tags

8. Context Menu

Show Tags in Grid: Shows all assigned tags in a grid column

Show this tag in Grid: Shows a specific tag branch in a grid column

Copy Tags: Copies the selected tags (and sub-tags) to the clipboard. 3 clipboard formats are used

Text: to paste in a text editor

Tab-Indented: To paste in a grid and create a hierarchy of items (i.e. paste in the Tags grid)

Tags: Used by the Paste Tags command

Paste Tags: Pastes the previously copied tags and creates a new set of tags
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8. Home Pages

Home Pages

The Home Page is a customizable HTML page that is shown as a tab in your workspace, along side your Calendar, Grids, Surface, MindMaps and other

views. By default, it look as such:
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It lists:

Today's events

Links to your Calendar

Links to web pages

Links to Favorite and Marked items

Links to Favorite and Recently used Grids

Links to your Grid Groups

Clicking on any link will show the corresponding information

If more than one Home Page is defined, << and >> navigation buttons are shown in the upper right corner. Click these to switch to a different Home

Page.

1.0 Managing Home Pages

You can have as many Home Pages as you wish. For example:

One per project, showing project related information and links

One for work and a different one for home

Any other information such as FAQs

1.1 Adding / Removing a Home Page

Any item's HTML page can become a Home Page.

Managing Home Pages is done through the Document Pane. Simply select an item and in the Doc Pane, set Menu > File > Use as Home Page:

The Home Page will instantly update to show the current Doc pane content. 



To remove a page of the Home Page list, un-check Use as a Home Page.

1.2 Modifying a Home Page

Modifying the default Home Page

The Default Home Page is stored in User files Folder\HomePage.htm. In a future version, modifying this will be improved, but currently, the easiest way

is to follow these steps:

�. Create an item. Set the item text to Default Home Page

�. In the Doc pane, do Menu > File > Open and select HomePage.htm in your User files folder (See Tools > Help > About > Support to find the

location of the user files folder)

�. You can now use the Doc pane to modify it

�. Optionally, you can set that item as a Favorite, to easily refer to it later on (It will also show in the default Home Page, along side  your other

Favorites)

Modifying user Home Pages

To modify a user home page:

�. Show that Home Pane

�. To the right of the home page navigation buttons, click on the "..." button. This will show the page in the Doc pane where you can make changes

�. Click save when done.

�. Click on the Home Page and press F5 to refresh it

The Live-Search can show the list of your user defined home pages. Click on the Home icon to show these. Use the Doc pane to edit.

1.3 Editing Home Page Content

For Home Pages, the Doc pane can be one of 4 types:

Embedded content (default)

Local HTML file (Link to a local file)

Local MHT file (Link to a local file)

A web page

In terms of content, the main purpose of the Home Page is to provide links to pertinent information, such as relavant items, grids, pivot tables,

mapviews, etc. Links can be added using:

Tokens

Hyperlinks

1.3.1 Using Tokens to Create Links

the Home Page supports tokens which will generate content for you. Supported tokens are:

�. [AllGrids]: All grids, sorted alphabetically

�. [Calendar]: Hyperlink to the Calendar

�. [CurrentDate]: Today's date

�. [EventsToday]: Lists today's events

�. [FavoriteItems]: Favorites items

�. [GridGroup:Group1]: All grids that belong to grid group Group1. To set groups, enter a comma delimited list of groups in Grid Properties > Other

> Groups

�. [GridGroups]: List of all grid groups

�. [Grids]: List of grids as shown on the toolbar

�. [MarkedItems]: Marked items

��. [NbEventsToday]: Number of event today

��. [RecentGrids]: List recently opened grids, most recent first (Qty=15)

��. [WinUser]: Windows login ID

��. [RecentFiles]: List of recently opened files

��. [OpenFile:Prompt text]: Generates a hyperlink with "Prompt text" to show the Open File dialog

��. [NewFile]: List of templates to create a new IQBase

��. [NewGrid:Prompt text]: Generates a hyperlink with "Prompt text" to show the New Grid dialog 

��. [IQLogoLarge], [IQLogo], [IQLogoSmall]: Inserts the InfoQube logo, various sizes
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The following tokens generate lists that support expand / collapse:

[AllGrids], [Grids], [RecentGrids]

[FavoriteItems]

[GridGroup:Group1], [GridGroups]

Click on the ? button (between << and >>) to get the list of supported tokens

1.3.2 Hyperlinks

Enter some descriptive text

Select the text

Click on the Hyperlink icon (or press Ctrl + K)

Use the Hyperlink dialog to select the link :

More details on using the Hyperlink dialog

2.0 Using Home Pages

Using Home Pages is quite simple. In can be used in a number of ways, but the 3 most common are:

�. Always visible vertical tab group

�. Only visible when active

�. In a pane

2.1 Always visible

Set the Home Page tab in a group of its own, with grids and other view in one or more groups to the right:

Hyperlinks in the Home Page will be shown in the right group.

2.2 Only visible when active

Set other grids and views in the same group as the Home Page:

Hyperlinks will open in the largest group. Press Alt + 1 to show the Home Page. Press Alt + 1 again to return to the current tab.

2.3 In a pane
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To view the Home Pane in a pane

�. Right-click on the Home Pane tab and select Detach

�. Once detached, the pane can be manipulated like any other pane

(i.e. can be set to be fixed, floating, hidden, etc). Details here

2.4 Navigating between Home Pages

To show the next Home Page:

Click on the >> button

Double-click

Alt + >

Ctrl + Right arrow

To show the previous Home Page:

Click on the << button

Double-click + any of Shift, Ctrl or Alt

Alt + <

Ctrl + Left arrow

2.5 Keyboard shortcuts

Alt + 1 to toggle between the Home Page and the currently active view

F5 to refresh the Home Page

Hints:

The program caption shows the active view: Home Page (Inbox). Press Alt+1 to return to the active view

The keyboard (Alt+1) shortcut can be changed, like any other command
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1. Omnibox

Using the Omnibox

The Omnibox is a small textbox normally located on the main menu bar:

It can be used to:

�. Search your IQBase

�. View Favorite items

�. Open Views (i.e. Grids, Calendar, etc)

�. Execute Commands

To activate the Omnibox you can either:
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Click in the text box, or

Hit the Omnibox shortcut key (normally Ctrl+Shift+F)

As soon as the Omnibox is activated, you can start typing. As typing is done, the Omnibox dropdown portion will updated:

Next, either:

Use cursor keys to select an entry from the list and hit Enter

If on the first entry, the Live-Search window will open with the search results. Details here

Otherwise, the entry will be executed

Click on an entry to execute it

Example of use:

Bold items (Ctrl+F, bold, Enter)

Open the InBox grid (Ctrl+F, inbox, Enter)

View a Favorite item

Search your IQBase using Live-Search

Tips:

�. You can restrict the output list to a specific type by adding a prefix:

/s : only do search (i.e. /s calendar to search for the word "calendar")

/f : only favorites

/v : only views (/g does the same thing)

/c : only commands (i.e. /c bold)

�. To Filter / Search for information in the current grid, you can:

Filter : Grid > Column Filter > Grid Column Filter....  (Ctrl+G) is the fastest way to filter the current grid. Enter the text and enter. You can

also use Column Filters. Details here

Search: Grid > Auto-Search (Ctrl + F3) and start typing. F3 for the next occurrence. To turn off, you can:

Toggle the Auto-search command (Ctrl + F3),

Press Escape, or

Start editing (F2)

�. You can turn off sections of the Omnibox results list. Use Tools > Options > 1.3.10 (Omnibox Results include)

�. The new Find / Filter dialog can also be used to find items
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Item Editor / New Item dialog

 The Item Editor is an always accessible UI to view / edit / create items. This includes:

Item text (or item name)
Doc pane content (long-form content associated with each item)
Commonly used fields, such as Inbox, URL, Due Date
Yes/No fields (i.e. folder-type fields)
Tags

Often items are entered directly in the view (Grids, Calendar Surface, etc). It fast and efficient.

At times however, either you are not in IQ, or not in the right place or you just want to have a larger window to add the new item. The New Item dialog

is a great tool then:

When in IQ, Edit > New Item (Ctrl + N)

When IQ is running but you're in another app (i.e. word processor, browser), press the New Item hotkey (Win + N by default)

The dialog is non-modal, meaning that you can leave it open while doing other things inside IQ

Multiple New Item dialog can be opened at the same time. Great to collect information from various sources

It also used by the Universal Clipper. Details here: 1. Clipping Content from other Apps

The dialog is divided in 4 main sections

�. Top: Item text

�. Middle: Options, common field assignments and the list of tags and fields selected

�. Bottom: Doc pane content

�. Right: Tags and Fields pane

1. Item Text

Use Alt + Up / Down arrows to change the edit box size

Alt + I moves focus to the item text

2. Options and Field Assignment

URL field: If another item already points to the same URL, the text box will be shown with a  yellow  background

Copy URL content: If checked, the whole page will be imported (i.e. not what you entered in the bottom section)

Save as MHT: MHT is a single file format for HTML content. Details here and here: Using MHT Documents

Add clipping info: Details here: Configuring the Clipping Footer

Assign to ...
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Inbox: Item will show in the Inbox grid (at the top of the list)

Current Grid: If the current grid has a simple source, check this to have the item automatically show in this grid

DueDate field: Add a date for this system field

3. Doc Pane Content

The Doc pane content is entered a WYSIWYG editor, similar to the Doc pane editor. Details here: 4. Document Pane

4. Tags and Fields

The right section shows 2 collapsible panes to assign tags and fields. Alt + T and Alt + F moves the focus to these panes

4.1 Tags Pane

Use it to assign tags to the new item. Filter and Auto-search tag list. Space bar to check / uncheck tags

Same features as the Tags pane. Details here: 7. Tags Pane

4.2 Fields Pane

Use it to assign fields to the new item

Similar features as the Tags pane (sub-set of)

5. Email Item to IQ

When EmailToIQ is enabled, it is possible to send the item by email instead of directly.

The advantage, is that a copy of the content will be in your email server.

Using GMail for example, with its outstanding search capability, allows user to find IQ related content withing GMail.

Notes:

When on a mobile or when IQ is not running or available, EmailToIQ can be used to do something very similar. See 2. Send To InfoQube using

EmailToIQ
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3. Popup Editor

3. Popup Editor

Using the Popup Editor

The Popup Editor is a WYSIWYG editor to edit items and other text fields.

It is generally accessible from the main menu and context menus. The default keyboard shortcut is Shift + F2

It can be used from the following UI elements:

Grids (text cells and header caption)
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Calendar

Surface

MapView

Properties Pane

1.0 Formatting

To format text, you can use:

Formatting toolbar

With text selected or not, right-click to show the context menu. Supports all formatting options:

 In addition to formatting text, icons can be inserted using the context menu.

Keyboard shortcuts, such as Ctrl + B for Bold, Ctrl + K for Hyperlinks, etc

2.0 Tips

The Popup Editor window is re-sizable. It can also be moved. To move it, click in a blank area and move it.

When editing grid header caption, the Popup Editor is in single line mode. Press Shift + Enter to add a carriage return

_____________

As of v115, On-screen keyboard and Handwriting recognition have been removed

2.0 Entering text

A physical keyboard is typically how content is entered. Windows 8 and up users can also use the Touch keyboard.

The Popup Editor supports 2 alternative input methods: On-screen keyboard and Handwriting recognition.

2.1 On-screen keyboard

Click on the keyboard icon to show it. It is located on the bottom-left side of the Popup Editor window.



2.2 Handwriting recognition

Windows versions supporting handwriting input are Windows XP Tablet PC Edition, Windows 7 and, of course, Windows 8 and up.

Click on the pen icon to reveals the handwriting input pane:

The handwriting panel can be used with any pointing devices:

Mice and trackpads

Touch screens

Capacitive pens

Active pens

Active pens provide the best experience of course.

Selecting your input device

To select the input device, hold the Shift key and and double-click on the panel. Once selected, handwriting can be entered. 

Handwriting

Write one or more words on the panel. Ink will be shown as you write.

After 1 second of inactivity, the handwriting recognition will take place and ink will be replaced by characters.

Enter as much or as little as you want.

To select text, long-press and drag

At any time, you can click on the Paste icon to move the text to the upper pane (ensure you set the caret, or insertion point, first)

The handwriting panel also supports keyboard input, should you need it for special characters or other editing

Gestures

The handwriting panel supports gestures:

New line :  ,  Space :   and Backspace : 

All input devices can be used for gestures, not just the selected one. 

This can be useful sometimes. For example, say you're using a pen for handwriting and you want to enter a space. 

You could use it to perform the gestures but if it isn't just right, it may be interpreted as handwriting. 

By using another input device, say the touch screen, ensure that it is recognized as a gesture and not as ink. 

Languages and language packs

Windows support handwriting recognition for many language, including Chinese and other Asian languages.

To see which languages are installed or to install new ones, open the Control Panel to Control Panel\All Control Panel Items\Language\Add

languages

Adding a language is a 2 step ladder :

https://msdn.microsoft.com/en-us/library/ms839533.aspx


�. Adding the Language: (no download required) Includes spell checker and word recognition

�. Adding the Language Pack: (large download required, 180MB and up). Includes Windows UI language and language specific handwriting

recognition. 

For example without the French language packs, words like "c'est" or "aujourd'hui" are not recognized properly because of the " ' ".

Asian languages absolutely require the language pack, as expected.

To learn how to install language packs, see: https://support.microsoft.com/en-us/kb/2607607

To switch language, click on the language button on the Taskbar or swipe from the right to reveal the panel (Windows 8 and up Touch screen) 
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4. Forms

Using Forms

Forms are a user-defined group of fields, shown vertically in the Properties Pane, in a specified order.

Forms allow you to view / edit / add items. You select the fields and the order displayed in Tools > Manage Forms. You can have as many forms as

you wish.

Forms are great for data entry. Grids can also be used for data entry, but when the number of columns gets large, they can be cumbersome.

Forms provide an alternate way of entering information.

In addition, default values for each field can be defined for each form. So you can have forms for contacts, tasks, one for each project (for billing

perhaps).

Hint: The Form Manager is used to make changes to forms. The properties pane is to actually use forms.

The following screen shot shows them side by side:

..............Form manager ...........................................Properties pane......................
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1. Managing Forms

Use either Tools > Manage Forms or right-click on a form (in the Properties pane) to open Form Manager.

In the Form Manager, you can:

Add / remove / rename / re-order Forms. Click (New form) to add a form.

Add / Remove / re-order fields. Click (New field) to add an existing field to the form.

Set the default values for each field. The default value is used when applying a form. See below

1.1 Re-arranging Forms and Fields

To re-arrange forms and fields, you can use the standard keys: 

Ctrl + Left / Right to open / close forms

Alt + Up / Down to move forms and fields

Delete to delete forms and fields

Drag-drop fields within forms

1.2 Defining the Default Values

The default values will be set for the specified fields when creating items / sub-items or when the Apply Form icon   is clicked

You can enter equations as the default value e.g. to have a form ask you to enter a value, simply enter =inputbox("caption", "dialog title")

https://infoqubeim.com/drupal5/index.php?q=node/128


For text field, simply enter the text string

For dates, =Now gives the current date and time, while =int(now) gives the current date

For yes/no, =-1 is checked, leave blank for unchecked

Tags can be assigned. Enter the list of tags as default value for the ItemTags field (format: #Tag1 #Tag2 #Tag3 ...)

When referencing fields, enclose these with square brackets (i.e. [SomeField] )

In the above screenshot, form Invoice:

Date will be given today's date

HrsRate = 50

Invoices is checked (=-1 is checked)

Item = "Invoice"

When you're happy with your forms, click OK. The Properties pane will be updated.

2- Using Forms

In the Properties pane, you'll find all your forms under the "Forms..." top level heading

Click on the form to expand / collapse the form content

By default, opening a form does not close other forms. Right-click on Forms to change the behavior

When set to close other forms, hold the Shift key to open multiple forms

Forms fields are identical to other fields in the Properties Pane, except that YOU control which field is listed and in which order.

Values can be added / modified / deleted. Change is applied to all selected items.

2.1- Using the Forms Buttons

When you open a form, 4 buttons are displayed: 

Click the first one to add a new item to the current grid and apply the form

Click the second one to add a new sub-item to the current grid and apply the form

Click the third one to apply the form to the selected items in the current grid

Click the forth one to clear the form values for the selected items in the current grid

Tips: Holding Ctrl while moving the mouse shows Tooltips:

3. Forms and Grid Columns sets

Forms can also be used as column sets for grids. Using the Properties pane:

Right-click on a form and select Load Column Set

To restore the grid's native columns, right-click again on the form and select Unload Column Set

(or under Grids, right-click on the Current Grid item and select Load Column Set)

Column Sets are chosen using Column > Column Sets command

A form can be created from grid columns. See 6. Manage Grids Dialog for details

See 4. Grid Columns and Column Sets for more information on Column Sets

Hints:

To have a form show the Tags assigned to the focused item, add the ItemTags field

In addition to the Manage Forms dialog, many changes can be made directly in the Properties pane. This includes:

Add fields: Drag-drop a field from the All Fields section to the form. It is also possible to use the context menu to Copy / Paste fields to a

form

Remove Fields: Right-click on a field > Remove Field xyz

Move Fields: Drag-drop or Alt+Up/Down arrows

It is also possible to create forms using the Manage Grids dialog. Right-click on a grid > Save Columns as Form
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5. More Info Pane

More Info Pane

The More Info Pane shows detailed information on items and field-values. The same information is also shown as tooltips:

In views, such as grids:

Last modified date for the item and by which user

Item ID

Item text

List of Related items

All other field-values

In the Properties pane, over a field name (left column):

Field name

Field ID

Field Type

Number of field-values

List of forms showing this field

List of grids showing this field

In the Properties pane, over a field value (right column)

Field name

Field value

Modified date for that specific field-value and by which user

Using the More Info pane 

Do View > More Info Pane to show / hide the pane

Pane can be floating, docked or in auto-hide (same as other panes)

Right-click on the pane to toggle between two display modes:

Show Selected

Show Mouse-over

Only "Show Selected" mode displays Related Items

Press F2 to toggle between formatted and plain text view mode (or right-click)

Press Ctrl + C to copy the pane content (plain text, IQ and HTML formats)

Press SHIFT to freeze the pane content. Useful when moving the mouse to the More Info pane
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Date Editor Dialog

Items can have numerous date values (birthday, meeting, todo, done, etc).

These can be shown in a grid, as a grid column. They are also shown in the Properties pane.

Either way, the date value can be modified using the Date Editor dialog:

Click the arrows to change month

Click the month to show a dropdown of months

Click the year, to change year

Click on the red circle to select today's date

Dates can also include a time. Enter it in the text box below the mini-calendar

1. Showing dates in the Calendar

Use the "Show in Calendar" checkbox to add / remove the item's date to the Calendar.
 
All 3 types of events can be created this way:

If a time is specified, a scheduled event will be created.
If a time is not specified, then the ItemDuration field determines the type of event:

If the ItemDuration has a value, an unscheduled event will be created
If the itemDuration field is empty, an all-day event will be created

Click on Edit to show the Event dialog:

Details here
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7. Visual Basic Editor

Visual Basic Editor

Sometimes relations between fields cannot be defined by a simple equation. In such cases, the user can write a user-defined function. The required

parameters are passed to the function which calculates it output. For example, in the default template, the item color is automatically changed based

on an Urgency value (itself calculated)

ItemColor = CalcColor( [Urgency] )

CalcColor is itself defined by a VBScript equation::

Function CalcColor(Urgency) ' calculation of the itemcolor color code based on the Urgency level

if isnull(Urgency) then
CalcColor = ""

else
if Urgency < -10 then

CalcColor=""
elseif Urgency <=-3 then CalcColor="Yellow"
elseif Urgency <= 2 then CalcColor="Blue"
elseif Urgency <=10 then CalcColor="Purple"
else CalcColor="Red"
end if

end if

End Function

This way, as a task approaches its deadline it changes color from none, to purple, to blue, to yellow and finally to red indicating that it late. No user

intervention. Completely user-definable

Function Code Stores

VBScript code is store in three different locations:

�. System code: Supplied with InfoQube and updated with each new release. Read-only

�. User code: Generic functions created by each user. Common to all IQBases

�. Database code: Specific functions to a particular IQBase

In case of name conflict, the database code has highest priority, followed by user and finally, system code. This allows for worry-free function

overloading

VB Editor

The built in VB Editor can be used to view the functions that come with IQ or that you have added. Take a look at the built-in scripts already defined

and explore the many possibilities.



Function Development Tips

Full VBScript reference (from Microsoft) can be found here: https://msdn.microsoft.com/en-us/library/d1wf56tt(v=vs.84).aspx

All VBScript functions should return a value. If no value is returned, the function will return "Empty" and an error message will be pop-up

(Options setting to disable it). A useful return value is "Null" which is different than 0 or an empty string. Null will clear the field value. See also

the section above on "Hierarchy Equations with Parameters" how Null is used.

All string functions are case sensitive by default. To do case insensitive comparisons, use (1) LCase/UCase or (2) set the function compare

parameter to 1 (0=case sensitive, 1 = case insensitive)

Unfortunately IQ's built-in VBScript tools are very basic and its not very good at letting you know when you have made a mistake. A recommended

practice is to write and test your functions in another tool with better support then then when you have it working copy it to IQ.

IQ uses Microsoft's VB Script engine. See this page on stack overflow for tools that work with VB Script.

One good approach is to use the VBA (VisualBasic for Applications) Editor built right into Excel. It gives you full highlighting, code completion, and

debugging. Note that VB Script is a subset of VBA, so there are some things you will need to avoid in the code you copy to IQ (see

http://www.activecallcenter.com/manual/249.htm the main differences).
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8. Image Viewer

Image Viewer

The built-in image viewer is useful to view

�. items linked to image files and,

�. items showing a folder in the HTML pane
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9. Status Bar

Using the Status Bar

The Status Bar is shown at the bottom of the InfoQube's main window. Use View > Status Bar to show / hide it.

It is divided into 9 sections (from left to right)

�. Lineage and other "status-type" information (non-intrusive messages)

�. Higher importance messages (shown with a bright yellow background)

�. Timers. See Using Timers below for details

�. Google Calendar Sync button and status: Click on the icon to start a manual sync with your Google calendars. All enabled calendars will sync

�. EmailToIQ button and status. Details here

�. Arrow keys behavior when editing in grids: When ON, arrow keys will never terminate editing. When OFF, editing will end when the cursor

reaches a boundary

�. Overtype mode: Details here

�. Current Date

�. Current Time

Section 1 is the widest section on the Status Bar. It is used to show a large number of messages and status, depending on the view, such as:

Event information when in the Calendar

Item lineage in other views (see details below)

The number of selected items in Grids

Zoom changes
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Countless other bits of information !

Section 2 is bright yellow: 

(not shown in the above screen shot)

This section shows messages of higher importance than section 1.

It is also possible to cancel some operation by double-clicking on this section, such as:

Cancel or postpone recalculation of fields which are date dependent (as this can be lengthy for large databases)

1. Showing Item Lineage and Related Items

The Status Bar can show the current item's Related items and lineage (i.e. the item parent, grand-parent, etc.)

Each item is shown as a hyperlink. Click on the hyperlink to instantly go to that item.

There are 6 display modes. To change mode, double-click on the section:

�. None: Lineage is not shown

�. Related Items: List items related to the selected item or items. Details here

�. Parent -> Child: Starting from the item, the main parents tree is shown, from right to left

�. Child -> Parent: Same as the above, but in reverse order. To ease navigation, the item itself is not shown

�. As viewed: Shows the parent tree as displayed in the grid. This may be different than (2.) above when:

Context Parent display is turned off or set to just a few levels. Details here

Grid is hoisted

Grid display mode is not set to Normal (i.e. set to Flat or Tree views)

Items have multiple parents. The parent shown in the grid may not be the main parent

�. Inverse view: Same as the above, but in reverse order. To ease navigation, the item itself is not shown

Hint: Double-click cycles through the above modes (1 > 2 > 3 > 4 > 5 > 6). Press Shift while double-click will cycle in the reverse direction

2. Timers

Count-up timer(s) can be shown on the Status Bar area.

Use Tools > Options > General, “Nb of timers on the status bar” to set the number of timers (max of 6 timers)

Controlling Timers:

Start: single-click

Pause: single-click

Reset: double-click

Timers stop counting when the computer goes into pause (i.e. gone for lunch)

Timer values are preserved between session (program close, re-start)

Uses:

Track time spent on each project / task. Example would be consultants who get paid on an hourly basis.

(Often, such an individuals work on a many projects and are interrupted by phone calls and must work on something else and later on return,

etc)

Miscellaneous tasks, not computer-related, such as a tea timer

n.b.: There is no link between the counters and any fields, it is the responsibility of the user to enter the timed value in the proper project, etc.
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