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A Quick Introduction to InfoQube

InfoQube is an Information Management System that provides all the tools you need to simplify your life:

Calendar

Multi-column Outliner Grids

Gantt and Timeline Charts

2-D Surface

Card View

MapView

Pivot Table and Charts (when Office 2000+ is installed)

WYSIWYG Rich-Text, Markdown and Handwriting pane

Live-Search

Rather than forcing you to accept predefined categories, InfoQube gives you the tools to create your own organizational structure:

Record and view information in one of the many InfoQube views

Use InfoQube to cross-reference information and associate values with this information

Use InfoQube to collect Web clippings and use the built-in rich-text editor to edit this content

Share this information with other users

Increase Your Productivity with InfoQube

InfoQube can be used to easily perform many daily tasks which are complicated with current main-stream office-like suites:

Manage your appointments and meetings and add an infinite amount of notes specific to that item, using one of the 3 built-in

features:

User-defined Fields: Add text, numbers and dates values to each item

Rich-text Outliner: Add multi-level outlining notes using the built-in advanced rich-text outliner

WYSIWYG Word Processor: Add fully formatted text to each item (including support for bullets, images and tables)

Manage your contacts and sale leads using the Address Book:

Enter as little or as much details as you wish for each contact. No limits to the number of email adresses and phone numbers

Organize your contacts in hierarchy (Company > Contact).

Doing it this way, you only need to enter the Company phone numbers once and the built-in phone dialer will find this info for all

contacts under the company.

Contact specific phone numbers will be presented first, followed by Company ones.

Quickly find contacts using any combination of:

One-click alpha-numeric filter (e.g. to only show contacts starting with the letter F)

Search box: enter part of a name and hit enter to get a filtered list

Easy grid and column filters. Hit CTRL-G to filter

Auto-Search: Just type in whatever column and matching items will come in focus. F3 will move to the next item. CTRL-F3

to toggle

User-defined fields (Work, Personal, Due, Hot, etc)
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Sort your contacts by (all methods support multi-key sorts)

Clicking on the column header

Drag a column header to the Sort bar

The Sort criteria

Assign user-defined values to your contacts, to be used in filtering and sorting

Use field equations to automatically flag contacts:

Compute a value based on when the contact was last contacted

Flag contacts those in due of a follow up (i.e. x days after last call)

Flagged contacts can be shown in a separate list and/or color highlighted

Enter the new call (or email) information and automatically have the contact removed from this "flagged" list (if desired)

Enter outlining notes regarding this specific call to this contact

Assign tasks, appointments related to this call

Assign these to yourself or to co-workers

Manage your tasks more effectively:

In a work-group environment, view only your tasks, tasks you've assigned to others, etc

Use the Gantt Chart display to graphically view your tasks and:

Move tasks, change duration

Add dependencies simply by dragging a link between the two using the mouse (e.g. one task must be completed before

starting another one)

Only show tasks that you can do now (hide tasks that have non-completed dependent

Show work-load graph (helps getting extra resources and/or move tasks to avoid overtime and better predict delivery

dates)

In multi-user environments, view how tasks and info must move from one worker to another (using the Group By features)

Enter Due Date, Duration, Effort Required and %Done

Compute earliest delivery and critical path

Get tasks flagged when due date is approaching / passed (color coded)

See tasks start and / or stop in the Calendar

Manage all other types of info using InfoQube Grids:

Use InfoQube fields to organize information into virtual folders

Specify which folders are displayed in each grid

Organize the information in collapsible outlines

Hoist to focus on one or more branches

You can even put an item under many parent items

Use the new Surface View to emphasize specific items in 2-D:

If MS Office 2000+ is installed, you can use Pivot tables and charts to:

Compute monthly totals, project totals, etc

View aggregate info from different dimensions

Create visually pleasant charts
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Export these to HTML files to share with others and/or publish
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InfoQube Program Install and Set-up

InfoQube (IQ) comes in 2 flavors:

�. Installable (Win XP and up, Mac, Linux in Windows emulation)

�. Portable (Win XP and up)

The portable flavor is identical to the installable one, not a scaled down / limited one. It works in even the most secured / locked down work

environments / Internet cafés.

It can run from a USB drive, does not write to the registry or to any local file. It leaves absolutely no traces behind.

The portable flavor is in fact more immune to PC setup, so it will, in some cases, work correctly when the installable will not. These cases are

rare though and both flavors generally work correctly.

After reading this page, checkout Settings for best IQ experience

1. Using the Installable flavor

�. Uninstall any previous versions (using the control panel Add/Remove Programs)

�. Download the InfoQube Installer

�. As InfoQube is updated on a regular basis, using version-specific file names, your browser may issue the warning: "InfoQubexxx is not

commonly downloaded and may be dangerous". Click the arrow and select "Keep"

�. Unzip to extract the file setup.exe

�. (optional) In Windows Explorer, right-click on setup.exe > Properties and check the Unblock checkbox. Click OK

�. Run setup.exe. If the file was not unblocked in the previous step, Windows Defender SmarScreen may show a warning that the app

may put your PC at risk. Click "More info" and click "Run anyway"

�. If upgrading from a previous version, your settings will remain intact

2. Using the Portable flavor

�. Download the Portable InfoQube Zip file

�. Extract to any non-protected folder (local HD or portable). So do not copy IQ Portable to the Program Files folder !!! (e.g. Use

c:\SomeFolder, MyDocuments\SomeFolder, etc)

�. If you wish to have a desktop shortcut:

�. Right-click on the file InfoQube.exe, select - Send To > Desktop

�. You can drag this shortcut to the Quick Launch section of the Windows Start Menu

�. If you wish to add it to the Start Menu:

�. Right-click on the file InfoQube.exe and select Copy.

�. Right-click on the “Start” button and select either “Open” or “Open All Users” Then, open the “Programs” folder.

�. Right click on a blank space in the “Programs” folder and select “Paste Shortcut”

�. If you receive a security warning when starting or using InfoQube, either select "run anyways" or better still, run the batch file

UnblockIQPortable.bat
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�. When upgrading from a previous version, simply paste the content of the zip file to the previous version folder and overwrite the files.

Your settings will remain intact.

 Once installed, the following folder structure should be present (folder "InfoQube" may be named differently, depending on where you

installed it):

InfoQube

AppData

AppFiles

Controls

Icons

Users

Installing patches

Between versions, patches are sometimes available. To install these:

�. Download from the patch (same link as above)

�. Since the file is less common, browsers will likely flag it as suspicious. Click Keep (or Open) :

�. Locate the main program folder (use Tools > Help > About > Support Info to find the program folder)

�. Close IQ if it is running

�. Open the zip file (which was most likely saved in your Downloads folder)

�. Copy paste the InfoQube.exe file from the zip file to the main program folder

The default database engine is MS JET 4.0. InfoQube also supports using MS ACE 12. To use this newer engine:

�. Install the MS 32-bit Access 2010 Runtime from here

�. Download the ACE specific patch (may not be as up to date as the regular patch)

�. Unzip and overwrite InfoQube.exe as per above

�. n.b. In every day uses, there isn't any advantages to using the ACE engine, so most users should stick with the stock one.

It is provided as an option to be used in rare cases where issues are found with the JET

3. Installing Visual C++ 2008 redistributable

Both flavors required that Visual C++ 2008 redistributable package be installed (VC++ 9.0). The VC++ 9.0 runtime is typically already pre-

installed on Windows computers, but for older computers it may not be. If not, you'll receive a registration error message (Installable flavor)

or a program lockup (Portable flavor).

To fix, download and install the VC9 redist from here: http://www.microsoft.com/en-us/download/details.aspx?id=29

4. Installing the IQ:// URI Protocol

InfoQube has support for universal links (a.k.a URI protocol links) in both direction (from other apps to IQ and from IQ to other apps).

To link to specific IQ items and views, the following key is added to the registry: HKEY_CLASSES_ROOT\IQ

Windows Registry Editor Version 5.00 
[HKEY_CLASSES_ROOT\IQ] 
@="URL:InfoQube Folders" 
"URL Protocol"="" 
[HKEY_CLASSES_ROOT\IQ\DefaultIcon]
@="\"C:\\IQAPPFolder\\InfoQubeClipper.exe\"" 
[HKEY_CLASSES_ROOT\IQ\shell] 
@="open" 
[HKEY_CLASSES_ROOT\IQ\shell\open] 
@="" 
[HKEY_CLASSES_ROOT\IQ\shell\open\command] 
@="\"C:\\IQAPPFolder\\InfoQubeClipper.exe\" /select %1"

The setup package includes a utility to make these changes automatically. Run IQURIProtocolInstall.exe to install the IQ:// protocol.

5. Installing the Help File
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To install a local copy of the Help file, follow these instructions: InfoQube Documentation: Main Page

The local Help file is however outdated. It is recommended to:

Use online help (this web site)

Open the Welcome to IQ database (updated with every release)

6. Installing Microsoft Web Components

If you have Microsoft Office installed (2000 - 2003 and up), InfoQube can use its Pivot Tables and Charts. These are great for data analysis

and reporting.

2 cases:

Office 2000, 2002 (XP) or 2003 is installed: The Office Web Components are already installed

Office 2007 and up: The Office 2003 Web Components can be downloaded here (local copy)

See Pivot Tables and Charts  on how to use Pivot Tables and Charts

7. Installing Support Programs 

InfoQube can make use of external programs, such as:

Microsoft Word, BlockNote and WizHTMLEditor to edit MHT documents

StylusLabs Write to edit Ink documents

Inkscape to edit drawings (SVG documents)

7.1 Install MHT Editors

InfoQube lets you use any 2 MHT editors

To edit an MHT document with these, click on the corresponding button on the toolbar or press the shortcut key (Ctrl + W and Ctrl +

Shift + W)

Download and install any of these free MHT editors and enter the paths in Tools > Options > General > Document pane > MS Word /

Alternate MHT Editor:

BlockNote can be downloaded here and here (local copy)

WizHTMLEditor can be downloaded here and here (local copy)

Kingsoft Write Free 2013 can be downloaded here

7.2 Install Ink Document Editor

InfoQube uses StylusLabs Write (free) as its Ink editor. Write is described as a Word processor for handwriting. Its support for ink is

outstanding. See Using Ink Documents (handwriting) Using Ink Documents to learn more on the Ink Editor

To install the Ink Editor:

�. Download zip file. 2 versions are available: v2.02 (link) and v2.09 (link). v2.09 has a few issues, so it is recommended to use v2.02. Both

can be installed at once, in different folders

�. Write is a portable App. It is therefore recommended to:

�. Create a folder C:\PortableApps

�. Create a sub-folder StylusLabsWrite

�. Extract the content of the zip file into this folder

�. In InfoQube, do Tools > Options > General > Document pane > Ink Editor path. Point to the above path and select Write.exe. Click OK

�. Write is also available as an installable program, so instead of steps 1 and 2 above, you can download and install the setup

available here. It is however the most recent version, which has a issue with the "single file" mode. So this is not the recommended

approach

�. To view Ink documents, the Document pane must be using IE 9 or above (see Program Settings and options 10. Program Settings and

options)

Configuring the Ink Editor
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To configure Write, start the program and click on the 3 vertical dots on the right of the window and select Preferences. Select "Show

advanced preferences". The dialog will now show the following sections:

�. Input

�. User Interface: see below

�. Document List

�. General

�. Ruled Tools

�. Performance

�. Advanced

Recommended settings if you have an active pen are:

�. Input: Mouse Input=Pan, Single-touch=Ignore, Multi-touch=Pan, Smoothing=10

�. User Interface: Return to previous tool: uncheck

Click on Edit Toolbar and drag-drop icons to customize the Toolbar, typically adding:

Save

Create Link

Full Screen

Pan

Pen Color

Create Whiteboard and Open Whiteboard (if you plan to use the new real-time collaboration on Ink documents)

�. Document List: Uncheck Prompt before saving and Reopen last

�. General: Check all except Auto grow page right and Display time range. Set View mode=Vertical scrolling

�. Rules Tools: Check all. Column detection=Normal. Minimum reflow=0.30

�. Performance:

�. Advanced: Check all except Check for updates. Set File extension=shtml

Additional settings

Write defaults to saving files with images down sampled (to reduce file size). So if you later on increase the image size, you'll notice

significant image quality degradation.

You can change this by adding this setting in the Write.xml config file: <int name="savePicScaled" value="0" />.

The file is typically located in c:\users\YourUserName\AppData\Roaming\Stylus Labs

The toolbar customize UI is missing Zoom In/Out commands. These can nevertheless be added by editing the Write.xml file: In the

toolbar section, add actionZoom_In and actionZoom_Out

7.3 Install Inkscape (SVG document editor)

Inkscape latest version can be downloaded here (official site)

In InfoQube, do Tools > Options > General > Document pane > SVG Editor path. Point to the above path and select Inkscape.exe. Click

OK

To view SVG documents, the Document pane must be using IE 9 or above (see Program Settings and options 10. Program Settings and

options)

7.4 Viewing PDF files

To display PDFs in the Document pane, Adobe Acrobat Reader must be installed. Version X 10.1.4 or 10.1.16 works fine. Steps are:

Download Acrobat Reader X from here

Install it

Open Acrobat Reader
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Edit > Preferences > Internet: Check Display PDF in browser (should be checked by default):

Edit > Preferences > Reading: In Screen Reader Options > Page vs Document, select Only read the currently visible page (Ref link)

On recent Windows 10 OS versions, this version of Acrobat Reader will crash after a few seconds. If this happens, click on the Adobe

Update icon on the taskbar and install the recommended update

When in IQ, if showing PDF documents brings up a dialog about Reading Order every time, close IQ and open the file in Acrobat

Reader. Select the above reading options and check to save this setting:

InfoQube is also compatible with more recent versions of Acrobat Reader (such as version DC). For such versions, the setting to view PDF

documents in browsers is with Internet Explorer:

Open Internet Explorer

Choose Tools > Manage Add-ons

In the list of add-ons, select Adobe PDF Reader

Click the Enable button

Additional info here: https://helpx.adobe.com/acrobat/using/display-pdf-in-browser.html

It is also possible to use Foxit PDF Reader instead of Acrobat. Download it here.

8. Installing the Extensions

Whether you're using the installable or portable flavors, you may want to install the extensions. These allow 1-click clipping into IQ.

If you choose not to install the extensions, the Universal Clipper can still be used to clip content into IQ. See Clipping Content from other

Apps 1. Clipping Content from other Apps for details

8.1 Install the Internet Explorer Extension

�. Close all instances of IE

�. In Windows Explorer, double-click on the file InfoQubeIEExtensionInstall.exe. The file is in the same folder as the main InfoQube

executable (InfoQube.exe). Alternatively, it can be downloaded here (unzip downloaded file and place content in the IQ folder).

�. Click Yes to confirm modification to the registry (you'll need admin priviledges to do this).

8.2 Install the Firefox Extension

�. Open Firefox (up to v56. Clipper is incompatible with v57+)

�. Navigate to this page: https://addons.mozilla.org/fr/firefox/addon/infoqube-firefox-extension/

�. Click Install.

�. Click on Restart Firefox
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8.3 Install the Thunderbird Extension

�. In Thunderbird, Tools > Add-ons and browse to the file InfoQubeTBExtension.xpi. The file is in the same folder as the InfoQube

program 

9. Registry Settings

IQ comes with a few registry tweaks files:

�. EMLRegistryFix.reg: Use this if EML files are not displayed correctly in the Document pane.

�. OutlookProtocol2007.reg, OutlookProtocol2010.reg, OutlookProtocol2013.reg, OutlookProtocol2016.reg: Use this if hyperlinks using

the Outlook protocol do not work (Outlook:UUID).

See this reference on how to tune this depending on the exact version of Outlook

To apply these: Right-click on this file and select Run as Administrator.

10. Copying user settings and IQ configuration files

Whether installing onto a new drive/folder (USB or other) or moving from Installable to Portable flavors, users will want to move their

settings with them. All settings are saved in the following folder:

Installable:

C:\Documents and settings\YourUserName\Application Data\InfoQube (XP)

C:\Users\YourUserName\AppData\Roaming\InfoQube (Vista and up)

Portable: Your IQ folder\Users\YourUserName

This folder contains the following files:

File Description

Dock.dat Configuration of the docked panels

HomePage.htm IQ's HomePage

HTMLClipperTemplate.HTM Used by content clippers. Details here Configuring the Clipping Footer

Menu.dat Your customization of the main menu

MenuHTML.dat Your customization of the Document pane menu

NewHTML.htm Default template for new HTML documents

NewInk.slink Default template for new Ink documents

NewMHT.mht Default template for new MHT documents

NewSVG.svg Default template for new SVG documents

Options.ini IQ options (Tools>>Options>>Program Settings)

Settings.ini Window sizes, Dialog settings and values, etc

User.vb User specific VBScript code: View>>Visual Basic Editor>>User Code

You may choose to copy all or only certain of these files

Pierre_Admin 2018/10/01 20:44

185 views

Beginners' Guide

Beginners' Guide

InfoQube Beginners' Guide

InfoQube is so customizable that it can be daunting, at first, to know how to start. Kind of like the blank page anxiety for writers...

To help get started we've put together a collection of beginners' guides, many of which were written by actual users after they

had experienced that "Aha!" moment.
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All users are encouraged to submit guides and/or contributions to existing ones. These are not arranged in any particular order, so scan

through these and explore the ones that seem to best describe what you want InfoQube do for you.

Title Category Author

Getting started Start InfoQube

Writing an outline Outliner Cyganet

Making a grid with columns Grid, Table, Sheet Cyganet

Items, Values and Views Data, Viewing data InfoQube
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Getting Started Guide

1. Starting InfoQube

On startup, InfoQube will show the Start page:

2. Create and Open an IQBase

InfoQube is a file-based application, so the first step is naturally to open / create a new file (i.e. IQBase)

Options are:

New blank IQBase

New IQBase: with sample data
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New IQBase: copy of the Welcome to IQ file containing the full user manual

Open an existing IQBase, such as the Welcome to IQ file. File > Welcome to IQ

When saving the file, select a non-protected folder, such as your Documents folder or sub-folder of it

Do not save the file to a protected folder, such as a folder under Program Files

When opening an IQBase, the Home page may be displayed (setting in Tools > Options). The Home page is a convenient way to access

content. Details here

3. Entering Information

Grids are the primary user interface to enter content:

To create a grid, click the last workspace tab (+) or do View > Grids > New Grid...

To open an existing grid, do View > Grids and select one from the list

If you started with the sample IQBase, there are already a large number of grid available (Inbox, AdrsBook, Project, etc). To open an existing

grid:

View > Grids >

This list can be detached by grabbing the (.............) header and docking to a side of the main window. 

If you're just starting, it may already be docked to the left side

Let's open the Inbox grid:

You'll see a flat list of items, with a set of properties:

Above the grid, the source says that items are coming from Inbox. Inbox is a field and any items with this field checked will show here

(unless another filter is applied).

4 items are shown

The main item text is stored in the Item field

The next column is the Inbox field. All items have this checked or otherwise they would not be shown. To remove an item, uncheck this

field

DueDate has a dropdown to select a date (and other options)

The next 4 columns show check boxes and are linked (using their field properties):

Today and Tomorrow are mutually exclusive

ThisWeek is checked if either Today or Tomorrow is checked

Checking NextWeek will unselect all 3 other fields

4. Creating a Shopping List

If you started from the sample IQBase, there is already a Shopping List grid created for you. Otherwise do:

https://infoqubeim.com/3445


View > Grids > New Grid: 

We'll call it "Shopping list"

You'll then be presented with a blank page (i.e. a grid). Notice how the grid tab will show the grid name, and the number of items in the grid.

You are now ready to enter your information. Simply start typing and hit enter to create the item and move onto the next.

IQ auto-switches to edit mode as soon as you start typing. Alternatively, you can click on some text or press F2 to start editing

Next, you'll want to add some additional columns. There are many ways to add fields as column. We'll use the Column > Add / Remove

Column command (or right-click on a column header)

Go to "Done" and check it, then click OK.

The grid now shows 2 columns

To mark items as done, do Item > Mark as Done  (Ctrl + M)

In the sample, 2 items are already marked as done. Done items can be shown with a different color, in this case it is set to a pale grey

background:

Last step of this tutorial is that you may want to hide items that are done. There are many ways to do this, but the simplest is to use the

column filters:

Hover over the column header and click on the column filter button (right edge of the column header) and click on (blank)

Notice that a filter icon is displayed on the Done column to remind you that a filter is applied.

There is also a yellow band at the bottom of the grid, showing the current filter

To turn off the column filter, you can click on the X on the yellow band or on the Column Filter button (main toolbar and Grid menu)

The Column filter button is a toggle button (split button), so you can toggle between filtered and non-filtered view by pressing on this

button



 5. Your Next Steps

Writing an outline

Using Grids

Using the IQ Calendar

The Document pane

Documentation Table of Content
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InfoQube for beginners: Writing an outline

by Cyganet, originally published in a user blog in May 2020

Introduction

Hello and welcome! Are you new to InfoQube? I'm a newcomer as well, and I wrote this guide to help someone like me who has no previous

experience with InfoQube get up and running instead of getting stuck on the learning curve. InfoQube can be intimidating because it can do

so much. It's easier to start by doing something simple and getting a feel for how it works.

Here is a step-by-step guide to writing, organising, formatting and exporting an outline in InfoQube. I use the keyboard a lot - we're in the

middle of writing an outline after all - so this guide is full of keyboard shortcuts. There are often other ways to do the same thing (menus,

toolbar buttons, right-click, other panes) that I have skipped in this introduction.

InfoQube is very easy to use as a powerful outliner. You can write a document with unlimited levels of hierarchy, outline styling and

numbering, rich text formatting, hyperlinks and embedded images. To keep it simple, we are going to start by writing in plain text. We will

use the Lite version of the program, InfoQube Outliner, to get started. The steps described here apply to both versions of the program.
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Install and start InfoQube Outliner

Go to the InfoQube download page and download the latest portable version of InfoQube Outliner. Extract the zip file to a non-protected

folder of your choice. The download page has more instructions if you need more help.

Start InfoQube Outliner. You will be greeted with the welcome page. We first need to create a new IQBase. Click on "Blank IQBase" or

"IQBase (with sample data)", whichever you prefer. Name and save your database file.

Create your outline grid

Go to the menu bar, click on View > Grid > New Grid (or click on the + tab). Enter a name for your grid and click OK. For example, you can

name it My Outline. Spaces are allowed in grid names.

You will now see a blank grid with two columns: # and Item. # is the row number in the grid. Item is where you will write your text. There is

one item in the grid, and it is highlighted.

Plain text outline

Write your outline text

You can start writing in the highlighted item by simply starting to type while the cell is selected. If there is existing text in the cell, it will add

the text to the end. Hit ENTER to submit your text.

Hit ENTER again to create a new item below the item you just edited. Then start typing in the new item. Repeat as often as necessary.

To add an item above your selected item, hit ALT+ENTER. To add a child item to your selected item, hit CTRL+ENTER. To indent/outdent your

selected item hit TAB/SHIFT+TAB

ENTER, ALT+ENTER and CTRL+ENTER operate at the same level of hierarchy as your selected item, so you can add a new item below an item

with child items by hitting ENTER while that (parent) item is selected.

Your outline is automatically saved as you write.

Edit your text

Hit SPACE on a highlighted item to enter edit mode with the cursor at the end. This will not add a space to the item text. Then you can start

to add text. Hit ENTER to submit your edits. If you do not wish to keep your edits, hit ESCAPE.

You can also enter edit mode by double-clicking on the item cell or pressing F2. F2 or double-click puts the edit cursor at the beginning of

your text. Hit END to move the cursor to the end of the line. In a multi-line item, it will go to the end of the first line and can be moved down

with the arrow down key. Inside edit mode, the standard shortcuts for select all, cut, copy, paste (CTRL+A, X, C, V) all work as expected.

To delete an item, hit CTRL+D, then hit 1 to delete it entirely. Hit ESC or 4 to cancel deletion.

Spell checking is available but needs to be enabled in the program options. Go to the menu bar and click Tools > Options. Expand the

options list under 1. Program > Document. Hit the checkbox next to Spell Checking (Win 8+), then click OK. Restart the program. It will

reload the grid so you can continue where you left off.

http://www.infoqube.biz/download


Move around your outline

Move the selection with the up and down arrows to go to the previous or next item in the grid, regardless of hierarchy. Move the selection

with CTRL+up and CTRL+down to go to the previous or next item at the same level in the hierarchy, i.e. skipping the children. Hit

CTRL+Home to go to the top of your outline, and CTRL+End to go to the end.

Hit CTRL+right to expand your outline and CTRL+left to collapse it. This will affect the section of the outline that you are currently working

in. If you are inside a child item and hit CTRL+left, it will collapse its parent and move the selection to the parent. You can also expand and

collapse outline levels by clicking on the arrows next to the parent items.

If you want to see specific levels in your outline, a handy tool is in the menu Item > Sub-Items > Show Levels, or CTRL+SHIFT+L. To collapse

all headings pick All items, then click on 1. To expand everything, click on All. The Show Levels window can stay open while you write if you

unclick Auto-Close.

InfoQube stores a history of items you have edited. Click on the clock icon on the toolbar, or on the menu View > History. You can choose

Back, Forward, or pick a specific item in the history.

Reorganise your outline

To move an item's position in the outline, you can use ALT+arrow keys to move up, down, left (outdent), right (indent)

You can drag and drop an item inside the outline. Long-click on the item and start dragging it. You will see a red line indicating the new

position of the item in the outline. Release the mouse in the new position.

If you decide while writing that you want to split an item, position the cursor inside the item at the split position, then go to the menu bar

and click Item > Split Item, or hit CTRL+SHIFT+S.

If you want to join two or more items, select them using SHIFT-click or CTRL-click, then go to the menu bar and click Item > Join Items, or

hit CTRL+SHIFT+J. The order in which you select the items matters for the join result. The item selected first is the one that the other items

will be joined into. Child items are not brought along in a join. You will get a popup window with merge options. Check "Delete merged

items" if you want the original (separate) items to be deleted. If you leave it unchecked, you will keep the original version of the merged

items.

To delete an item, hit CTRL+D, then hit 1 to delete it entirely. Hit ESC or 4 to cancel deletion.

You can show the same item in multiple positions in your outline at the same time. You can edit the item at any position, and edits in one are

reflected in the others. You may have noticed that the text related to deleting an item appears twice. That is the same item in two different

places.

To show an item in a new position, select it and start dragging it like you would for moving it with drag and drop. While keeping the mouse

held down, hit CTRL so that a + icon appears next to the red line. Drag the red line to the new position and release the mouse, while keeping

CTRL held down.

If the drag distance is too far, here is another way to get to the new position. Select an item in the outline, then right-click and select Mark

Items, or hit CTRL+SHIFT+M. Then go to the parent item in the outline where you want to add the item, right-click and select Add as Sub-

Items

To delete an item in one position without deleting the others, select it and hit CTRL+D, then hit 3 to remove the item from this parent only.

Zoom in and out of your outline

There are two types of zoom. One is zooming in and out in terms of font size, to make the text easier to read. To zoom in, click on the

magnifying glass on the toolbar, then click Zoom In, or hit CTRL+SHIFT+=. To zoom out, click on Zoom Out under the magnifying glass, or

hit CTRL+SHIFT+-. To reset the Zoom, click on Reset Zoom under the magnifying glass, or hit CTRL+=.

The other type of zoom is zooming into to edit one section of your outline, also known as hoisting. To start hoisting, select the parent item

that you want to zoom into, the go to the menu Grid > Hoist Items > Hoist Selected Items. On the toolbar, the filter with the letter H next to

it will be highlighted, so you know you are in a Hoist. Under that filter, you will find the same menu options, including Toggle Hoist On/Off

(CTRL+ALT+H), which allows you to move back and forth between the Hoisted and the full outline.



Search your outline

To find text inside your outline, hit CTRL+F, type the search term in the Omnibox, then hit ENTER. This will bring up the live-search grid (the

one with binoculars in the tab heading).

You can look through the results to find the item you are looking for. Then click the blue underlined link in the "Show In" column. That will

take you to the item inside its grid.

So there you have it, all you need to know to make a plain text outline! If plain text is what you want, you can stop reading and get started on

your own outline now.

Rich text outline

If you're interested in a more content-rich outline, InfoQube also has options for formatting, highlighting, styling, numbering, linking, and

adding images.

Format and highlight your text

The grid supports rich text formatting inside the item text. When typing inside the grid, you can apply bold, italic, underline, strikethrough,
superscript,  subscript,  font colour, highlight and background colour using the buttons on the formatting toolbar. You need to select the text

first, then hit the button.

You can also format the entire item text by selecting the item (not in edit mode) and applying one of the formatting options. The options on

the toolbar change to reflect the ones that are available to you. For example, you can increase or decrease the font size, or change the font

of the whole item.

To highlight an item in the grid, i.e. colour the entire row, use the background colour option on the item. For example, this item is

highlighted in yellow. The highlight is lost on HTML export.



If you want to add checkboxes to your outline, go the menu and click Grid > Done Checkbox. You can now click on individual checkboxes,

or hit CTRL+M to mark/unmark them as done. The checkboxes are per item only, so a parent item does not check/uncheck its children. You

can hide the checkboxes again with Grid > Done Checkbox. Checkbox states are saved so you can hide and unhide them as often as you

like.

Style and number your headings

You can format the headings in your outline with a style set that you define yourself. There are no default style formats in InfoQube. First, we

need to make a grid that will store the styles. Click on the menu Grid > New Grid. Name the new grid OutlineStyles. That name tells the

program that the grid is the style source grid.

In the OutlineStyles grid, type the style name in the first item, e.g. "My Style". Make a hierarchy of child items under the first item using

CTRL+ENTER. Name them Level 1, Level 2, Level 3, etc. Format each Level x item in the way that you would like Level x headings to appear in

your outline, i.e. font, font size, font colour, bold or italic, etc.

Go back to your outline grid. Go to the menu bar and click Grid > Outline Styles and pick the named style that you just created. There's also

an Outline Styles button on the standard toolbar.

You may find that all your items are now being styled. That's because the program needs to be told which items are headings and which

ones are normal text. Select the items in the grid that are normal text and hit CTRL+SHIFT+N, or click the N button on the formatting

toolbar. When the H button on the formatting toolbar is highlighted, then the item is being seen as a heading.

If you change the formatting of your style in the OutlineStyles grid, hit F5 to refresh your outline and see the updated style. You can create

as many styles as you like in the OutlineStyles grid. Each style starts with a top-level item. You can reopen the OutlineSyles grid using Grid >

Outline Syles > Manage Styles.

If you want to use heading numbering, there are named numbering styles available in the menu Grid > Outline Labels, such as Numeric,

Legal, etc. Creating new numbering styles is possible using Grid > Outline Labels > Manage Labels. See 2. Outline Labels in the User Manual

for details.

https://infoqubeim.com/3825


Insert hyperlinks

To insert a hyperlink into an empty item, hit CTRL+K or click on the hyperlink button on the formatting toolbar. Enter the link text and

destination, to get something

like this

As long as there is no other text inside the item, you can edit the hyperlink using CTRL+K on the selected item

like this as well

Adding a hyperlink to an item that already contains text, as well as editing it, requires using another editor. Select the item, then hit Shift+F2

to bring up the pop-up editor.

Inside the pop-up editor, you can add a hyperlink using the link button at the lower right as follows: First write the link text, then select it,

then hit the link button, then add the link reference to create a hyperlink more like this. Editing a hyperlink inside an item goes in the same

way, using the link button inside the pop-up editor.

If you want to link to another item in your outline, you need to know its ItemID as the destination for the link. You can see the ItemID easily

by holding down CTRL then hovering over the item with your mouse. A yellow popup window will tell you what its ItemID is. If you don't

want to manually remember the ItemID, you can also select the item that you want to link to, and go to the menu Edit > Copy > Copy Item

IDs.

Add a link to the item in the same way as adding a general hyperlink. Instead of entering a URL, just paste or type in the ItemID number, e.g.

1804, without brackets. This will link to the desired item. Internal links are lost on HTML export.

Insert images

If you want to embed an image inside your grid, you can add it using File > Import From > Text and Image Files. Select the file you wish to

import, click Open, then select option 1. Your image will be added as an item to your grid.

Refresh the grid (F5) to see the image. It may be all the way at the top, so hit CTRL+Home, then use ALT+arrows or drag and drop to put it

where you want it in your outline. You can drag to expand the item row height to see the entire image.

http://www.infoqube.biz/
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You can show/hide pictures in the grid from the menu Grid > Show > Pictures.

If the image is taking up too much space in the grid, you can replace it with a text description. Select the item with the image, hit CTRL+E,

and replace the image name in the top half of the box with some text. Click OK, then F5 to refresh the grid. The image is not lost, since it is

stored in the item's document pane.

You can add icons inside your text using the Add Icon button on the formatting toolbar while you are in edit mode. Icons are not visible in

HTML export files.

Export your outline

When you have finished your outline, you will probably want to export it to another program or print it.

Print your outline

Select the items in your outline that you want to print. On the menu bar, click File > Print Preview, or hit CTRL+P. Select option 1, WYSIWYG

printing of the complete grid. That will print your grid in its current state, i.e. with levels collapsed/expanded as they are on your screen.

In the print preview window, click on Scale. Select the checkbox for Scaling, and set the options to 1 page wide and 0 pages tall. Then click

on print.



Export to HTML using outline styles

A general rule for export is that it processes items in the order that you select them, so if you want them to appear in the right order, select

them from top to bottom in the grid. The easiest way to keep your outline in the right order is to have the entire outline be child items of

one title item at the top, and select that one for exporting.

Export the outline using File > Export To > HTML, or File > Print Preview (CTRL+P), option 4. Both bring up the same dialog box.

Fill in a title for your outline under heading, e.g. My Outline. Pick a name for your output file. Click "Save and Preview". The Outline Export

Settings dialog box comes up.

Check "Export heading items" and "Styles based on item hierarchy" and set Base to H1, or lower if you want to start at lower heading levels.

Uncheck "Use grid outline labels" if you don't want to keep them. Check "Export non-heading items", and uncheck "Sub-items become

lists". Depending on how you wrote the outline, you way want to check "Items starting with - of 1- become lists". Check "Export Document

Pane content". Although we did not write anything in the document pane while making this outline, any embedded images are stored there.

Keep checked "Show this dialog on copy". Click OK.



You should now have a saved HTML file and a preview in your web browser.

Copy to Microsoft Word

The process is almost identical to HTML export. On the menu bar, click on Edit > Copy > Copy as HTML Outline. This opens the same

Outline Export Settings dialog box. When you click OK the selected outline is copied to the Clipboard. Open MS Word and hit CTRL+V to

paste.

Note that the exported outline does not get formatted in the same way as it appears in the grid. The formatting is default HTML for H1, H2,

H3, etc and body text. The heading levels are preserved, so you can reformat the styles inside MS Word.

Where to learn more about using InfoQube

I hope this introduction has helped you to get started. This blog post was written inside InfoQube using the outline steps described above,

and exported as HTML. If you want to see what the outline of this article looks like, please download the attached IQBase.

For more information, please have a look at the extensive InfoQube User Manual.

Thank you for reading!

Pierre_Admin 2021/04/04 20:48
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Making a grid with columns

*** Work in progress ***

InfoQube for Beginners: Making a grid with columns

Hello and welcome! Are you interested in learning how to use InfoQube to manage tables of information?  This guide is written to help you

get up and running creating a grid that contains different fields displayed as columns.

In this guide we cover creating rows and columns, entering and formatting information, sorting, filtering and grouping rows, and creating

automated data entry rules.  We will look at easy ways to get things done, often using keyboard shortcuts.  There are other ways to do the

same thing, but not every method will be covered here.

Let's get started!

What is a grid?

MS Excel calls it a "Sheet" and MS Word calls it a "Table". In InfoQube, it is called a "Grid". It is a view showing rows and columns of data.

https://infoqubeim.com/drupal5/node/48
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Let's create a new grid.  Go to the menu bar and click on View > Grids > New Grid.  Enter a name for your grid and click OK.  For example,

you can name it My Table or MyTable.  Spaces are allowed in grid names, although CamelCase is recommended.

You will now see a blank grid with two columns: # and Item. # is the row number in the grid.  Item is the header of the first column in the

grid. There is one blank item in the grid and it is highlighted.

Before we start adding columns, here is a little explanation of what the grid is showing you:

�. InfoQube is a database that contains items.  Each item is shown as one row in the grid. You can make a selection of items from the

database to show as rows in your grid.

�. An item can have different kinds of data associated with it, which are stored in fields.  All fields in the database exist for all items, so an

item can have a value for any field.  You can make a selection of the fields in the database and show these as columns in your grid.

�. By default, a grid does not show all items and all fields that exist in the database.  It only shows the items that meet the grid source

criteria, and the fields that are chosen to show as columns.  It is a view of the database rather than the whole database.

What are grid source criteria?

That third point can be confusing when you first start using InfoQube, so here's some more detail. Making a new grid called MyTable using

View > Grids > New Grid creates a Yes/No field called MyTable, which is the grid's source field. Any item that you add to this grid will have

the field MyTable set to Yes.

Conversely, any item that has its MyTable field set to Yes will show in the grid MyTable.  Grids are not exclusive, so the same item can show

up in different grids by having their corresponding source fields set to Yes.  If you want to see all the items in the database in one grid, open

the "Journal" grid using View > Grids > Journal.

Now, back to our table!

Making a simple table

InfoQube can be used as an outliner, where you indent / outdent items to arrange them in hierarchy.  However, for this first table, we are not

going to use the outliner functions just yet.  Instead, we are going to make a simple list of items, one after the other without any hierarchy.

Adding items to the grid, i.e. rows

You can start writing in the highlighted item by simply starting to type while the cell is selected.  If there is existing text in the cell, it will add

the text to the end. Hit ENTER to submit your text. To add an item above your selected item, hit ALT+ENTER then start typing.

Another way to add a new item is to click on the "Add new item" button on the Item Commands toolbar or click Item > Insert > New Item in

the menus. The new item added this way will appear at the bottom of your list.

If you want to edit a row, move your cursor to that row so that it is highlighted, then either double-click, hit SPACE or F2. SPACE puts your

cursor at the end of the line, and double-click and F2 at the beginning.  Confirm your edits with ENTER. Cancel your edits with ESC.

You cannot undo adding a new item, but you can delete it. If you want to delete a row from the grid, select it then type CTRL+D.  Select

option 1 to delete it from the database entirely, or option 2 to remove it from this grid only while keeping it in the database.



If you want to move a row up or down in the grid, type ALT+up/down arrow with that row selected.  There are also Move Up and Move

Down buttons on the Item Commands toolbar and in the Item > Move menu.

Adding fields to the grid, i.e. columns

You can add a column to the grid by clicking on the Column > Add Columns menu, or right-clicking on the column header to get the same

menu.  There is also an Add Columns button on the Item Commands toolbar. 

This will bring up a list of fields that exist in the database, with those currently shown in the grid at the top.  Those have a green check mark

in the "Show" column.  The other available fields are listed in alphabetical order.  In addition to the field names, this menu lists the field types

and descriptions so you know what kind of field you're choosing.

To find the field that you want to add, you can scroll through the list, or type part of the name in the filter box in the top right hand corner. 

Once you have found the field, click on the checkbox in the "Show" column.  It will now have a green checkmark.  You can add multiple fields

in this way.  Click OK when you are done, and the chosen fields will now appear as columns in the grid.  They are added to the right of the

existing columns, in reverse order to how you selected them.

By default the column header is the name of the field that is displayed in the column.  You can change the column header to a new name

without changing the field name.  For example, if your field name is "Due" but you want it called "Due Date" in the column header, you can

go to Column > Header > Caption (either via right-click or the menu) and change it.  When you change the column header caption, it is set

to that name for all grids in which the column appears.  The Column > Header menu also has options to change the header text alignment.

Creating new fields

As you create your table, you may want to add new columns to it that don't yet exist as fields in the database.  To do this you need to create

new fields.  When you're in the Add Columns window, there's an "Add New..." button in the lower left corner. Click on it to select the column

type that you would like to add, either a text column, number column, date column or Yes/No column.



For our example we are going to make a list of Hugo Award-winning novels.  So we are going to add new columns as follows:

Author Text column

Title Text column

Publisher Text column

AwardYear Number column

"AwardYear" is not a date column because we don't want to enter days or months, just years.  We'll cover formatting this column below.

Note how the order in which they appear in the Add Columns window is with the most recently created column at the top.

(The screenshots show a typo in the Publisher field, which is fixed later.)

https://en.wikipedia.org/wiki/Hugo_Award_for_Best_Novel


They are then added to the grid in the order they were added to the list.

We still have the "Item" column, which is the main column in every grid.  If we want the "Item" column to contain the title of the book, then

we don't need the "Title" column.  Let's remove it.  Right-click on the Title column header and select Remove Column.  We can change the

caption of the "Item" column to read "Book title".  Note that this changes the header in all grids, so only change it if it doesn't hinder other

grids in your database.

The AwardYear column has a truncated header. Drag the border of the column header to the right to expand it.  Now the grid looks like this.



Changing the grid layout

You can make a column wider or narrower by dragging on the right-hand border of the column header.  You can turn word wrapping of

column headers on or off using the checkbox found in Tools > Manage Grids. In the Properties box on the right, look under Options for

Multiline column headers and check the box. Then press the save button.

You can rearrange columns into the order that you want by clicking on a column header (the grey box) and dragging the column to a new

position.  Green arrows will show you where the column will go.  When you release the mouse the column is moved.

If you want to remove a column from the grid, you can right-click on the column header then selecting "Remove column". The same

command is available using the menu Column > Remove Column.  Removing a column from the grid does not delete any of the data that

were shown in the column.  The data are available in the database until you delete them.

If you have a grid with many columns, and you want to temporarily hide a column without removing it from the grid you can choose

Column > Hide Column.  You can bring it back using Column > Hidden Columns.

Entering data in fields

Now we can add data into the cells in the grid. The active cell that is highlighted is the one where the data will be entered.  You can move the

selection of the active cell with the arrows. TAB and Shift+TAB will also move the cell highlight except when the highlighted cell is in the Item

column.  In that case they will indent or outdent the item.

Just like in the Item column, you can start typing and the text will be added to the end of the active cell. You can also use SPACE or F2 to

enter edit mode.

To delete a value from a field, simply hit the DELETE key.  You can undo the deletion of one cell with CTRL+Z, but if you delete more than one

it cannot be restored that way, so be careful.

Copying and pasting

You can copy data using CTRL+C/V when the field types match, so text between text fields, dates between date fields, and so on. 

Pasting multiple columns in one row

Highlight the columns that you want to copy, then press CTRL+C or Edit > Copy > Copy Special... (Ctrl+Shift+C) option 3. Then highlight all

the columns in which you want to paste, then press CTRL+V or Edit > Paste > Paste Special (Ctrl+Shift+V).

Pasting from other sources

You can paste text from outside InfoQube. For example, for the list of award-winning books we can copy and paste from the wikipedia

webpage.  First, reorder the columns to match the order on the webpage: AwardYear, Author, Book title, Publisher.  Then highlight a row

from the table on the webpage and press CTRL+C. Then highlight all the columns in a row in InfoQube where you want to paste, and press

CTRL+V.



Pasting multiple rows and columns

To paste multiple rows and columns at the same time, select then copy them from the source, then select the relevant columns of the row

where you want to add them, and press CTRL+V.  A dialog box will pop up asking you how you want to paste them. Select option 2 to create

new items for the additional rows that are needed.

Alternatively, if you want to paste into existing rows, select all the rows and columns that are needed, then select Option 3.

For the award-winning books table, there is an additional Ref column which we don't really need, but let's add it to the grid (as a text

column) so we can copy multiple rows.  An additional complication is that the year isn't repeated in each row on the webpage. Let's ignore

that for the moment.

Looking at the year 1956, we can highlight the five rows starting from the author column, copy those, then highlight five rows and four

columns in InfoQube, and paste them using Option 3. The result looks like this:

We don't need to manually type in the year five times.  Copy the year (1956) from the webpage, then highligh the first column in the five

rows and hit CTRL+V. The result looks like this:



In summary, InfoQube will paste into the highlighted columns, so you always need to highlight all the columns that are needed.  You can

choose to add new rows if you have more rows in the clipboard than in the selection.  And IQ will repeat the contents inside the selected

rows if you have fewer rows in the clipboard than in the selection.

Formatting text

You can use the text formatting options found in the Formatting menu bar to format the text.  If you highlight a cell and press a button on

the menu bar, like Bold for example, then all the text in the entire row becomes bold.  If you just want to format the text inside one cell,

double-click it to enter edit mode, select the text that you want to format, then click the button on the menu bar.  The formatting applied

per cell is independent from the formatting applied per row. In the image below you see that the row is green, but the text inside the

publisher field is highlighted in yellow.

The "undo" button doesn't work for formatting changes, so if you want to reverse any changes you have to do it manually.

Formatting number and date fields

If you want to format a number or date field in a particular way, the options to do so are in the Field Properties dialog box. This is a very

powerful dialog box with many options, but we're going to keep it simple and only use the ones we need.

Going back to our example table, the AwardYear field is a number field.  We haven't constrained it yet, but we want it to contain whole

numbers only, not decimals. Right-click on the AwardYear column header and select Manage Fields. The Field Properties dialog box opens

with the AwardYear field highlighted on the left and the properties of that field shown on the right. There is a format box in the section

headed Type.



To format your number or date you manually enter a format code in that box, for example, entering 0 formats the number without decimals,

and 0.00 formats it with two decimals. Just for fun, we're going to enter 0.00 in the format box, then press the save button. The grid

immediately updates to show the years as 1963.00.  That's not what we want, so enter 0 in the format box then press save.

Why didn't we make AwardYear a date field? Because we cannot just enter a just a year as date.  As a test, here is the table with an additional

AwardDate column.  If you enter 1953 in that column, it's converted to the date 6 May 1905. Look at the image below for what happened to

all the years in the table.



If you want to format date fields, you can enter a formatting code like yyyy-mm-dd or mmm d yy into the format box. All the number and

date formatting codes are listed on this page, and there is a link to it in the user guide so you can always find it there.

Conditional formatting

work in progress, will be continued

will be covered later in the document:

Editing field properties

Depending on the field settings (more on this below), what you can enter in a cell may be constrained to a particular data type (e.g. a date

field) or to a fixed list of entries. If there is a fixed list of entries defined, clicking on an active cell will show a downward arrow on the right

hand side of the cell.  Click on the arrow to show the list of entries, then either scroll to the entry you want or start typing, and the selection

bar will move to the matching entry.  You can also press F2 twice to show the list. Press ENTER or click OK to select the desired entry.  For an

empty cell, a quick way to show the entry list is to tap SPACE twice, which is handy when you are using the keyboard.  However, this method

doesn't work if the cell already contains data, use F2 instead.

to do: insert image of downward arrow to the right of a cell for selecting entries

Unlike these however, in IQ grids, you can:

Show the items (i.e. rows) in multiple places (in the grid, and in other grids)
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InfoQube's main elements: Items, Values and Views

1. Items

In InfoQube, the information is centered on items. The term item is generic and can refer to:

a person

a thing

a task

a thought

a file

notes

or just about anything...

https://docs.microsoft.com/en-us/office/vba/language/reference/user-interface-help/format-function-visual-basic-for-applications
https://infoqubeim.com/drupal5/node/1068
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This means that InfoQube does not try to decide for you how you enter your information. You are in control.

This is not the same behavior as in other applications! For example: if you are in Outlook, you can create a contact using the contact form... a

task using the task form, etc.

In Outlook a contact item is different than a task item... but this is not the case in InfoQube .

All items are equal - regardless of where created. An item is an item.

There is no "contact item" or "task item". There are items.

Each item has a unique ID number. What also differentiates items are their field values: (see next).

2. Values and Tags

What differentiates a contact from a task in InfoQube is which values and tags it has. Values are stored in fields, of which there are 4 types:

text, dates, numbers and check-mark

If you put a check-mark in the Contact field, it will be displayed in your contact list

Put a date in the ToDo field, and it will be a task

Assign it to a project, it will be displayed in your project grid

3. Grids and other Views

As you put more and more information in InfoQube it becomes crucial to be able to show just the section that you want to see.  The Grid is

the primary working window, but there are others, such as the Calendar, the Surface and Card views

A Grid displays selected items and selected fields --  items correspond to  lines, and fields are shown in columns.

InfoQube grids are very flexible in the way they presents your information. See Grid Display Modes for more info.

One of the most important InfoQube principles to learn and remember is :

An item doesn't "belong" to a grid;  a grid shows any item that meets certain filter criteria

In other words, items shown in a grid are selected from all the ones in the database

using  filters. How ? Using the edit boxes at the top of the grid, in what is called the 

source bar (Grid > Source Bar). Each grid uses those filters to define the content. 

This screenshot shows some of the built-in features of InfoQube

2 windows are shown here: 

The left window is the grid (or notepad). This shows the various items, organized in a tree-outline. Any number of fields can be defined

and displayed in the grid.

The right window is the properties pane. It shows useful information about the selected item: the item properties

https://infoqubeim.com/261


You are of course free to arrange/hide windows as desired.

You can have as many grids as you want, and even display several at the same time.

Filters can be applied to grid to further limit the items shown. See Filtering Items for details

Expand/Collapse buttons: Information is organized into items and sub-items. To open (expand) or close (collapse) an item, simply click

the expand buttons to the left of the item.

Auto-numbering: The left-most column displays the item / sub-item number

Fields support Row Equations. So entering a value in a field can fill another. In the above example, Nb Days is set from the start / end

dates

Fields also support Column Equations: It is hierarchy based. Notice how the main project Nb Days is the sum of the sub-items.

Circular equations are no problem in InfoQube. In the above example, TaskActEnd can be inputted (which calculates Nb Days) but it

can also be computed from TaskActStart and Nb Days. Try doing that in Excel and you'll get an error !

Text Formatting: 5 types of text formatting are supported by InfoQube.

Conditional Format: Details here

In-item. Use the Formatting toolbar to format parts of the text

Item. Choose font, size, color attributes to be applied to the item. It will be applied to all fields or just those you want (as defined

by View>Grids)

Outline: Choose from a list of outline style (or create your own) to apply formatting based on hierarchy (text font, size, color).

Details here

Number and Date Formatting: User-defined formats are supported. InfoQube uses a Microsoft-standard format string (both named

and user-defined). More info from this Microsoft reference .

4. Forms

Forms are another way to display fields values. If grids display fields from left to right, forms displays them from top to bottom, in a

vertical list.

In addition, forms can be used to apply values to items

Forms are displayed in the Properties pane

More info here

5. Panes

Panes are windows that can be:

Left open (non-modal)

Docked to any edge of the main IQ window

Floating, either over the main IQ window or outside it

Minimized (i.e. collapsed)

There are quite a few panes in InfoQube (Grids can even be shown in a pane), but the two key ones are:

�. Properties pane: This is where all item information is shown. Details here

�. Document pane: This page is for large text contents. It supports many formats, including handwriting. Details here

https://infoqubeim.com/854
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Managing Tasks

InfoQube lets you manage a wide range of information content. One such content are tasks and events, i.e. things to do, people to meet,

important dates

Tasks and events are overlapping concepts to a certain extent, but generally speaking, events are shown in a calendar and have start time,

end time and duration. Tasks can be shown in task lists and calendars, and can have a due date and a duration (optional). Once completed, a

done date is assigned.

While both events and tasks can be used, tasks generally:

are thing to do

are shown in a list. List can be sorted

are sometimes arranged in a hierarchy (task / sub-task)

may or may not have a specific date

may have a duration specified

do not have a specific time

once marked done, tasks are moved / hidden out of view

Tasks are sometimes done on the go, so having a mobile app is essential. Some tasks management tools have desktop and mobile apps.

InfoQube uses a different approach by syncing its content with 3rd party apps (Google Tasks for now, other to come).

This page shows how to setup and manage Tasks. To manage events, check out Using the IQ Calendar

1. Set-up

InfoQube has system fields to manage tasks:

Item contains the task subject

Due contains the optional due date

ItemDuration contains the time (in hours) to complete the task

Done shows the date the task was done

Notes contains addition information for the task

ToDo is the date the task was created

TaskList groups tasks into list

Inbox shows the tasks in your Inbox

InfoQube's grids are the natural UI to manage tasks:

(hint: This grid can be setup automatically for you through the Google Connect dialog. Details here

This grid sorts and filters items to show most relevant items at the top of the list:

�. Done tasks are filtered out 30 days after being done

�. Done tasks show at the bottom of the list

�. Tasks are sorted by list, then by Due date

Users can of course change these settings !

2. Managing Tasks

https://infoqubeim.com/drupal5/index.php/pierre
https://infoqubeim.com/1215
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Tasks are regular items, so they be displayed in numerous UIs, included multiple grids at once

Tasks can be arranged in a hierarchy, with or without non-task items in between. Basically, you are free to arrange items as needed

To mark a task as done, use Item > Mark as Done (or use the default shortcut Ctrl + M)

Unlike some other task manager, marking a sub-task done, does not mark the parent task as done

Tasks can be created anywhere, not just in the ToDo grid. However, unless you change the ToDo grid to a different source, only items

with a ToDo date will show in the ToDo grid

InfoQube does not have alarms and notifications built-in but you can easily get these on your mobile using Google Tasks (and soon

Microsoft To Do). See below

3. Showing Tasks in the Calendar

Tasks use 4 date fields:

ToDo (ID=83): Task created

DueDate (ID=80): Task Due date (optional)

Done (ID=81): Task Done date (when completed)

ItemDuration (ID=51): Time to complete task (optional)

Like any other date field, these can be shown in the Calendar, either automatically or for individual items:

Automatically: In the Field Properties, check "in Calendar by default". Details here

Specific items: Numerous ways. Details: Using the IQ Calendar

(i.e. Item > Events > Create Event, or Edit the date and select Show in Calendar)

Tasks will by default be shown as unscheduled events. Details here

4. Syncing with Google Tasks

Google provides tasks management through the Tasks services and apps. In the spectrum of task management apps, it is one of the simpler

to use, with a narrow focus and scope:

Tasks are organized in lists

Tasks have a title

Tasks can have a Due date which can include a time

Tasks can be repeating

Tasks can be marked as done and hidden from view (or shown under a "Completed" heading

On the web, Google Tasks used to have a web address. This is no longer available

Tasks are now viewed as side panels in GMail and Google Calendar

Still available on the web, is a web service that can access Tasks, GTaskD: https://tasks.gtaskd.com/

It is simple, but quite functional. Screenshot here

On mobile devices, Google Tasks apps (Android and iOS) provide access to tasks

4.1 Set-up and Sync Parameters

See Synchronization with Google Services

4.2. Syncing Tasks

https://infoqubeim.com/1068
https://infoqubeim.com/1215
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Syncing tasks is a simple process:

Click on the Tasks icon the status bar to schedule a sync

If Sync is not set to Manual, it will run at the specified interval

If the Google Connect dialog is open, you can also click on the refresh button (first column in the calendar / task list grid) to perform a

sync or full-sync

4.3 Managing Task Lists 

Because IQ will be able to interact with many tasks servers, and to allow not all tasks to sync with all servers, task lists must be

managed on Google apps / server

Changes made to task lists (number of lists, names of) are not automatically read during the sync process

To refresh, simply open the Google Connect dialog (or if already opened, click on the refresh icon located just above the task list grid)

When IQ detects that a task list name has changed, it will update the corresponding task list (field TaskList)

4.4 Task Alarms and Notifications

Set a Due Date for your task to get a notification on your mobile

5. Issues and workarounds:

5.1 Task Due with Date and Time

On the web and in mobile apps, tasks due date can include a specific time. This time is not available to the API used by InfoQube. As a

consequence:

In IQ, due date do not have a time component

If a task is modified in IQ, the time component will be lost after a sync

5.2 Task Hierarchy

Google Tasks now only support 1 level of sub-tasks. IQ supports multiple levels and multiple parents (i.e. possibility of having a task under 2

or more parent tasks), so:

Importing new tasks from Google Tasks will reproduce the task hierarchy if present

Hierarchy changes in Google Tasks of existing items will not sync to IQ

Hierarchy changes in IQ will not sync back to Google Tasks

Tasks created in IQ will sync as level 1 tasks in Google Tasks

5.3 Repeating Tasks

Google Tasks "sort of" supports repeating tasks:

Repeating tasks can be created in Google Tasks but only for level 1 tasks (i.e. not sub-tasks)

Google Calendar properly shows repeating tasks. Individual instances can be marked as done

Tasks side-panel does not work well with repeating tasks

As soon as an instance of a repeating task is marked as done, it is not possible to make changes

On the day a task is repeating, Google creates a new Task item. In IQ, you'll then have multiple items, one for each past instance

(it would be better if the task item was created prior to the repeat day)

Google Tasks API does not expose the repeat settings
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