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Printing and Exporting

InfoQube has many UI to show items, namely:

�. Grids

�. 2-D Surface

�. Calendar

�. Map View

�. TimeLine

In addition, information is also shown in panes, namely

�. Doc pane

�. Properties pane

Each of these "views" can print and / or export the content shown.

The useful commands are:

File > Print Preview

File > Export

Edit > Copy Special

Doc pane:

Menu > File > Print Preview, or

Menu > File > Open in Browser
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1. Print Preview

Print Preview - Grids

File > Print Preview can be used to print / export grid content. A number of print options are available:

https://infoqubeim.com/drupal5/index.php/pierre


1. WYSIWYG Printing

Opens a print-preview window with a toolbar:

where you can:

Set the view zoom

Set the number of pages visible on screen

Choose the paper orientation

Set other print options:

Show / hide row colors

Select the printer and paper size

Save As: PDF file or an image file: JPeg, Png or EMF

Copy as an image, to paste into other applications

Print

If the grid is showing a Gantt chart, a Gantt Print Options dialog is first shown:



Tips and Tricks

WYSIWYG printing will print all items in the grid. To limit it to a list of items:

�. Select the items to print

�. Do a Hoist filter (Grid > Hoist Items or the H filter on the toolbar)

�. Print Preview

�. Repeat Grid > Hoist Items to remove the Hoist filter

Some Print-to-Fit options result is severely degraded text quality. Test various options to see which ones

provide the best print quality

Using the Copy toolbar button will put a copy of the source grid onto the clipboard. Pasting this into a

word processor document often yields excellent results. If you want to print just a section of the grid /

Gantt, see the first tip in this section to apply a Hoist filter

If you need to shrink the print output, a better option is often to:

�. Select a large paper size (optionally install a printer that supports this). Tabloid (11in x 17in) is often

the largest pager size available. Some printer drivers allow custom paper sizes. Try creating one

even larger

�. Instead of printing, click on Save As... and select an image file (e.g. PNG)

�. Paste this image in a word processor, such as Microsoft Word

�. Print the document to a printer or a PDF printer (to generate a PDF file)

�. Instead of steps 2 to 4 above, it is possible to generate a PDF file directly by clicking on Save As...

and selecting PDF file

HP has a universal printer driver which should enable large printers (not tested). WinLine also provides

drivers for HP Plotter printers (tested). With this driver, one can select very large paper sizes. Expensive

(200USD), but with a free trial. Details here: WinLINE Printer Driver

Another option to print large grids is create a copy of the grid and reduce the font size and column

widths. Print this grid instead

2. HTML-Based Exports

Print-preview options 2 to 5 show the HTML Export dialog which consists of 4 tabs:

�. Template Merge

�. Table with Columns

�. Bullet List

�. Using Styles
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2.1 Template Merge

Template Merge is similar to any mail / email merge process and consists of 2 parts:

�. One or more items to merge, each item having a list of values to fill the form template (name, email,

amount, date, etc)

�. A Template file which contains rich text content and field placeholders

InfoQube can Template Merge to a single document or to individual emails

2.1.1 Template File

Use the Doc pane (recommended) or another HTML editor to generate the Template file

It is best to save the file in the IQBase Files folder

Use the formatting tools to bold, link and add images

To merge field-values, add the field name enclosed with {  }, such as {Item}

Item parent field-values can be used by preceding the field name with "parent.", such as {Parent.Item}

2.1.2 Merging

To perform the merge

�. Select one or more items in a grid

�. The fields to merge do not need to be shown in the grid as InfoQube will look in the IQBase to read them

�. File > Print-Preview > Merge the selected items with a template tile

�. If performing an email-merge, enter the email subject, email field and sender address. Click Preview to

preview the email. Click Email Merge to perform the merge



�. If merging to a document, click one of the buttons at the bottom of the dialog (i.e. Save and Preview)

3. Table with Columns

The export has many options and can even generate interactive content, such as expand / collapse sub-items

and Doc pane content:

�. Configure the grid to show the desired columns

�. Select one or more items / sub-items

�. Only selected items are included in the export

�. File > Print-Preview > Table of items and field values

�. Try the various options and see which ones provides the desired output

�. More information can be found here: HTML Export dialog: Table with Columns

4. Bullet List

Similar to Table with column output, but generates a bullet list of items:
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�. Select one or more items / sub-items (only the tree column is exported)

�. Only selected items are included in the export

�. File > Print-Preview > Outline in Bullet List form

�. Try the various options and see which ones provides the desired output

5. Using Styles

This export is identical to the command Copy > Copy as an HTML Outline. Details here: 2. Export Outlines

(Print-ready)

 6. Properties Pane of the Focused Item

Opens a WYSIWYG preview of the Properties pane.

Important notes

The export will display items in the order of selection, and not the ordering shown in the grid... If you want your

items to be exported as shown in the grid, make sure you select them going from top to bottom (using SHIFT

+ mouse left click, or CONTROL+ mouse left click for non-adjacent items).
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Exporting Outlines (Print-ready) 

When working on medium, large documents, it is quite useful to break it down in parts, more specifically, in an

outline (main chapters, sections, sub-sections, etc)

InfoQube can generate a compound document of all these parts. Using styles, this can be a "Print-ready"

document.

To generate the compound document, the steps are as simple as:

�. Select one or more main items

�. Edit > Copy > Copy as Outline  . (The command can be added to any toolbar) 

(or do File > Print-Preview > Outline using Styles)

�. Set outline export settings

�. Paste into a rich-text editor, such as MS Word, Wordpress, or an IQ item's Doc pane

�. Select / Apply a style sheet 

Outline export settings dialog : 

https://infoqubeim.com/drupal5/index.php/pierre


1. Writing your document

When writing your document, there are a number of strategies that you can use, based on your writing style

and writing project. Any of the following stategies can be used:

�. Outline items represent sections / sub-sections of the document. The actual content of each section is

entered in the Document pane

�. Outline items describe the content of each section but are not to be part of the final document. The

document content is entered entirely in the Document pane 

Sub-items can be used to add notes, references, etc. to each section but are not included in the final

document

�. Outline items represent sections / sub-sections and content of the document 

The document pane is only used to enter notes, reference information, etc, not to be included in the final

document

�. Outline items represent sections / sub-sections and simple / short form content of the document.

Complex / long form content is entered in the Document pane 

It's important to decide what writing style / structure you want to use as this affect where content is entered

and where non-printing notes are entered

To create items, the following is a friendly reminder:

Hit Enter to add an item. 

Ctrl+Enter adds a sub-item

Alt + up / down / right / left arrows moves items in the hierarchy. Tab / Shift Tab also moves items to

sub-items and back

Drag-drop can also be used

Blocks can be used in more than one document. To do so, hold the CTRL key when dragging an item

block as this creates an additional parent link. More info here

The Item Commands toolbar contains all related commands. Right-click on any toolbar to show / hide

toolbars 

A few guidelines:

�. Select an outline style using Grid > Outline Style, as this helps visualize the document structure

�. InfoQube uses the Heading / Normal Text property when formatting. By default, items are Heading item

Use the H or N command button on the formatting toolbar to set the item type (Ctrl + Shift + N)

�. Short / medium length content can be entered as items or in the Doc pane

�. Content that includes images must be in the Doc pane

�. Items can be easily be moved and expanded / collapsed. This sometimes influences where the content is

entered

�. Document pane content can also be expanded / collapsed, based in styles (H1... H6, use Alt + Click to

expand / collapse sections), but moving is done through copy / paste

How compound documents are generated follows these simple rules:

https://infoqubeim.com/drupal5/?q=node/237
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�. Heading items will be formatted as HTML heading tags (<H1> ... <H6>), based on the item hierarchy w.r.t.

the main item

�. Use Outline Labels to auto-number sections / sub-sections

�. Normal text item which is an immediate sub-item of a Heading item will appear as a paragraph

�. Normal text item which is a sub-item of another Normal Text item will appear as a list item (bullet or

numbered)

�. Normal text which start with "- " will be turned into a bullet list

�. Normal text which start with "1- " will be turned into a numbered list

�. Content in the Doc pane appear after the item text, as a paragraph

�. You can use heading styles in the Doc pane, but these will not the adjusted based on the item hierarchy 

(this means that generated document may not have the correct heading level, so it is perhaps best to

avoid it if possible)

The following screenshot shows a typical use case. Notice how:

Headings are in bold, in decreasing font sizes. See 3. Outline Styles for details

Normal text items contain parts of the document body. These support rich text, such as  bold,  italic, 

hyperlinks, etc

Rich text can be copy / pasted from other apps to IQ items and vice-versa

The Doc pane is useful for long-form content

The Doc pane always shows the content of the currently focused item (unless it is locked to a specific

item)

When generating the compound document, Normal text and Doc pane content are treated in a very

similar manner

Many Doc panes can be opened at once. This is useful to see content from more than one item

If an item outside the current hierarchy contains a previously generated compound document, you can

view the whole document (a version of it) in a pane while writing in another pane

https://infoqubeim.com/drupal5/?q=node/3825
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Export between IQBases

To export items from one IQBase to another, use one of the following 2 methods:

�. Tab-delimited list of items and field-values

�. XML format

1. Tab-delimited

To copy a flat list of items with limited number of field-values, a simple tab-delimited copy / paste can be done

The steps are:

�. Setup a grid with the items and desired field-values as columns

https://infoqubeim.com/drupal5/files/1/images/CopyStyles3.png
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�. Select items and columns (or Edit > Select All)

�. Edit > Copy: Selected grid rows and columns

�. In the destination IQBase, setup an identical grid

�. Create a blank item and select it

�. Edit > Paste

2. XML format

XML format copy / paste creates exact item replicas, that is with the same field values and properties

The steps are:

�. If the export must contain field values, these fields must be created in the destination IQBase first

�. Select the items to export

�. In the destination IQBase, Edit > Copy > Copy Special (if more than one column is selected, Edit > Copy

is sufficient)

�. The following dialog will appear:

�. Select one of the 2 XML options (#5 or #6)

�. Check "Only copy user values" to exclude system fields

�. In the destination IQBase, open any grid. Select the # column.



�. Edit > Paste

�. Items will be created.

��. To view the new items, you can

Use the Journal grid

Edit > Find

Open a grid where these items meet the source

Open the Properties Pane and double-click on a field which the new items have values
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Export to other Outliners

When copying one or more items, InfoQube puts a number of different formats in the clipboard:

�. Tab-Indented Outline

�. XML

�. OPML

�. HTML

These clipboard format are text-based but are not all are supported by other applications.

To convert them to a standard text format, use this free clipboard viewer utility: InsideClipboard:

The steps are:

�. Select items

�. Edit > Copy or Edit > Copy > Copy Special

�. Open InsideClipboard

�. Select a clipboard format. The text content will appear in the lower pane

�. Select and copy the lower pane content (Select All context menu)

�. Paste in the application

�. If the application prefers importing through a file, open Notepad and paste the text into it. Save that file

and proceed with file import

As support for hierarchical data is non standard, users are encouraged to try each format and determine the

one giving the best results
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5. Export to Excel

Export to Excel

Exporting content from InfoQube to Excel can be done in 3 different ways:

1. Export to Excel

�. Open the grid which contains the information to export

�. All shown grid columns will be exported. Show / hide columns to get the desired list

�. File > Export > Microsoft Excel

�. An GridName.XLS file will be created in the same folder as the IQBase

Note:

Only items that belong to the grid will be exported.

The items that belong are those that meet the grid source / filter

To view that list, turn off Grid Column Filters, Context Parents and select the Flat List view

2. Copy / Paste to Excel

�. Open the grid which contains the information to export

�. Select items / sub-items and the desired columns

�. Edit > Copy. Select 3-Selected grid rows and columns

�. Open Excel and Paste

Note:

All selected items will be copied

Item hierarchy will be collapsed (i.e. flat list of items)

3. Live Links to Excel

Other application can view live IQ data, including Excel. Details here

Pierre_Admin 2018/11/06 14:43

47 views

6. Export to Outlook

6. Export to Outlook

Export to Outlook

To export to Outlook from InfoQube:

https://infoqubeim.com/1254
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�. Export to Excel,

�. and... import the Excel file in Outlook.

To import the Excel file in Outlook :

Once the file is exported (your_file_name.xls) from IQ, open Outlook and use the Import and Export feature in

the File menu.

Follow the instructions.

( Approximately :

�. Click on Import from another program or file

�. Click on Microsoft Excel

�. Chose whether you want to Import duplicate items or not

�. Select the destination folder

�. Select the sheets you want to import in Outlook AND (for better results) (re)Map Custom Fields (follow

explanations in the dialog)

�. Click on Finish )

Tips :

The second exporting method to Excel (described in here) is usually simpler : copy in IQ -- Tab delimited -- and

paste in Excel.

But... if you decide to use the first one (using the Export to Excel button/function) :

�. Keep in mind that the exported grid must display all the fields that you want to export to (and

import in) Outlook

�. The whole grid will be exported, so you might want to filter out the unwanted items before you

export/import anything from IQ
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Live Links to IQ Grids from Word and Excel

Through ODBC, many application can view IQ data.

With Office applications, such as Microsoft Word and Excel, ODBC can of course be used, but an even easier

method uses ODC connections. Either way, you then have live connections to IQ data and you can:

Perform mail-merge, and email-merge

Share IQ grid content with other users that don't have InfoQube, simply by send them an Excel file. 

If you are connected though a LAN or a VPN, this file will be linked to your live data (or can easily be

made so by editing the connection file)

https://infoqubeim.com/321
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Use Excel to perform calculations on your data

Analyse it and Chart it with Excel

And this connection is live, so when you make changes IQ, the Excel sheet is updated!

What items / columns are exported:

�. Items: The items will be those that match the grid source. Context parents and sub-items cannot be

represented inside Word / Excel. The list will be the same as when the grid display settings are:

Display mode: Source items (flat list)

Context Parent off

�. Columns: The columns (Excel) and fields (Word) visible through the ODC connection will be the ones in

your grid when you create the ODC file. If you change the column set, simple regenerate the ODC file.

1. Creating an ODC file in InfoQube

To do so is as simple as:

�. Open the grid that you want to link to. In this example, we'll use the stock To-Do's grid.

�. Grid>>Create an ODC file:

A file with the name YourGridName.odc was created and placed in the same folder as your IQBase.

�. Important: The grid must be visible to other applications (Grid > Properties > Options > Grid visible to

other applications)

If it isn't a dialog will pop-up to do it for you:



2. Working with ODC files in Excel 2003

2 methods are possible

�. The first, which is the simpler way, consists of opening the .odc file (Excel > File > Open)

�. The second, a bit more complex, adds the link to an existing file, on a new sheet for example:

In Excel: Data>>Import external data>>Import data:

Select your grid.odc file:

and voilà!. Excel is now linked to your IQBase grid:



To refresh the data in Excel, right-click on the Excel table and select Refresh Data

Excel allows you to customize the connection. Right-click>>Data Range Properties:

3. Working with ODC files in Excel 2007

In Excel 2007 the easiest way to bring in an ODC file is from the File Explorer. Right-click the ODC file, select

Open With, the Excel. Excel will create a new Excel file with you using the ODC file.

4. Working with ODC files in Microsoft Word

In MS Word, you can mail-merge a document and send it to a list of recipients stored in your IQBase. To do so,

follow the normal steps to do an email-merge and in step 3 (in Office XP), select Use an existing list and browse



to your grid.odc file.
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 HTML Export: Table with Columns

Comments Reference

Column

headings

 This options is greyed out if the HTML style bulleted list is

selected

Sortable

headings

Adds javascript code to allow for sorting. Click on the

header to sort

Font

Sizes
 Enter a comma separated list of font sizes, for levels

1,2,3,4,5,6

Override item

font

If checked, font sizes defined above will override any item

specific font sizes

Include HTML

below the

item

Borders: Inner/Outer/Both/None

Spacing: After level 1 items/After level 1 and 2 items/None

Width:  Enter the width. Ex: 500px, 90%
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Cell Prefix:  Prefix added to all table cells

Cell Suffix:  Suffix added to all table cells

Check box

text:

Checked:

 To be used, instead of the default -1

Check box

text:

Unchecked:

 To be used for unchecked cells, instead of the default 0

Bullets: All levels/Exclude 1st level/None

Expand links: All levels/Exclude 1st level/None

Link type: Buttons/Item Text/Both

Closed items: Hide Item / Hide Item if Level 1 / Show Item, Hide Subs

Close items

at level #
 All items deeper than this level will be shown closed

Sortable

headings

 Adds javascript code to allow for sorting. Click on the

header to sort

Show (...)
 If checked, shows (...) after the item text to

expand/collapse the HTML

Close HTML
 If checked, HTML content will not be shown by default.

Click on (...) to show it

Indent:  Indent of the HTML content

Style=
The HTML style. Setting the HTML style to: background-

color: #FFFF00 would give you a yellow background.

Hide tag:

HTML pane text enclosed with this tag, via the

edit>"enclose text with" function will be excluded from

the HTML export

Selective

HTML

export
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HTML Export Merge Fields and Codes

To create your own merge template, use a "real" HTML editor (or WYSIWYG HTML editor).

But  -- NOT MS Word !! Otherwise, chances are that your template won't produce the expected results. If you

do use MS Word, save the file as Web page, filtered

Some free WYSIWYG HTML editor :

Amaya

https://infoqubeim.com/1547
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Free Online Web Page Editor

Nvu

Kompozer

BlockNote

WizHtmlEditor

IQ's built-in Doc pane

List of the "merge codes":

Code Description

{DataBLK} ...

{/DataBLK}
Defines the start and end of the HTML that contains merged data.

{ItemBLK} ...

{/ItemBLK}

Defines the start and end of an item. A page can contain multiple items (i.e. a

list of contact), and support multiple columns. This is defined only once. To

define other occurrences of item blocks, use the {ItemRPT} code

{ItemRPT} Placeholder that will repeat the ItemBLK content

{SomeFieldName} Will merge the value of the field "SomeFieldName" for this item

{Parent.SomeField} Will merge the value of the field "SomeField" for the main parent of this item

{PageBRK} Will insert a page break

 {ItemHTML} The content of the HTML pane for this item

Examples

A sample file is provided: AppFiles\InvoiceEx.htm

Here's a small example of exporting only a few item fields in a simple format :

{DataBLK}{ItemBLK}

==========================

Title : {item}

PROJECT : {project}

ORDER : {Order}

URGENCE : {Urgency}

DUEDATE : {DueDate} 

CATEGORY : {WIKITag}

==========================

{/ItemBLK}{/DataBLK}
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