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Synchronization

InfoQube supports the following types of synchronization:

�. Synchronization between computers using Dropbox

�. Synchronization with Google Services

�. Synchronization with Remote Databases
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Synchronization between computers using Dropbox

It is possible to use the same IQBase on multiple computers.

Following a simple setup, you'll be able to seamlessly edit information in your IQBase using any number of

computers. If an instance detects a change, it will inform the user and use the updated copy. No need to close

each instance of your IQBase to be able to use it on another computer.

The synchronization typically uses a sync service, such as Dropbox (though a LAN / WAN setup will work too).

A- Setup Instructions

To setup, follow these easy steps:

1-Set-up folders

Let us assume that the user (User1) wants to have the IQBase in the folder IQBases of Documents. So on first

computer (PC1):

MyIQBase1.SNDB is located in C:\Users\User1\Documents\IQBases

Backups can be located in C:\Users\User1\Documents\IQBackups

Note that having backups is not really required since the sync process automatically copies the database to

multiple computers and to Dropbox, which itself acts as an online backup

Sync folder needs to be in a Dropbox folder (i.e. C:\Users\User1\Documents\Dropbox\IQBases\Sync)

.Files folder (MyIQBase1.SNDB.Files) needs also to be a Dropbox folder (i.e.in

C:\Users\User1\Documents\Dropbox\IQBases\MyIQBase1.SNDB.Files)

2- Set-up the IQBase

Start IQ and open C:\Users\Documents\IQBases\MyIQBase1.SNDB
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Open the Options dialog (Tools > Options)

In section 2.4 (Data storage), set-up items 2.4.7 and 2.4.10 as per the following screenshot:

A file named MyIQBase1.ini will be created to save these sync settings

Note that in the above screenshot, the Sync and .Files folder now show the absolute path (i.e.

C:\Users\User1\Documents\Dropbox\IQBases\...)

3- Set-up other computers

Do step 1 above on the second computer (i.e. PC2). The IQBases folder on PC2 does not need to have the

same path as on PC1 (to handle different account names)

Copy MyBase1.SNDB from PC1 to PC2 or wait for the initial sync process to occur. The file MyBase1.SNDB

will appear in the sync folder. Copy this file in the IQBases folder (i.e. C:\Users\User1\Documents\IQBases)



Repeat step 2. The Sync and .Files folders shown will be those of PC1. If PC2 has a different folder structure,

enter the correct folders. 

Repeat step 3 for each additional computer

You are now ready to start using your IQBase on multiple computers.

B- Using IQ on multiple computers

Once properly setup, using a synced copy of your IQBase is the same as a regular IQBase.

If an updated copy is found, IQ will display this dialog:

Unless you want to ignore (and lose) the changes, click the default button to update your database. Views (grids,

calendar, etc) will not auto-update, so it is recommended to refresh (F5) all opened views.

Also, be sure to read the next section, Precautions, to ensure a safe and smooth synchronization.

C- What is synced and what is not

All settings in Tools > Options > This file are synced with the exception of the following (which are saved in

YourFile.ini and therefore not synced) :

�. Backup paths (2.4.6)

�. .Files path (2.4.11)

�. Sync settings (2.4.8, 2.4.9, 2.4.10)

�. Pane layouts

In addition, the following is also saved in the IQBase:

�. Tab-workspace layout

�. Grid name is used for Search, Scratch, Inbox

�. User Home pages

�. Outline labels

The following settings are not synced (since saved in the installation folder) :

�. List of users

�. User name (IQ uses the logon name to stamp all changes)

�. All settings in Tools > Options > Program Settings (file options.ini)

�. Dialog sizes and default settings (file settings.ini)

�. Menu customizations (files menu.dat and menuhtml.dat)

�. HTML pane's default documents (NewHTML,HTM, NewMHT.MHT, etc)

�. Default Home page



n.b. Only the IQBase is synced using this setup. To sync more, consider putting the program folder on a Dropbox

folder (possible but not recommended)

D- Precautions

�. After making changes to your IQBase, it is important to let your computer update the sync version. You can

force a save by doing Grid > Save (CTRL+S) or wait until the auto-backup executes (delay between auto-

backups is set in Options > 2.4.3)

�. After the changes have been saved in the Sync folder, you must also wait until Dropbox uploads the

changes. You can check the Dropbox status icon on the taskbar. This delay depends on the file size, amount

of changes and your Internet upload data rate, but is typically less than 15 seconds. Once this is

completed, you can pause or shut down the computer if you wish.

�. When restarting a computer (startup or exit from pause), it is important to wait for the update process to

complete (Dropbox must build its index on startup and then download all new files). Do not start editing

your IQBase until this is completed. This may take significant time if there are many and/or large files to

download. Monitor the Dropbox status icon on the taskbar. IQ itself will pick up the change very quickly (< 2

seconds) and prompt you if you if an updated file is available.

�. To avoid needless disruptions, IQ looks for "data" change. UI changes will not trigger an update. Examples of

these are grid settings, grid columns, etc. 

If you want these to be sent to other computers, ensure that you make a small data change to trigger the

sync process.

�. When using EmailToIQ in conjunction with Dropbox sync, there is a possibility that emails are imported to

the older file before you get the chance to sync/overwrite it with the newer one.

If this happens, you have 3 options:

Set EmailToIQ to be in manual mode (line 2.3.2 = 0)

Open the Email client (or navigate to your web server using a browser) and mark the emails as Unread.

IQ will re-import them

Manually re-import previous emails. To do that, right-click on the Tools >  Check EmailToIQ

now command and select the number of days you want to re-import
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Synchronization with Google Services

InfoQube can sync with the following Google Services:

�. Calendar

�. Tasks

The end goal is to enable synchronization with many Google services, such as:
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Contacts

Keep

Drive

GMail

The steps to enable sync are:

�. Authorize access

n.b.: If the current IQBase was authorized using a previous version of IQ (v114 and previous), it needs re-

authorization. Disconnect and Reconnect to perform this

�. Set sync parameters for each Google Calendar

�. Set sync parameters for Google Tasks

1. Authorize Access

Use Tools > Google Connect to show the Google Connect dialog:

InfoQube uses the latest most secure method to connect to Google services (3-Legged OAuth 2.0). This ensures

that it has no knowledge of any password and at any time, you can choose to revoke access.

To do so, access is granted using your default browser.

�. Click the Connect button

�. Your default browser will open (a Windows Security Alert dialog may show, if so, click Allow access)

�. If you are not logged into the Google account you want to use, click on Disconnect and select the account

to use:

�. Currently, it seems Google needs to validate that IQ is safe, so until this is resolved, you'll get a warning

when connecting to Google:



Click Advanced and then Go to InfoQube (unsafe)

�. Once logged on, this page will be shown:

�. Click Allow to proceed and close the browser

�. InfoQube will receive the connect token and show the calendars and tasks lists in this account:



�. Click on the checkmark, left of the Calendars and Tasks to enable / disable sync

 2. Set Sync Parameters for each Calendar

�. Click the >> button (right-most grid column) to configure each calendar to be synced:

�. Click the ... menu (top right) to:

�. Get information on this calendar. It will list a few calendar statistics:

�. Delete local copies of all events in this calendar

�. Select Sync Type. It is one of:

�. None

�. View Events

�. View / Edit Events

�. One Way: Google --> IQ Items

�. One Way: IQ events --> Google

�. Full: Google <-- --> IQ Items

�. The last 3 sync types require a matching IQ field. Select from the dropdown list or click New to create a new

date field. See section 3 below

�. Select how often to sync the calendar (0=manual). Each calendar can have different settings



�. Click OK

�. Repeat for all the calendars to sync

�. Once done, click the Close button to dismiss the Google Connect dialog

�. A popup message will be shown on the taskbar informing you that sync is in process. You can continue to

work normally

3. Set Sync Parameters for Tasks

�. Click the >> button (right-most grid column) to configure task sync:

�. Start Date: Tasks created / updated before this date will not be synced 

�. Click the Tasks Grid... button to create a grid pre-configured to view tasks:

4. Syncing Calendars

Syncing calendars is a simple process:

Click on the Calendar icon the status bar to schedule a sync

If Sync is not set to Manual, it will run at the specified interval

If the Google Connect dialog is open, you can also click on the refresh button (first column in the list) to

sync changes or perform a full-sync

Changes made to the Google calendars (list of calendars, calendar color, etc) are not automatically read during

the sync process.

To refresh, simply open the Google Connect dialog (or if already opened, click on the refresh icon located just

above the calendar/tasks list).



4.1. Selecting the Sync Type

InfoQube provides a number of Sync types. To select the most appropriate sync type, it is useful to understand

the relationship between items, date values and events.

In InfoQube, each item can have many associated dates. For example, a "contact" item could have:

Birthday

Wedding date

Graduation date

etc.

Each of these dates are stored in a separate date field. Date fields are shown in the Properties pane and can be

shown as a grid column.

The IQ Calendar does not display items. It doesn't display dates either. It displays Events. Each date field-value

can be turned into an IQ event and shown in the Calendar.

IQ provides many ways to create events, but the process revolves around selecting a date field-value(s) and

instructing IQ to show it in the Calendar.

An IQ event has a date plus many associated properties:

Duration

Scheduled, Unscheduled or All-day

Description

Location

Repeating pattern

etc.

Events not linked to an item

Events created in InfoQube are always associated with items and date field-values. Deleting an item deletes

all its events

This isn't always the case for events created outside of InfoQube, such as Google Calendar events

An event not associated with an item can only be displayed in the Calendar, not in grids and other UI

Whether an item is created for each Google calendar event depends on the sync type

4.2 Sync Type: None

To prevent events from syncing, you can either:

Un-check Enabled in the Calendar Sync dialog

Set the Sync Type to None

4.3 Sync Type: View Events

To simply view events from a particular Google calendar, select this sync type

This could be a read-only calendar (national holidays, co-worker's calendar, etc) or any calendar that you

don't want to associate with IQ items

It is the sync type that has the least effect on your IQBase

At any time, you can decide to set the sync type back to None and events will be deleted from the IQBase

Since these events are not linked to any item, they can only be viewed in the Calendar, not in grids and

other UI



4.4 Sync Type: View / Edit Events

Similar to 3.2 above, except that events can be modified within IQ. Changes will sync back to Google 

4.5 Sync Type: One Way: Google --> IQ Items

All events created in Google Calendar become IQ items and events

The date field set as the sync field (in the Calendar Sync dialog, shown above) contains the event date / time

4.6 Sync Type: One Way: IQ Events -->Google

All events created in IQ become Google Calendar events

Events modified in Google Calendar are synced with IQ

Events created in Google Calendar are not synced with IQ

Events deleted in Google Calendar are not synced with IQ

If a full sync is performed, events which were deleted in Google Calendar will be shown again in Google

Calendar

4.7 Sync Type: Full: Google <-- --> IQ Items

All events created in IQ become Google events

All events created in Google Calendar become IQ items and events

The date field set as the sync field (in the Calendar Sync dialog, shown above) contains the event date / time

4.8 Removing Synced Events

When transitioning from a Sync type to Sync None, users may want to remove local copies of events

For a limited number of events, this is best done using the Calendar:

In Google Sync, set the Calendar Sync type to None. Click OK to save

Select one or more events and do Edit > Delete (or hit the Delete key)

For a large number of events, do:

�. In Google Sync, set the Calendar Sync type to None. Click OK to save

�. If the Google Calendar was at some point synced to IQ items, it is best to delete these items

�. In the Calendar Sync dialog, click on the ... menu and select Delete local events

�. You' ll be prompted to delete just events not associated to items or all events created on Google Calendar

See also: 2. IQ Calendar

5. Syncing Tasks

Syncing tasks is a simple process:

Click on the Tasks icon the status bar to schedule a sync

If Sync is not set to Manual, it will run at the specified interval

If the Google Connect dialog is open, you can also click on the refresh button (first column in the list) to

sync changes or perform a full-sync
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Changes made to the Google tasks (number and name of the task lists) are not automatically read during the

sync process.

To refresh, simply open the Google Connect dialog (or if already opened, click on the refresh icon located just

above the calendar/tasks list)

See also: Managing Tasks

Notes:

For read-only calendars (as the example above), only None, View Events and One Way: Google --> IQ Items

are enabled

When an item has more than one event, each event becomes a separate Google event

Put differently, the fact that events belong to the same item is not an information that Google Calendar

knows

For the sync types that involves items, each Google calendar must be linked to a distinct IQ date field. That

is, a date field cannot sync to more than one Google Calendar
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Synchronization with Evernote

InfoQube can now sync with Evernote !

Evernote sync is available as a two-tier feature:

�. Sync with a single Evernote Notebook and a single Tag (free IQ Outliner): Available in v117Pre1

�. Sync with any / all Evernote Notebooks and Tags (InfoQube IM): Not yet available, in development

1. Set-up: Connect and Authorize

Use Tools > Evernote Connect to show the Evernote Connect dialog:

InfoQube uses the latest most secure method to connect to Evernote (3-Legged OAuth 2.0). This ensures that it

has no knowledge of any password and at any time, you can choose to revoke access.

The first step is to select the Evernote account.

Evernote will show a "connect" dialog:
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The Google and Apple connection do not work. Perhaps Evernote will eventually fix this.

So currently, you must use option 3 and enter your Evernote account name or email + password.

You'll then be prompted to Authorize access:

Once authorized, the Evernote Connect dialog will update and you can set sync options:
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2. Viewing / Editing Synced Notes / Items

On first sync, a notebook and a tag will be created, both named IQENSync. The sync engine will import all

Evernote notes in this notebook or tagged with this tag.

In InfoQube, you'll find 2 new fields:

�. ENSync: All items with this field checked will sync between InfoQube and Evernote

�. ENTrash: Checked if the note has been placed in the Evernote Trash

A grid is not currently automatically created to view the synced content. Create one with ENSync as the grid

source (details here):

In the above sample, there are 3 notes being synced with note 3 being in the Evernote trash.

The actual note content is naturally shown in the Doc pane, which supports all the same editing features as

Evernote. A new toolbar is now available which reproduces the Evernote's one:

One can also use the Item Editor to view the Item / Note:
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3. Syncing between InfoQube and Evernote

One-way sync (from IQ to EN) is performed whenever the Doc pane / Item Editor content is saved

Two-way sync will be performed as a background process every X minutes as set in the Evernote Connect

dialog (see above)

In addition, there is an icon on the status bar: 

Single-click will perform two-way sync between IQ and Evernote

Double-click will open the Evernote Connect dialog

Evernote can handle a variety of content. The following gives the current sync status (as this feature is still in

development):

3.1 Information that syncs

�. Title

�. Text content

�. Text formatting (bold, italic, underline, etc)

�. Hyperlinks

�. Tables

�. Highlight colors: Evernote supports 6 highlight colors. During sync, the closest color is used to match the

background color selected in IQ

�. Checkboxes

�. Checklists

�. Divider line

��. Web clips source URL: Loose sync in that URL content will sync, but deleted URLs will not sync

3.2 Information that will sync (still in dev)

�. Tags

�. Images

�. Text contained in images

�. Code blocks

3.3 Information that may never sync (i.e. it isn't planned)
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�. Media notes

�. Attachments

�. Stacks

�. Google Drive

�. Sketches

More Information

�. Items deleted in IQ will move the corresponding Evernote note to the trash

�. Toggling the ENTrash field will move / remove notes from the Evernote trash. It is much quicker to do this in

IQ than in the Evernote app

�. Items can be arranged in a hierarchy (not possible in Evernote)

�. By default, only top-level grid items will sync with Evernote (i.e. ENSync field checked)

If you want all items created in this grid to sync with Evernote, in Manage Grids > Data, add ENSync to the

setting "Auto-assign field list for all items added to this grid"

�. Once the IQENSync notebook and tag have been created, these can be renamed

�. If you have some content in an existing notebook or tagged with an existing tag and want IQ to use these,

follow these steps:

�. Disable the sync (in IQ)

�. In Evernote, delete the IQ generated notebook and/or tag

�. Rename the existing notebook/tag to IQENSync

�. Re-enable sync and perform a full sync

�. Once sync has completed, you can rename the notebook/tag to their original name

�. Evernote imposes API usage limits. If this is exceeded, the service will be suspended for a significant amount

of time (30 minutes or more). The Evernote icon on the status bar will show  !!  and give the number of

minutes before sync can resume

�. The free Evernote tier allows for 2 devices (Evernote > Account > Devices). This is typically a mobile device

and an app (Windows, macOS, Web)

�. As InfoQube is not considered as a device, but rather as an application, it does not count as a device and

can be a third method to access your EN content
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Synchronization with Remote Databases

InfoQube can pull data from external data sources, such as SQL Server, mySQL, Oracle, MSAccess, etc. Any

ODBC data source can be used.

When configured correctly, a click of a button is all that is required to refresh the data!

This is an advanced feature which requires some database query knowledge to configure it correctly.

The sync is done through a configuration file (xml type). This file defines:
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The connection string

The SQL statement to retrieve the data (use Access, Enterprise Manager or other similar tool to generate

the statement)

The field mapping between the back-end database and InfoQube ( back-end fields are [ ] enclosed,

otherwise a fixed value will be imported)

The synchronization parameters. (Unique record identifier field, Last update date, etc)

The back-end database can be local or remote (either publicly visible or through a VPN).

To enable this feature:

In Tools > Options > This Database > Data storage

Enable Remote database one-way sync
Set the auto-sync delay (in minutes, 0=manual only)
If syncing with only one remote database, enter the sync config file
If syncing with more than one remote database, leave Sync Config File blank and put all config files in the same folder as the
IQBase. InfoQube will ask you which ones to sync (uses SQLSync*.xml as a matching pattern)

2 examples are provided here:

Sync with the Online User Manual (mySQL server)

Sync with a fictitious SQL Server database
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Sync with a fictitious SQL Server database

Sync with a fictitious SQL Server database

The fictitious SQL Server back-end database contains contact information (companies, contacts, record status,

etc). It is used as part of a secure web-site, where users can view/modify their information. The managing

organization already uses InfoQube for CRM type information and wanted to link to the web-site information as

its agents were answering calls/emails.

The following configuration file can be used:

<ConnectionString>PROVIDER=SQLOLEDB.1;PASSWORD=SomePassword;PERSIST SECURITY INFO=TRUE;USER

ID=SomeUser;INITIAL CATALOG=YourDataBase;DATA SOURCE=SQLServerIP;Use Procedure for Prepare=1;Auto

Translate=True;Packet Size=4096

</ConnectionString>

<Password></Password>

<FieldMap>

[company_id] IDSQL

[steward_no2] NoEnterprise

[company_name] Item
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[address1] Address

[address2] Address2

[address3] Address3

[city] City

[province] Province

[postal_code] PostalCode

[country] Country

[website] WWW

[phone_number] Tel

[fax_number] Fax

[first_name] FirstName

[last_name] LastName

[title] Titre

[telephone_no] TelContact

[telephone_ext] Ext

[last_modified] DateUpdate

[email_address] email

IMPORT IDStatusSQL

1 Contacts

</FieldMap>

<Source>

SELECT dbo.COMPANIES.*, dbo.COMPANIES_S.steward_no AS steward_no2, dbo.CONTACTS.first_name,

dbo.CONTACTS.last_name,

dbo.CONTACTS.title, dbo.CONTACTS.telephone_no, dbo.CONTACTS.telephone_ext,

dbo.CONTACTS.email_address

FROM dbo.CONTACTS_S RIGHT OUTER JOIN

dbo.CONTACTS ON dbo.CONTACTS_S.contact_id = dbo.CONTACTS.contact_id RIGHT OUTER JOIN

dbo.COMPANIES INNER JOIN

dbo.COMPANIES_S ON dbo.COMPANIES.company_id = dbo.COMPANIES_S.company_id ON

dbo.CONTACTS.company_id = dbo.COMPANIES.company_id

WHERE (dbo.CONTACTS_S.primary_contact = 1) AND (dbo.COMPANIES.last_modified > CONVERT(DATETIME,

'[LASTUPDATE]', 102))

</source>

<RecordIDField>IDSQL</RecordIDField>

<RecordStatus>IDStatusSQL ADD UPDATE</RecordStatus>

<RecordDateField>DateUpdate</RecordDateField>

<LastUpdate>2007-03-15 07:00:00</LastUpdate>

Notes:

The Password key is optional and if present, is the encrypted password (inquire about the encryption utility)

Field mapping format is: [BackEndField] TABKey InfoQubeField or Value TABKey InfoQubeField. In the latter

case, InfoQube field will be assigned Value. In the above example, Contact field is checked for all imported

data and the string "IMPORT" is placed in the field IDStatusSQL

Source: standard SQL select statement with 1 exception. The string [LASTUPDATE] will be replaced by the

LastUpdate key. This way, only changed data is read. If this is not used, all recordset data will be read on

each update, which may take a long time.

RecordIDField is the InfoQube field to hold the back-end database record key

RecordStatus format is: InfoQubeField TABKey AddString TABKey UpdateString. This step is optional but will

fill the InfoQubeField with AddString if adding, and UpdateString on record update. In the above example,

ADD and UPDATE will be placed in the field. This way managers can process these separately



RecordDateField is the InfoQube field which contains the record last change date (used in conjunction with

the LastUpdate)

LastUpdate is the date/time of the last update. Used in conjunction with the SQL Select statement to read

new/changed data only
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Sync with the Online User Manual

InfoQube can sync with the Online User Manual so that any new content / changes will automatically be imported

in any IQBase.

The "Welcome to InfoQube" IQBase is pre-configured to connect with our web server.

Steps are:

�. Download and install the mySQL ODBC connector (version 8.0)

Select Windows (x86, 32-bit), MSI Installer or use this direct link

�. You'll be asked to login to Oracle. You can, but better still simply click on No thanks, just start my

download

�. Install the downloaded file (mysql-connector-odbc-8.0.xx-win32.msi)

�. To synchronize, do Tool  > Database management  > Remote database sync 

(you can customize the toolbar [right-click ->customize] to add it to a toolbar if you want)

To configure another IQBase, a few fields must be created. The extra steps are:

�. In Field Management, create the following fields:

IQDoc: Yes/No

IQDocDate: Date: Doc update date

IQDocNID: Number: Doc node ID

IQDocPID: Number: Doc parent node ID

IQDocStatus: Text: New / Update status

�. To have a direct link to the online page, add the following in the Equations > Auto-assign section of the field

IQDocNID:

AM:[URL]="https://infoqubeim.com/drupal5/node/" & [IQDocNID] | E:[URL]= 
 

�. Create a new grid IQDoc (will automatically use the field IQDoc)

�. In Tools > Options > This File > Data storage

�. Enable Remote database one-way Sync

�. Set  the auto-sync delay (in minutes, 0=manual only -- recommended)

�. In Sync Config file, browse to select the config file. The one provided is SQLSyncIQDoc.xml (located in

AppFiles folder)
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�. If syncing with more than one remote database, leave this blank and put all config files (named

SQLSync*.xml) in the same folder as the IQBase. InfoQube will ask you which ones to sync.

When using sync, the following applies:

�. Sync main field is IQDocNID.

�. If an item exists with book page node id, it is used else an item is created

�. The fields Item and HTML are updated with the doc content

�. There are a few Regexp substitutions made, as defined in the SQLSyncIQDoc.xml file

�. Relative paths are converted to absolute ones

�. Internal links (node:nodeid enclosed by [ ]) are converted to URLs and to an IQBase internal link

(IQDocNID=nodeid)

�. You can add any other field values / tags and these will not change after a sync

�. New doc items will appear under the correct parent item. It's positional order may not match the web site

though

�. The last line of the sync config file gives the date of the last sync (in ICal format). Only changes more recent

than this date will sync. To re-sync with the whole user manual, remove that date:

i.e. change <LastUpdate>20181120T011501</LastUpdate> to <LastUpdate>
</LastUpdate> and save the file.

The Online User Manual is nice, but having an updated copy right inside InfoQube is so much nicer to navigate,

read, search, filter, etc.

Troubleshooting

If you have difficulty connecting to the remote database, try disabling the router firewall. If it then works,

configure to open port 3306, which is used by IQ to access remote databases
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