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Working with Icons

Icons can be used in many contexts within InfoQube:

Anywhere inside the item text. These will display in just about all InfoQube UIs (Grids, Properties pane, Calendar, Surface, TimeLine, Map View)

Anywhere in other text fields (Grids, Properties pane)

In Field names (Grids, Properties pane)

As part of Outline labels (Grids)

In Links (Surface)

1. What Icons are available

Icons are loaded from the \Icons folder when InfoQube starts

The default setup has 88 icons. There are quite a few free icon sets that can be downloaded. Do not hesitate to be create !

To add icons, add image files to that folder. Images must be 16x16 gif files (8-bit color depth or less)

The icon file name is what is used everywhere within InfoQube, so be careful if renaming image files

2. Manually Adding Icons inside Text Fields

All text fields support icons. Typical uses are:

Item text

Field showing the item's type or types (contact, task, event, etc)

Field showing the item's status (To do, In progress, Late, Done)

To add icons, do one of:

In a grid, use the formatting toolbar and select an icon from the dropdown command button

Insert the html code for the item. It is <img>IconName</img>. If the icon name is not correct (bad spelling, deleted), a place holder is shown

Edit the text using the Popup Editor. Right-click and select an icon from the list

The icon name is the file name, in lower case, without the .gif extension

The icon name is case sensitive in some UI and not in others, so it is best to simply always use lower case

3. Icons in Field Names

It can be really useful to display icons in grid's column header, as visual cue and when the field name is rather long (such as Date_Of_Preliminary_Report)

Grids: Right-click on the column header > Column Header > Caption. The Popup editor will show where you can change the displayed name, font, and

add icon(s)

Properties pane: Right-click on the field > Caption

4. Icons in Outline Labels

See 2. Outline Labels

5. Icons in Surface Links

https://infoqubeim.com/drupal5/index.php/pierre
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See 3. IQ Surface

6. Automatic Icons

It is possible to automatically add icons, as items are added, field values checked, etc. Typically, this uses field Auto-Assign rules.

Example 1: Item Type column

�. Create a text field and name it ItemType

�. In the AddressBook field properties > Equations > Auto-Assign Rules, add: A:ItemType="<img>users</img>" | E:ItemType=
�. Similarly, the TaskDate could be used to show a task icon when a date is set: A:ItemType="<img>pen</img>" | E:ItemType=
�. When a task is done, the icon can change with the rule: A:ItemType="<img>check</img>" | E:ItemType=
�. Save and close the Field properties dialog

Example 2: Multiple Icons

It is even possible to automatically show multiple icons using VBScript. There are System supplied functions to do just that

AddKeyword (...)

RemoveKeyword (...)

Use the following rules for AddressBook: A:ItemType=AddKeyword(ItemType, "<img>users</img>") |
E:ItemType=RemoveKeyword(ItemType, "<img>users</img>")

List of Default Icons
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Selecting Items

Selecting a single item is simple and the same for all UIs: Click on the item

Selecting multiple items is allowed in most UIs with specific methods that depend on the UI. IQ can show multiple items in the following UIs:

�. Grid (Outliner with columns)

�. IQ Surface

�. IQ Calendar

�. Card View
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�. Map View

�. TimeLine View

1. Grid (Outliner with columns)

Grids support selecting one or more items. To select items, use any of the following methods:

Using Mouse / Touchpad

Click on an item. Unselects any previously selected items

Click to select the first item. Shift+Click on the last item: Selects contiguous items

Ctrl+Click to select an item keeping previously selected items (i.e.toggles the item select state)

Click and Drag from the first item to the last item

2 caveats: (1) Click must not be on the tree column (this starts item drag-drop). (2) The columns must make up half or more of the grid (known bug)

Using the Keyboard

Up/Down arrow to select an item

Shift+Up/Down arrow: Selects contiguous items

Ctrl+Up/Down arrow: If 2 or more items are already selected, this will move the focus to a different item. Press Space Bar to toggle the select state

Using Menu Commands

Item > Select has the following sub-commands:

Unselect All

Invert Selection

Select Sub-Items (also available under Item > Sub-Items)

Edit > Select All (Ctrl+A): Selects all visible items (i.e. not  filtered)

2. IQ Surface

The IQ Surface supports selecting one or more items. To select items, use any of the following methods:

Click on an item. Unselects any previously selected items

Ctrl+Click to select an item keeping previously selected items (i.e.toggles the item select state)

Hold the Shift key and Click and Drag to select items in an area 

Item > Sub-Items > Select Sub-Items

Edit > Select All (Ctrl+A): Selects all items

3. IQ Calendar

The IQ Calendar supports selecting one or more events. To select events, use any of the following methods:

Click on an event. Unselects any previously selected events

Ctrl+Click to select an event keeping previously selected events (i.e.toggles the event select state)

Hold the Shift key and Click and Drag to select events in an area 

4. Card View

The Card View supports selecting one or more items. To select items, use any of the following methods:

Click on an item. Unselects any previously selected items

Ctrl+Click to select an item keeping previously selected items (i.e.toggles the item select state)

Hold the Shift key and Click and Drag to select items in an area 

Edit > Select All (Ctrl+A). Selects all visible items in a quadrant (i.e. not filtered)

If all are already selected, selects all visible items in the view

5. Map View

Map view does not support selecting multiple items. Click to select an item

6. TimeLine View



The TimeLine view shows items as Gantt bars and while more than one bar can be selected (using Ctrl+Click, drag to select), not much can be done with

these selected bars.

Hint: Keyboard shortcuts can be assigned to all of the above commands. Details here
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Task Dependencies in InfoQube

In InfoQube, you can set dependencies between items, typically items which represent tasks. This is done using 3 fields:

�. TaskID (System Field #97)

�. NextTaskID (System Field #98)

�. NextTaskDelay (System Field #93)

These are used in 2 contexts:

�. Gantt chart, to show links between items, optionally defining the exact dependency (Finish to Start for example)

�. Task management through the Next Task Actions settings

1. Gantt Chart Task Links and Dependencies

See Gantt Charts and Project Management for details

2. Next Task Actions

The purpose of this feature is to perform some operations on dependent items when an item is marked as done. Examples of operations are:

Set a due date

Change the item color

Have it shown in a To-Do's grid for immediate action

Repeating Tasks

1.1 Example 1

Consider the following scenario where we have a series of tasks as seen on a fictitious June 30th. Task 1 is due the next day so the item has turned blue.

One can use the TaskID, NextTaskID and optionally NextTaskDelay to define dependencies:

TaskID field:

By default items don't have any TaskIDs. This is by design as not all items are tasks and of those tasks, not all have dependencies.

The TaskID field is auto-generated. To set it, simply double-click on the cell and InfoQube will find the next available number.

NextTaskID field:

Once you've assigned TaskIDs, you can start entering NextTaskIDs.

Notice that you can enter a comma separated list of TaskIDs in the NextTaskID (see item 1.1 above)

Notes: NextTaskID may map to the item hierarchy but do not need to. In fact, you can have items from totally different hierarchies and/or different

grids, etc and still create dependencies this way. In this example, these mostly follow the hierarchy, except the last one. The next task of item 1.1.2 (Task

4) is 1.2 (Task 5)

NextTaskDelay field:

https://infoqubeim.com/144
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Enter here the delay (in days) before the next task is due

If left blank, 0 is assumed

Next Task Actions settings:

Use Tools > Options > This file > General > Next task actions to define what operations should be applied to dependent items when an item is

marked as done.

In this example, this setting is: AM:[DueDate] = [done] + [NextTaskDelay] | E:DueDate=.

This means that when you mark an item as done, dependent one(s) will have the field DueDate set to X days after completing the task (where

X=NextTaskDelay)

If the done field is erased, the DueDate will be removed.

In the sample database, setting the DueDate also sets the item back color through the Urgency field 

(See the DueDate and Urgency Fields)

Starting v0.9.26PreRel54, you can also reference field values of the dependant items. To do so, enclose those field is curly brackets ( {Field1} )

For example, you can have AM:[DueDate] = [done] + [NextTaskDelay] + {AdditionalDelay} (where the field AdditionalDelay is a field value of the

dependant task.)

Once set up, let's see what happens as tasks are completed.

�. Let say that Task 1 is completed 1 day ahead of scheduled, on June 30th. 

Task 2 is the next task, it will have a new DueDate equal to when Task 1 was done + 5 days (NextTaskDelay is equal to 5 for Task 1). 

Notice that the item color is set to yellow, to indicate that the item's deadline is not too far away:

�. A week later on July 7th, Task 2 has turned Purple to indicate that the task is now late (as Urgency is now up to 2)

It is finally completed and both dependent tasks (Task 3 and Task 4) will have a new DueDate of July 9th (Done date of Task 2 + 2 days):

(notice how Task 2 looses its ItemColor as it is marked as done)

�. Finally, Task 4 is marked as done, say on-time on July 9th.

Now, notice that Task 4 has a dependent task (Task A) which is totally unrelated. Regardless, it then becomes the focus of attention.

The To-Do's grid shows items which require attention. It will therefore now highlight Task A:



1.2 Example 2

As a second example, consider the task of watering plants. One can use an Event recurrence for this, but it is not really suitable.

That is, say you want to water the plants every 2 week, on Mondays. If one week, you forget and only water them the following Monday, a regular recurrence

would warn you a week later, when really, it would be more suitable to do it 2 weeks later. This type of recurrence is known as "Interval-Since-Completion

Recurring Task".

Setting this up is really easy in InfoQube:

�. Set the NextTaskID equal to the TaskID and set the NextTaskDelay to 14 (days):

�. As soon as you mark the item as done, a new DueDate will be set, 14 days later. 

If done on July 8th, the next DueDate will be July 22nd:

�. If the next time you water the plants late, say on July 26th, the next date will be automatically set to 14 days later, on August 9th:

Pierre_Admin 2010/10/05 11:29

17 views

3. Backup your database, Encryption

3. Backup your database, Encryption

1) How Information is Saved in IQ

Summary:

Your main IQ file (also known as an IQBase) has an .SNDB extension e.g. YourIQBase.sndb

There is an associated folder YourIQBase.sndb.files which stores web clippings, MHT content (from the HTML pane), etc

Information viewed in IQ can be from 4 sources:

YourIQBase.sndb:-  Grids, Calendar, embedded HTML content

YourIQBase.sndb.files folder:-  Embedded HTML and captured content (universal clipper, browser extensions, etc) saved as MHT or as an HTML file *

A link to a file anywhere on your computer (or a link to an item in a file, such as an Outlook item link)

A URL from the web (web-pages viewed with the HTML pane in browse mode)

To back these up:

See #2 below for IQ options to backup the SNDB file

See #3 below for suggestions on backing up the YourIQBase.sndb.files folder

Linked items (e.g files stored elsewhere on your computer and linked to IQ) and web pages browsed are not backed up

* Keep the following in mind:

Images from clipped web content saved as HTML are currently NOT saved locally. If you aren't online, you will not be able to see these images.

If you want / need to see images offline, save in MHT format.

2) IQ's backup options:

Menu: Tools >Options:

https://infoqubeim.com/drupal5/index.php/pierre


 Options from 2.2 onwards are related to current file - these options are only visible when a file is open.

Important Notes :

When backing up your database file (IQBase), using the settings shown in Options, only the *.SNDB file will be backed up.

The folder IQ creates to contain all the separate HTML/MHT files (*\YourIQBase.SNDB.Files\ ) is by default located in the same folder where the

Database is initially created. It is not backed up using the integrated backup option (see #3 below for tips on backing up this folder). Text copies

of the HTML Pane content are stored in the database SNDB file

The Backup options :

# 2.2.1  - Backups created on program close (# 2.2.1) use rotating numbers .SNBK0, .SNBK1 and .SNBK2 e.g TestFile.SNBK1 (where .SNBK0 is the

current backup, .SNDB1 is 1 day old and .SNDB2 is 2 days old). This is NOT enabled by default.

# 2.2.2  - By default, Auto-Backup (# 2.2.2) is set to every 10 minutes. These backups are currently saved in the same folder as the file itself. After

10 minutes the backup files are replaced if changes have been made to the file. These backups have .SNBKA extensions.

# 2.2.3  - If you enable the Timestamp option (# 2.2.3) each backup creates a new file, with the date/time in the file name, e.g. TestFile.20090818-

1848.SNBKA. Format is always: Filename.yyyymmdd-HhNn.SNDBA (where Hh is hour in 24hr format, and Nn is minutes). Otherwise backups are

replaced by the most recent backup.

# 2.2.4  - Limit the number of backups created:

This option deletes all but the last timestamped auto-backup of each day that are at least n days old.

Delete is performed once per day, on the first occasion after midnight.

# 2.2.5  - Select the folder where the backup is to be created. If this is left blank, the backup is created in the same folder as the IQ file. If this is

your only backup it is recommended to add a different backup location here, ideally on a separate partition, or even better, on a different hard-

drive (click in option # 2.2.5 and browse to new location).

~

If you are using IQ on a USB stick it will probably have different paths on different computers. In order to backup the database on the USB stick

use a relative path for the backup folder path:

Tools > Options > 2.2.5 Backup folder:  instead of g:\somepath\somesubpath, simply enter "somesubpath" (assuming the IQBase is in the

folder "somepath" (make sure that "somesubpath" exits!)

See Link to Files, Folders and URLs for more info about relative paths. See also Backin Up to discuss relative paths.

- Manual backups:

   are done on demand:-  Menu: Tools > Database Management > Backup.  Manual backups have an .SNBKM extension.

3) Tips for more complete backup:

A good option would be to use some online backup system - either to backup your backups, or, to copy the database file itself .A service like Dropbox will

backup your file and make a revision each time you close the file. Dropbox is unable to backup your file while it is in use. (Note: revisions are only made for

https://infoqubeim.com/116
https://infoqubeim.com/1048
https://www.dropbox.com/


the last 30 days in the free version). If IQ creates a backup in the same folder, there is the advantage that Dropbox can back that up while the IQ database is
open. You would then have the following in the Dropbox folder:

  the IQ Database file e.g. YourIQBase.SNDB

  the folder *\YourIQBase.SNDB.Files

  the auto-backup created by (don't use the timestamp option here:  this isn't necessary with Dropbox as it keeps multiple versions).

This is a good backup solution if you have an internet connection. To be extra safe it's good to consider doing a local backup as well, using backup software.

See forum thread Backup - Backing up IQbase to discuss Dropbox backup

4) Encryption:

You can also encrypt and password protect your database:

Encryption Security is based on 2 points (required since IQ used JET as storage and any ODBC app can open JET files) 

1) Encryption: This prevents access to information by bypassing the JET ODBC driver (notepad, hex viewer, etc) by encrypting the content. JET

will encrypt/decrypt on the fly, so normal users don't see a difference (except for 15% reduction of speed). When you entcrypt your file it creates

a new file FileName.Entcrypt.SNDB. After encrypting (and closing down IQ/InfoQube) you should:

- Backup your original file somewhere safe, then:

- Rename your encrypted file to the old name (recommended)

2) Password: This limits file access to users that know the password. All apps requesting access to the information (e.g. IQ but also Word, Excel,

etc) will prompt for the password

- You can use 1 or 2, but only the combination of the two provides full protection. If using 1+2, then remember to encrypt before setting

the password

Both settings are available under Menu: Tools >Database Management>

MHT content is stored in a folder in the same location as the IQ file - it can be encrypted using Windows folder encryption (which is totally

distinct from IQ encryption) - though this hasn't been tested.

See also 3.10.20.60 This file>Data storage

Index terms: Backup, encryption

node 987
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Inserting and Viewing Images

Images can be inserted in many UIs and in a number of different ways:

�. In Grids, by dragging an image / picture from File Explorer or from the HTML pane (folder mode)

�. In Grids and the HTML pane with Copy / Paste: an image file will be created and stored in the .Files folder (ItemIDXXXX.jpg)

Viewing Images

�. In grids: Grid > View Pictures

�. View > Image Viewer

�. Select an item to show the linked image file in the viewer (all UIs)

https://infoqubeim.com/1845
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�. When the HTML pane is showing a folder: select any file in the file list
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5. Comparison with EccoPro

Feature comparison chart: Ecco, Ecco + Ext and InfoQube

WARNING: This table is severely outdated !!

Item Category Ecco Ecco+Ext Ecco Notes InfoQube Notes

1 Built-in Pivot table for data analysis Analysis - -  Yes

2
Charts: full-features, configuration saved in the

database
Analysis - -  Yes  In 0.9.16

3 Group-by: similar to Outlook's group by bar Analysis - -  Yes

4
Has full calendar functions... including an actual

weekly/monthly calendar
Calendar Yes Yes -

5 4 field data types Data Yes Yes  Yes

6
Advanced notepad source (Folder1 AND

Folder2="this text"
Data Yes -

But supports multiple

folders in a view
 Yes

7 Auto-backup, backup on file close Data Yes Yes  Yes   Uses separate backup file names

8 Database management (compact, repair) Data Yes Yes  Yes

9 Default field values : user settable Data - -  Yes   Can even be an equation

10 Items can have multiple parents Data - -  Yes

11 Manual backup Data  - -

Saves creates a

backup. However it

overwrites previous

backups.

 Yes

  Uses separate backup file names

from auto-backup, to ensure no

overwrite

12 Private items Data Yes Yes  -

13 Unlimited number of items Data - - 65000  Yes

14 Advanced phone number recognition Dialer - -  Yes  Uses regexp

15 Finds phone numbers in parents Dialer - -  Yes

 Searches the parents tree and

displays a complete list of all found

phone numbers, number can even be

in the item text

16 Phone dialer Dialer Yes Yes  Yes
 Uses TAPI for quick change in

configuration (work, home, travel)

17 Phone dialer with logger Dialer Yes Yes  -  Planned for 0.9.27

18 POP E-mail checker E-Mail - -  Yes

19  Column equations (hierarchy equations) Equations - Yes

Depends on Ecco's

auto-assign

mechanism

 Yes  Built-in

20 Database calculated fields (uses no storage space) Equations - -  Yes

 21 Row equations Equations - Yes

Depends on Ecco's

auto-assign

mechanism

 Yes  Built-in

 22 Scripting Equations - Yes
LUA and many other

languages
 Yes  VBScript. Eventually will use LUA also

 23
Auto-form: dynamically shows current grid

columns
Forms - -  Yes

 24 Forms with default values Forms Yes Yes  Yes

 25
Forms with default values: default values can be

equations
Forms - -  Yes

 26 Forms: Add item by form Forms Yes Yes  Yes

 27 Forms: Add sub-items by form Forms - -  Yes

 28 Forms: Apply form to items Forms Yes Yes  Yes

 29 GTD: Specialized in-box form with system-wide

shortcut key CTRL-SHIFT-N (for item, field values

Forms - -  YesYes  To implement GTD methodology

https://infoqubeim.com/drupal5/index.php/pierre


and HTML content)

 30
Can use MSWord as external editor. Retains all

Word advanced formatting
HTML - -  Yes

 31 HTML Editor/browser built-in HTML - -  Yes

 32
Html editor: advanced with fonts, bullets, links,

tables, embedded tables
HTML - -  Yes

 33
HTML Editor: can open local files (HTM, MHT, PDF)

and web pages
HTML - -  Yes

 34 HTML Editor: support drag-drop from web pages HTML - -  Yes
 Collect web clippings. Switch to

browse mode to have a live web page

 35 Built in Off-Line multi-file syncing I/O Yes Yes  -  planned for 0.9.24

 36 Cut and Paste multi-items as standard outline/text I/O - Yes  Yes

 37 DDE interface for add-on tools I/O Yes Yes  -    API and ActiveX planned

 38 Direct Palm Sync I/O Yes Yes  -
  Planned through Outlook or other

Web Calendars

 39 Export to Excel (1 click) I/O - -  Yes

 40 Export to HTML I/O - -  Yes

 41
Export to HTML with advanced options and

expandable outline
I/O - -  Yes

 42 Import Ecco files I/O - -  Yes

 43
Mail-merge, HTML based, multi-column output,

template based
I/O - -  Yes

 44 Multi-column selection, copy/paste I/O - Yes

All or none, cannot

select just some

columns

 Yes

 45 Office application can read live database data I/O - -  Yes
  Each view is accessible to Office

applications

 46 Open database format I/O - -  Yes
 Uses JET, could use other DB engines

(SQL Server planned for 0.9.24)

 47
Sync with external database, local or web (SQL

Server, MySQL)
I/O - -  Yes

 48 Users without the software can view data  I/O - -  Yes

  Excel or other ODBC spreadsheet

can view the data you choose to

make public

 49
In-cell hyperlinks to another item or to a group of

items
Links - -  Yes

 50 In-cell hyperlinks to documents, web pages Links - -  Yes

 51 Links to documents and web pages Links Yes Yes  Yes

 52 Wiki-type hyperlinks Links  - -  Yes

 53 Multi-user Network Yes Yes  Yes

 54
Multi-user with centralized storage and no local

data
Network - -  Yes

  Ensures security of the information,

since it stays in the office, not

available off-line

 55
Auto-assignment to folders with LUA scripts and

REGEX expressions.
Scripting Yes Yes  -  Planned

 56 User-defined code and functions Scripting - Yes LUA  Yes  VBScript

 57 User-defined code can be used in forms and field Scripting - -  Yes

 58 Advanced find Search Yes Yes  Yes

 59
Advanced find with logical operators (AND, OR,

NOT, NULL, etc)
Search - -  Yes

 60 Alpha-numeric filter toolbar Search Yes Yes in Phonebook only  Yes
 For all grids. Can choose which fields

are used

 61 Auto-search (incremental search) Search - -  Yes
 Just start typing to find contact

items

 62 Filter by date using the DateFilter toolbar Search - -

Calendar can be used

for this, in a more

limited way

 Yes  Can be used in all grids

 63
Journal feature: view items by date (created,

modified) using the DateFilter toolbar
Search - -  Yes

 64
Live-search: search whole database with live

dynamic results grid
Search - -  Yes



 65 Search result can be displayed in any notepad, not

just the search notepad

Search - -  Yes

 66 Database encrypt, set password Security Yes Yes Cannot encrypt  Yes

 67 1-click column sort Sorting - -  Yes  Click on column header

 68 Item sort applied to new items Sorting - -
Must manually perform

sort
 Yes

 69
Multi-key sort, sort columns do not need to be

displayed in notepad
Sorting - -  Yes

 70 Notepad sort bar for easy multi-column sorting Sorting - -  Yes

 71 Sub-item sorting Sorting - Yes  Yes

 72
Dependancies: define relationships between tasks

and only relevant ones show up
Tasks - Yes No visual display  Yes

  Gantt charts show dependancies,

auto-generation by drag-drop

 73 Gantt charts Tasks - - Limited display  Yes

 74
Mark as done actions: what happens when an item

is marked DONE
Tasks - Yes Through auto-assign  Yes   Integrated

 75 Add/remove parents Tree -  Yes

 76 Add-on Tools via a "Launch Tool" menu UI Yes Yes  -  Planned

 77 Advanced sub-item display/sort criteria UI - -  Yes

  To limit sub-items to those related

to the current notepad, to show

relational data

 78 Alternate row colors, to highlight items UI - -  Yes   User settable colors

 79 Built in Shooter / Right Click Send-To UI Yes Yes  -

 80 Can control item text color via Folder Contents UI - Yes  Yes

 81 Combined views (many notepads in a view) UI Yes Yes  -   Planned

 82
Detailed item information (ID, date created,

modified, by who, etc)
UI - - ID available with Ext  Yes

 83 Dockable panes UI - -  Yes

 84 Drag & drop to move items UI Yes Yes  Yes

  SN will maintain tree structure after

a drag-drop. Hence may require to

move items left-right

 85 Find and replace UI Yes Yes  -

  Planned, but currently can use the

properties pane to make changes to

multiple items

 86 Floating/dockable toolbars UI - -  Yes

 87
Image viewer. Multiple instances. Will cycle

through instances. Great to view photos
UI - -  Yes

 88 Input masks UI - -  Yes

 89 Insert OLE objects in outline UI Yes Yes  -   Not recommended anyway

 90 Insert pictures in outline UI Yes Yes  Yes

 91
Insert pictures in outline: Picture can overlap

column area
UI - -  Yes

 92 Integrated Properties pane UI - -  Yes

 93 Item back color UI - -  Yes

  Can be set by an equation to

automatically highlight when an item

is due, for example

 94 Item fonts UI Yes Yes  Yes

 95
Item fonts: Can select that font applies to which

column
UI - -  Yes

 96 Item tagging UI - -  Yes

 Operations can be performed on

tagged items, instead of selected

items. Tagged items can be from

different notepads

 97 Items column can be positioned anywhere UI - -
Item column is always

the first column
 Yes

 98 Large editing window for text columns UI - - With EditNote add-on  Yes

 99 Locked columns, user settable UI - -
Items column is always

locked, other cannot
 Yes

 100 Mark item as done UI Yes Yes  Yes

 101 Move items up/down/left/right  UI Yes Yes  Yes

 102 Multi-language UI UI - -  Yes



 103 Multi-level column headers UI - -  Yes

 104 Named Filters UI Yes Yes  --  Planned for 0.9.23.4

 105
Navigation buttons (previous, next, next page, last,

etc)
UI - -  Yes

 106 Non-modal dialog boxes UI - -  Yes

 107 Notepad shortcut ALT+# UI Yes Yes  Yes

 108 Outline fonts UI Yes Yes  -  Default grid font can be set

 109 Outline number shows up right next to the text UI Yes Yes  -
  HTML Exporting can have outline

number next to the text

 110 Pop-up editor UI - - Add-on can do this  Yes

 111 Pop-up lists UI Yes Yes  Yes

 112
Pop-up lists: autogenerated, limit to list, coming

from an external database, multi-column
UI - -  Yes

 113 Quick column filters UI - -  Yes  Click on column arrow to filter items

 114  Show/hide context parents UI - -  Yes

 115 Show/hide hierarchy UI - -  Yes

 If item and sub-items meet the filter,

should they be displayed in hierarchy

or as TLI

 116 Split and join items UI Yes Yes  Yes

 117 Text column word-wrap UI - -  Yes
 Word-wrap in all text columns, not

just the item

 118
Toggle text case with 4 states (the house>The

house>The House>THE HOUSE)
UI - -  Yes

 119 Tree can be shown on any column UI - -  Yes

 120 Visual themes, msstyles support UI - -  Yes
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Embedded Formatting

REMINDER

InfoQube supports Rich-text formatting for grids, items and the HTML editing pane.

Editing in the HTML pane is similar to word-processors. See 4. Document Pane.

In grids, formatting is structured as a hierarchy. In increasing order of precedence,

these are:

�. Overall default font: set in Tools>Options>General>View: Grid font and Grid

font size settings

�. Grid specific font: set in Grid>Properties>Options: Default Font

�. Item format: Applies to the whole item or to specific columns. See Item

Formatting.

�. Outline style. See 3. Outline Styles

�. Embedded format: See Embedded Formatting

�. Conditional format. See Conditional Formatting

Embedded format will be shown throughout InfoQube, not just in grids

Editors are:

�. Plain text editor (Grids, Properties pane)

�. WYSIWYG editor (Grids)

�. Event details dialog (Calendar events)

�. New Item / Clipper dialog

�. Pop-up editor  (All view types)

1- Plain text editor

https://infoqubeim.com/drupal5/index.php/pierre
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Shows formatting codes in plain text

Use the formatting toolbar to enter codes. 

Enter codes manually. See below for details

2- WYSIWYG Editor

In a grid, enable the WYSIWYG editor by right-click on any text column header and check the option.

Supports spell checking

Use the formatting toolbar

The edit window automatically grow in height as you enter text. 

It is also possible to use Alt + down/up arrows to increase/reduce the editor height

3- Event Details dialog

Items shown in the Calendar (i.e. events) can use the Event Details dialog. The event text textbox is WYSIWYG (similar to the Pop-up editor). See 2. IQ

Calendar for details.

4- New Item / Clipper dialog

Items added through Edit > New Item or using a clipper show in the Add Item dialog. The item text textbox is WYSIWYG (similar to the Pop-up editor).

See 2. New Item dialog for details.

5- Pop-up editor

The pop-up editor can be used throughout InfoQube. This includes, grids, Properties pane, Calendar, Map view, Surface, etc. See 3. Popup Editor for details.

Using the formatting toolbar

While in edit mode, the formatting toolbar shows the following commands:

Font dialog

Bold, italic, underline, strikeout

Highlight text (bright yellow back color)

Superscript / subscript

Text Forecolor

Text Backcolor

Hyperlink

Insert Icon

Notes:

The commands are enabled for both the plain text editor and the WYSIWYG editor.

Like all toolbars, this toolbar can be customized. See Customizing Menus and Toolbars

https://infoqubeim.com/1215
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Using formatting codes

In the plain text editor, formatting can be entered manually:

<font face;size> text </font> displays portions of text with a different font and/or different size. For instance, the <font Tahoma;12>bit</font> draws

the bit text using the Tahoma font, on size 12 pt. If the name of the font is missing, and instead size is present, the current font is used with a different

size. For instance, <font ;12>bit</font> displays the bit text using the current font, but with a different size.

<b> bold </b> bolds a part of the caption.

<u> underline </u> specifies that the portion should appear as underlined.

<i> italic </i> specifies that the portion should appear as italic.

<s>strikeout </s> specifies that the portion should appear as strikeout.

<fgcolor=FF0000> fgcolor </fgcolor> changes the foreground color for a portion.

<bgcolor=FF0000> bgcolor </bgcolor> changes the background color for a portion.

<img>IconFileNameWithoutExtension</img> inserts an icon inside the cell's caption.

<a xyz>Hyperlink</a> creates a hyperlink to a web page or to InfoQube items. Details here: 4. Links

<sup>superscript</sup> specifies superscripts

<sub>subscript</sub> specifies subscripts 
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Item Formatting

REMINDER

InfoQube supports Rich-text formatting for grids, items and the HTML editing pane.

Editing in the HTML pane is similar to word-processors. See 4. Document Pane.

In grids, formatting is structured as a hierarchy. In increasing order of precedence,

these are:

�. Overall default font: set in Tools>Options>General>View: Grid font and Grid

font size settings

�. Grid specific font: set in Grid>Properties>Options: Default Font

�. Item format: Applies to the whole item or to specific columns. See Item

Formatting.

�. Outline style. See 3. Outline Styles

�. Embedded format: See Embedded Formatting

�. Conditional format. See Conditional Formatting

This page describes Item formatting, which has priority over grid specific font and overall default font. 

Keep in mind that ouline styles, In-cell formatting and conditional formatting have priority over item formatting. 

Item formatting consists of :

�. Font (face, size, bold, etc)

�. Text color

�. Back color.

These display attributes are saved in 3 fields defined in Tools > Options > This file > General. By default the fields are respectively:

�. ItemFont

�. ItemForeColor

�. ItemColor

To perform item formatting, first ensure that you are not editing. If currently editing, format will be applied to selected text (see in-cell formatting Embedded

Formatting)

You can use the formatting toolbar buttons :   

It contains the following icons:

Font dialog

Shortcuts for bold, italic, underline, strikethrough

Highlight text (bright yellow back color)
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Grow font, shrink font

Item Text color

Item Back color

Item Hyperlink

or edit the fields directly (in a grid or the properties pane)

By default it is applied to the entire row but you can choose to just have certain columns get the item formatting using Grid > Properties > Options > "Item

Font applies to field

1. Setting an Item's Backcolor (row highlighting)

You can highlight an item with any color via it's right-click menu in the grid (Item Color).

First we see a list of  named colors, then more colors & then an option to custom choose/create (even) more colors.

Named colors are defined in Tools > Options > This file > General > Named colors

2. Using the Item Forecolor and Backcolor Fields

Setting an Item's color using the context menu actually just sets its ItemBackColor field. You can change that field and its color will update automatically

next time you close/open the grid. You can also change its fore color using the field ItemForeColor. Both of these values are set using either VB Hex Color

Codes or Named Colors (see below). You can also change an Item's font by using its ItemFont field.

And since they are normal fields, you can update them using equations as well (see Field Management Dialog - Equations).

3. Changing the Item forecolor and backcolor fields

It is possible to have multiple item fore/backcolors defined for an item (e.g. one for printing, one for screen). By default colors are defined in ItemForeColor

and ItemBackColor fields. But you can change this at the database level (perhaps just while you print). To do so:

�. Create a new text field: AlternateItemColor

�. In Tools>>Options>>This Database>>General>>Item backcolor field: replace the default item color field (ItemColor) with the field AlternateItemColor

�. Press F5 to refresh the grid. You can also open a new instance of the grid (right-click on the tab or shift+click on the grid name)

In the this example, the User Manual item as ItemColor=Yellow and AlternateItemColor=Red. Using Tools>>Options, one can toggle between the two colors.

https://infoqubeim.com/128


4. Color Codes and Names

4.1 Color Codes

InfoQube uses VB hex numbers (e.g. the Red above is &HAAAAFF ) for its color codes. These are in BGR format while the rest of the web uses RGB. To add a

new color you have to find it's VB hex number, one good tool for this is Bullseye Color Picker. You can use other sites and tools also, but be sure to swap the

B and R if required.

4.2 Named Colors

Anywhere you can use a VB Hex Code you can also use a name if IQ knows it. These are called Named Colors. You can change or add new Named Colors in

the database options at  Tools > Options | This file > General > Named Colors  (see 3.10.20.70 This file>General).

 As you can see there is a list of colors there

Red|&HAAAAFF|Orange|&H99CCFF|Yellow|&HAAFFFF|Blue|&HFFFFAA|   etc.

First comes the color name which shows via item context menu (and can be used in equations / auto-assign rules).

Then a separator '|'

The comes the code for the color

Then another separator before the name of the next color

It's important to remember that you need to restart to see any Named Color changes and that Named Colors only apply to the current file only.

For instructions on adding the standard list of X11 colors see Web Named Colors (node 2360).
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Locked Items

- Locked items cannot be deleted until unlocked.

 Locked items are set in the properties pane. To find all the items which have locked checked, select the itemlocked field in the grid source.

Double-click "Locked" under Item info in the Properties panel will display it in the search grid.

Q. Locked items can not be deleted. However, they can still be edited (e.g. all text deleted). Is this on purpose? In comparison EccoExt does not allow deletion

or edits. What about subitems of a locked item? They can still be deleted. Is this on purpose (we need to lock them separately)?

A. Both of these are by design. Usage will tell if it needs to be changed. The rationale is:

http://download.cnet.com/Bullseye-Color-Picker/3000-2383_4-10412297.html
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You want to prevent from accidentally deleting items. If you are doing editing, you know what you are doing. Needing to unlock to edit, will likely make users

forget to re-lock, defeating the purpose.

Sub-items are full-fledged items in InfoQube (unlike in Ecco). They may also have many parents.

They may be displayed without their parents. So there is no reason why it should automatically be locked. Simply select all the items to lock, and check the

lock checkbox to lock them automatically.

Deleting an unlocked parent will not delete a locked sub.  



Pierre_Admin 2008/11/30 22:44

https://infoqubeim.com/drupal5/index.php/pierre


11 views

6. Example : Generating Invoices

6. Example : Generating Invoices

Generating Invoices

Case: You need to generate invoices for your consulting activities (could as well be products with only minor differences)

Solution: Use InfoQube and the built-in Template Merge feature

In this tutorial, you'll lean how to:

�. Use a grid and the Doc pane to enter the invoice data

�. Create a template file to merge the invoice data

�. Use the template file to generate the print-ready / email-ready personalized invoice

Step 1: Entering Data

The sample IQBase has a built-in grid to do this. It is quite easy to recreate if it was deleted or a blank IQBase was used:

Alternatively, the Invoice form can be used to enter the details for each invoice:

Enter an ID, Date, worked start and end dates, the nb of hours worked and HrsRate.

The description of the work done is entered in the Doc pane to ease formatting (bold, bullets, etc):

The rest is automatically calculated by the field equations (sub total, taxes and total):

SubTotal = [Duration] * [HrsRate]

Taxes = 0.08 * [SubTotal]

InvoiceTotal =[SubTotal] + [Taxes]



As seen in 7. Example : Time Tracking, the pivot table could be used to compute totals per client or per year.

Step 2: Creating the Template File

The template file can be created using text editors or simple HTML editors.

More complex editors, such as Microsoft Word tend to add styles, classes and a lot of extra HTML content which is not compatible with the mail merge

engine. If you use MS Word, ensure you save as "Web page, filtered"

One suitable HTML editor is IQ's built-in Doc pane of course !

�. Create a new item, name it Invoice template

�. In the Doc pane (or Item Editor window), set the document type to HTML file (Menu > File > New > New HTML File)

�. Enter the invoice content. Copy / Paste content from other apps if needed

�. Enter merge codes as needed, enclosed in { }. Details here: HTML Export Merge Fields and Codes

�. Enter merge field as needed, enclosed in { }. To refer to the parent item field value, precede the field with "Parent.", i.e. {Parent.Item} refers to the parent

item text

�. Save

�. The standard IQ installation package includes a sample template file named InvoiceEx.htm (AppFiles folder)

Step 3: Generating the Invoice

To generate invoices:

�. Select one or more "invoice" items in the Invoices grid

�. File > Print Preview

�. Select 5- Merge the selected items with a template file

�. Select the Template file

�. Click Save and Preview

Alternatively, you can email-merge the invoice using the same dialog.
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7. Example : Time Tracking

Case: You are a consultant and have a handful of customers, and you get paid by the hour. Your customers also may want detailed report of the work done

Solution: Use InfoQube to enter the work done, calculate total hours and provide detailed report.

In this grid:

the duration is calculated based on start-end times. If EndTime covers more than a day, it assumes 8 hours per day (this is a user setting, see item 1.2

which lasts 17 hours over 3 days). This is done using a user-defined equation (Duration = WorkTime( StartDate , EndDate , 8) - ( NonBillable ))

https://infoqubeim.com/231
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Since task items are created under a parent (Project Lear or Somiro), it will inherit the Project field automatically (Field Management > Inheritance is

checked).

NonBillable hours (i.e. lunch) are automatically substracted.

This detail can be exported as an HTML page with the columns you select. You can include that page as an attatchement to the actual bill. Example

available here.

You could also add work notes as sub-items under each Task entry (or in the HTML Editing Pane)

If you want to hide already billed hours from the grid, activate the filter.

Actual bill to be printed/PDF/e-mailed could also be generated by InfoQube (will be the subject of another post here)

Worked information can be entered in this grid or in a user-defined form.

Putting the task as a sub-item of the project allows: expand/collapse, automatic project field assignment, and gives you great viewing flexibility:

View work done by project as show above (grouped together) (Grid > Context parents checked)

View work done chronologically (context parents unchecked) to see your whole week/month

The pivot table on the lower part of the screenshot gives the totals hours, per project and per month that need to be billed. Change BillingNo in the pivot

table to see specific bills if desired or to see total work done last year, etc.

So when customers call, you can quickly tell them how many hours have been done and left on the budget!

BTW, this is not some theoretical billing solution, I've actually been using this for the last 2 years for my consulting activities, so it is a well tested solution!

The InfoQube default template (File>New) has been updated to include this sample.

Next step is 6. Example : Generating Invoices
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8. Example-Basketball Stats

Case: You have informal basketball games at lunch and want to keep track of the wins and losses of each player. You want to be able to quickly see which

player(s) has better stats.

Solution: Use InfoQube and have each player enter their score after lunch.

In this example, we'll learn how to:

Create fields to store players and results, including pop-up text list, dates and number fields. Default field values, inheritance and equations will be used

Create a grid to add/view the game results

Create a pivot table to summarize the results and determine players with the best won ratios per month

Set it up to allow multi-user access

There can many ways to go about this, all with advantages and disadvantages. We'll describe one method which shows many of the built-in features of

InfoQube.

The first step is to create some fields to store the information:

�. View > Field management.

�. Create a field PlayerName to hold the name of each player. Check Auto-list. Click Save

�. Create a field NbWon. Set the datatype as number. You may set the alignment to right. Click Save

�. Create a field NbLost. Set the datatype as number. You may set the alignment to right. Click Save

�. Create a field GameDiff.

�. Set the datatype as number.

�. Set the equation: = nbWon - nbLost.

�. Check Read Only.

�. You may set the alignment to right. Click Save

�. Create a field GameDate.

�. Set the datatype to Date.

�. Set the default value = int(now). This will default the game date to today

�. Set Alignment to centered

�. Check Value-->sub-items. This will allow us to use the pivot table to calculate the stats, since the player's score (i.e. the sub-item) will inherit the

date.

Now that we have created the fields to store the information, we'll create a grid to show/enter the data.

�. Do View > Grids > New Grid. Set the grid name to GameDate (select from the list). Click OK

http://www.public.infoqubeim.com/download/infoqube/Solutions/Billing/BillingEx.htm
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A new grid is created. The last thing we need to do is to display some columns.

�. Do Grid > Displayed columns. Check GameDate, GameDiff, NbWon, NbLost, PlayerName. Click OK

�. The Item column is not needed in this application, so right-click on the column heading > Hide Column

�. We'll set the tree column to the GameDate: right-click on the GameDate column header > Set Tree Column

�. Finally, you need to do Grid > Hierarchy to tell the grid to enforce parent-child display

�. If you want to rename the grid, to BasketBall Stats for example, do Grid > Properties and change the name

At this stage you should see something like this:

You are now ready to start entering results. For 2 days of data, it might look like this:

The GameDate is entered only one (for the game) and is automatically transfered to each player's score (this is optional and only there to allow us to

calculate stats over a given period of time. This may not be a requirement.).

Also, the PlayerName is entered once. Subsequent days, the player can pick from a drop-down list.

The data is entered by only one person or by many. InfoQube is based on a multi-user database, so many users can be working on the same database, at

the same time.

To share the database, simply put the InfoQube file (*.SNDB) on the LAN. That's it!

The final step is to create the pivot table to calculate the statistics. This requires MS-Office 2000 and up installed

�. Do Grid > Pivot Table. All steps now use the toolbar which is just above the pivot table

�. Click on the Fields button.

�. Drag the PlayerName to the "Drop Row Fields Here" area on the pivot

�. Drag the NbWon to the "Drop Totals or Detail Fields Here" area on the pivot

�. Repeat for the NbLost, and GameDiff field

�. For each of these, right-click on the heading and set AutoCalc to Sum

�. Click on the Sum of NbWon heading to select it and the Hide Details button on the toolbar

�. Click on the drop-down arrow to the right of PlayerName and uncheck (blank)

At this stage you should have this:

This shows that Bob and Henry have the best score, followed Mary. As for Joe, well, he's got some catching up to do...

The Pivot table properties window can be used to customize the pivot table. The final BasketBall stat application could look like this:



The default template has been updated to include this sample.

Using an alternative application structure, the following could also be done in InfoQube

:

This organization is more compact, does not require the use of the pivot table to calculate the best player. However it requires a field per player and some

user-defined code to determine the best players.
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9. Example-Finances

Case: You want to better manage your personal finances

Solution: Use InfoQube to enter revenues and spendings. Use InfoQube or Excel to calculate balances and perform analysis

To manage your personal finances with InfoQube, 2 approaches are possible: Full InfoQube or hybrid InfoQube + Excel:

Either way :

Create a number field: Amount. +ve numbers would be Credit and -ve numbers would be debit. (or invert it as you prefer)

Create a number field Actual$ with equation = ZN(- [Amount] * [Paid]). (Paid=true is equal to -1). So the Actual$ would be the amount paid/received.

Organize it under parent heading (Account 1, Invoices, Rent, Cash, etc ) if you wish.

You can use the DateFilter toolbar to easily filter on a specific date range (change the source to amount for this)

.

1- Full InfoQube:

Set-up Account 1 as parent item. You can have grouping items too if you wish (Rent, Revenues, etc)

I recommend a category field (Revenues, Car, Home, Food, etc) since this will allow the pivot table to group spendings by category. You can set Value --

> sub-items for this field to have the category automatically filled

Set the Actual$ field Parent = SUM(Children)

Create a number field: Initial$ with Null=0 Unchecked. This will ensure that the balance is calculated for the Account item only. (An alternative would be

to simply add a sub-item to your account with the starting balance)

Create a number field Balance with equation = Initial$ + Actual$

For the Paid field, set auto-assign rule: A:Done=int(now) | E:Done= . This will today's date in the done field when you check Paid (Optional)

https://infoqubeim.com/drupal5/index.php/pierre


Create a form with all relevant fields: Item, FinCategory, Amount, Paid, Date, Actual$, Done, Initial$, Balance, Notes

.

2- Hybrid InfoQube - Excel:

Set the source of your grid to Amount. This will display all items that have an amount. Since InfoQube can only display the immediate parent (this will

be improved), Either display the ItemParent field or keep the outline to just 2 levels: Account -> transactions

Create an ODBC Source for your InfoQube file. Use the MS Access database driver (Help available if needed)

In a blank Excel file, Cell B10 (approx), Do Data > External Data > New Database Query

Select the ODBC connection you just created.

You'll be presented with a list of queries, an InfoQube grid is actually a query. So select your current grid name from the list. Expand the + and copy all

fields to the right pane (to select those fields)

Hit OK until you get back to Excel

You'll then see your InfoQube grid data in Excel. This is not a copy but a live link.

Above your data block in Excel, you can enter equations and initial values to compute your balance. To the right of the data, you can also enter

equations to calculate running totals (i.e. daily balance). Make sure that your grid is set to sort on Date or your balance will not be calculated correctly

To refresh your data in Excel, right-click > Refresh Data

.

Both approches have +'s and -'s.

Pierre_Admin 2008/12/09 18:57

25 views

Auto item text based on content
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Auto item text based on content

Often, one wants the item text to reflect the first line of a document. MSWord does that to determine the proposed file name. InfoQube does the same:

Iff the item text is empty (and only if), then on the first time that the user hits the enter key in the Doc Pane and the Add new item form, the item text will be

set to the first line of text.

1. Using the enter key in the Add new item form:

https://infoqubeim.com/drupal5/index.php/pierre


Some text has been added to the Add New Item dialogue. Note the "Item Text" is empty.  Now hit the ENTER key:

The first line fills the "Item Text" area:

1. Using the enter key in the Doc pane:
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Changing field values in bulk

The Properties pane can be used to modify / add field values of many items in one step (i.e. in bulk)

To do so:

�. In any view (grid, Calendar, Surface, etc), select 1 or more items

�. Enter the value in the Properties pane. A Taskbar popup is shown confirming the operation. Click Edit > Undo (Ctrl + Z) to undo

Example:

You have created a grid called 'ProjectSomiro' .  All the items in it (at top level) have the field 'ProjectSomiro' set to true. As the number of project is

increasing, you realize that you prefer to use a single text field, instead of a multitude of yes/no fields. To perform the switch, you can:

�. Double-click on the field ProjectSomiro

�. Ensure the display is set Source Items (Flat list) and that context parents are off

�. Refresh

�. You should now see all items that have ProjectSomiro checked (and nothing else)

�. Select all items

�. In the properties pane, Enter "Somiro" in the field Project

�. Check that all was done

�. Before deleting your ProjectSomiro field, open your grids and modify them if needed to reflect the field change

The Properties pane supports equations:

Number Fields: Type + - / * operators to trigger calculation mode (i.e. +13.2 will add 13.2 to the selected field of all selected items)

Date Fields: Type + - operators to add days or hours to a date

Text Fields: Start the text with = and enter an expression. 

For example for the Notes field, =Left([Item],20) will extract the 20 first characters of the item field and put it in the Notes field (for all selected items)

Whether parsing is done automatically or manually is set, per field, in the Field Properties > General. To trigger manual parsing, enter the equation and

right click > Parse Equation
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Creating a grid of grids
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Grids are always shown a flat list. To arrange these in a hierarchy, create a hierarchy of items, each being a hyperlink to a grid

To do so:

�. Open the Manage Grids dialog

�. Select one or more grid

�. Right-click and select Copy

�. In a grid (perhaps an empty one), do Edit > Paste Special > IQ View

�. An item will be created for each grid

�. Create grouping items and move "grid" items under appropriate group

�. Hold the Ctrl key when moving an item to place the item under more than one group

�. Add formatting (font size, color, back color) to help locate each grid

�. The grid is then detached and docked to the side of the main IQ UI

��. Turn Auto-Search on to locate grid by simply typing a few characters
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Drag-and-drop and other common UI operations

See Item Copy & Paste - Selection - Drag & Drop for more info about Copy / Paste / Selection / Drag and Drop.

All kinds of drag-and-drop operations are possible in IQ.

Here is a table comparing IQ with Windows Explorer

Mouse Operations : comparisons with Windows Explorer

ACTIONS
Mouse

operations

Explorer vs

InfoQube

summary

Detailed explanations

Move items

Click +
drag &
drop

Same

To move items you must click in an

editable area of any selected item and

drag - any selected items will move

with the item you drag.

You can also move items in IQ by

clicking on a number in the # column

or by clicking on an item bullet and

dragging. This is similar to MS Word in

"Outline mode"

Select multiple

items

Click +

drag

Same For "multiple select" using click & drag

in Explorer or in IQ, just click anywhere

in a non editable areas (between text-

number-date fields, etc.) and drag the

mouse to make a selection box.

https://infoqubeim.com/drupal5/index.php/pierre
https://infoqubeim.com/1155


Note that in Explorer --Windows XP--

that means that you can click anywhere

except the filename column since only

the file name column is editable.

         [as above]
Shift +

Click
Same

To multiple select contiguous items

using shift + click in explorer or in IQ,

just click anywhere in an editable area

(on text/number/date), hold shift, and

click elsewhere. All intervening items

will be selected.

Select multiple

non-contiguous

items

Ctrl + Click Similar

In IQ:

keeping the Control key pressed - click

on the number in the # column of each

item you want to select.

In Explorer you have to click on the file

name column, keeping Control key

pressed.

IQ : Show items

in different

contexts

(create multiple

parent links,

etc.)

Explorer : Copy

items

Ctrl + Click

+ Drag &

Drop

Different

CTRL + click + drag & drop is used to

show items in a different context. This
is not the same as copying. The item(s)

shown in different grids/contexts is still

the same item.

(Full copying - to produce a replica

item but with a different ID number - is

managed with the item context menu

or the usual keyboard shortcuts.)

Create

shortcuts

(hyperlinks)

Alt + Click

+ Drag &

Drop

In IQ:- Not
yet
implemented
using mouse
actions

IQ does do this, but (currently) only

using the item context menu, not with

mouse actions.

Some of the most frequent issues while dragging and dropping an item are:

Automatic scrolling up/down in the grid, following mouse movement

Common problem: IQ does not scroll when mouse cursor hovers at bottom or on the scroll bar, or at the top of the grid.

It actually scrolls but you need to find the right spot where it starts scrolling: just a bit over the horizontal scrollbar, just a bit below the grids columns/fields

title bar.

Automatic expansion of the hierarchy where the item must be dropped

Common problem: If an item's hierarchy is collapsed, IQ doesn't 'open' the item when mouse cursor hovers over the collapsed item

The item's hierarchy will actually open, but you have to hover your mouse over the [+] or [-] or whatever is the expand/collapse symbol in your case.

Automatic creation of sub-item upon dragging and dropping an item over an other one

Common problem:  dragging-and-dropping an item over another item creates a sibling, not a sub-item.

In order to create a sub-item one needs to drag the item (by clicking on text and dragging) & hover above the destination item, until you see this arrow (a

line also shows under the item)



it will automatically create a sub-item.

One can also drag & drop as a child (sub-item) of a parent item by hovering the mouse over the "expand/collapse" symbol and then continue dragging the

item exactly where you want it among the sub-items. A black line will appear, indicating where the item will be dropped.

Pierre_Admin 2012/12/21 10:31

18 views

Forums: Great Threads

Forums: Great Threads

The following list link to forum threads that were particularly instructive:
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How to bypass the automatic opening of the previous file

How to bypass the automatic opening of the previous file

InfoQube has an option to open the last file on startup (Tools > Options > Program Settings > Modes)

While this is sometimes useful, at times it may not be desired. There are 2 ways to bypass this:

�. Start the program with a /file command like argument. Typically, a batch file is used for this. Details to come

�. Press and hold the Shift key while starting the program. Simple and effective
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IQ User Manual in CHM Format

IQ User Manual in CHM Format

Jibz came up with an automated way to create a quite useable  (CHM) HTML Help version of the onine manual.

He periodically updates runs his (perl) script, and posts the file to his dropbox account, and announces new versions in HTML Help (CHM) version of User

Manual - Updated May 16th 2016

 Discussion is in HTML Help version of the manual?

4/3/2011 Jibz' exact steps, in order for others to be able to create the chm manual:

Make sure you have Perl and the HTML Help Workshop installed.

Perl:

http://www.activestate.com/activeperl/downloads

Microsoft HTML Help Workshop

Create a folder and put the dump2chm perl script into it.

Open the printer friendly version of the top level page of the IQ User manual in Internet Explorer,

https://infoqubeim.com/drupal5/index.php?q=book/export/html/2043

Wait till the entire page has loaded with all graphics.

https://infoqubeim.com/drupal5/index.php/pierre
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Choose File->Save As... and select "Webpage, complete", and "Unicode (UTF-8)", and save to the folder

you put the script in.

Open a command prompt, and run the script with the name of the saved html page as argument

dump2chm InfoQube.htm 

This splits the htm file into a file for each node of the manual, and generates the index files required to

compile the chm.

Open index.hhc in your favorite text editor and move the line that links to node2043.html down one line and

change node2043.html to index.html and value="1" to value="11", i.e. in the current version, change

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN"> 
<HTML><HEAD></HEAD><BODY> 
<OBJECT type="text/site properties"> 
<param name="FrameName" value="right"> 
</OBJECT> 
<LI><OBJECT type="text/sitemap"><param name="Name" value="InfoQube User Manual (node 2043)"><param name="Local" value="node2043.html"><param name="ImageNum
<UL> 
<LI><OBJECT type="text/sitemap"><param name="Name" value="1. Introduction (node 33)"><param name="Local" value="node33.html"><param name="ImageNumber" valu

to

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN"> 
<HTML><HEAD></HEAD><BODY> 
<OBJECT type="text/site properties"> 
<param name="FrameName" value="right"> 
</OBJECT> 
<UL> 
<LI><OBJECT type="text/sitemap"><param name="Name" value="InfoQube User Manual"><param name="Local" value="index.html"><param name="ImageNumber" value="11
<LI><OBJECT type="text/sitemap"><param name="Name" value="1. Introduction (node 33)"><param name="Local" value="node33.html"><param name="ImageNumber" valu

Now run the chm compiler on the project file,

hhc index.hhp

And you should have a shiny new InfoQube.chm
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Perl script for generating the CHM manual

Perl script for generating the CHM manual

11/25/2010 the perl script Jibz uses to create the CHM file.

#!/usr/local/bin/perl -w

# Convert dumped printer friendly version of the online drupal user manual

# to a chm compilable state.

#

# Pass filename as arg.

use strict;

use open IO => ":utf8"; # all files are assumed to be utf8

# get filename from command line

my $filename = shift || die "syntax: dump2chm.pl <html file>";

# open html dump file

open FH, "<$filename" or die "couldn't open $filename";

# open files used by the chm compiler

open my $pfile, ">index.hhp" or die "couldn't open index.hhp"; 

open my $cfile, ">index.hhc" or die "couldn't open index.hhc"; 

open my $kfile, ">index.hhk" or die "couldn't open index.hhk"; 

open my $ifile, ">index.html" or die "couldn't open index.html"; 

# get date (snip from the internets)

my ($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst) = localtime(time);

$year += 1900; ## $year contains no. of years since 1900, to add 1900 to make Y2K compliant

my @mabbr = qw( Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec );

https://infoqubeim.com/drupal5/index.php/pierre
https://infoqubeim.com/drupal5/files/dump2chm.pl_.txt
https://infoqubeim.com/drupal5/files/dump2chm.zip


my $curnode = -1;

my $curnesting = 1;

# this will be the current node file when we open one

my $nfile;

# this hash will be used to store info about internal nodes

my %nodes;

# print headers

print $pfile <<EOT;

[OPTIONS]

Auto Index=Yes

Compiled file=InfoQube.chm

Compatibility=1.1

Full-text search=Yes

Contents file=index.hhc

Default Window=main

Default topic=index.html

Index file=index.hhk

Language=0x409 English (United States)

Title=InfoQube User Manual

[WINDOWS]

main="InfoQube Information Manager","index.hhc","index.hhk","index.html","index.html",,,,,0x23520,,0x387e,,,,,,,,0

[FILES]

index.html

EOT

print $cfile <<EOT;

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">

<HTML><HEAD></HEAD><BODY>

<OBJECT type="text/site properties">

<param name="FrameName" value="right">

</OBJECT>

EOT

print $kfile <<EOT;

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">

<HTML><HEAD></HEAD><BODY>

<OBJECT type="text/site properties">

<param name="FrameName" value="right">

</OBJECT>

<UL>

EOT

print $ifile <<EOT;

<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xml:lang="en" xmlns="http://www.w3.org/1999/xhtml" lang="en"><head>

<title>InfoQube User Manual</title></head><body>

<h1>InfoQube User Manual</h1>

<p>This manual has been automagically generated by <tt>dump2chm.pl</tt> on $mabbr[$mon] $mday $year.</p>

<p>It is a (rough) conversion of the online <a href="https://infoqubeim.com/drupal5/index.php?q=node/48">InfoQube User Manual</a>

and may contain some bad links, you've been warned.</p>

</body></html>

EOT

# scan file and collect used node numbers

while (<FH>)

{

# new drupal node

# format is <div id="node-61" class="section-2">

if (my ($node, $nesting) = /^<div id="?node-(\d+)"? class="?section-(\d+)"?>$/i) {

$nodes{$node} = $nesting;

}

http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd
http://www.w3.org/1999/xhtml
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}

# reset file

seek FH, 0, 0;

# loop through the html dump and write to appropriate files

while (<FH>)

{

# new drupal node

# format is <div id="node-61" class="section-2">

# ie uses capitals and no quotes, hence the optional quotes and ignore case option

if (my ($node, $nesting) = /^<div id="?node-(\d+)"? class="?section-(\d+)"?>$/i) {

$curnode = $node;

# print end of html to last node file if any

$nfile and print $nfile "</body></html>\n";

# open new file based on node number

open $nfile, ">node$node.html" or die "couldn't open node$node.html";

# print node header to new node file

print $nfile qq#<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">\n#;

print $nfile qq#<html xml:lang="en" xmlns="http://www.w3.org/1999/xhtml" lang="en"><head>\n#;

# add filename to index.hhp

print $pfile "node$node.html\n";

# finish last item in index.hhc setting the icon to book for nodes with children

if ($nesting > 1) {

if ($curnesting < $nesting) {

print $cfile qq#<param name="ImageNumber" value="1"></OBJECT>\n#;

} else {

print $cfile qq#<param name="ImageNumber" value="11"></OBJECT>\n#;

}

}

# add list start or end tags to index.hhc based on the new nesting depth

while ($curnesting > $nesting) {

print $cfile "</UL>\n";

--$curnesting;

}

while ($curnesting < $nesting) {

print $cfile "<UL>\n";

++$curnesting;

}

next;

}

# new section

# format is <h1 class="book-heading">3. InfoQube User Interface</h1>

# note: there can be line breaks in the titles! (e.g. 3.2.10)

if (my ($title) = /^<h1 class="?book-heading"?>(.+)$/i) {

chomp $title;

# append next line while we cannot remove the end tag

while ($title !~ s/<\/h1>$//i) {

$title .= <FH>;

chomp $title;

}

# make sure title is printed correctly to current node file

$_ = qq#<h1 class="book-heading">$title</h1>\n#;

# finish node file header and start body

print $nfile "<title>$title</title></head><body>\n";

http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd
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# add title to index.hhc

print $cfile qq#<LI><OBJECT type="text/sitemap"><param name="Name" value="$title"><param name="Local" value="node$curnode.html">#;

# remove any section number and add to index.hhk

$title =~ s/^\d+(?:\.\d+)*\.?\s+//;

print $kfile qq#<LI><OBJECT type="text/sitemap"><param name="Name" value="$title"><param name="Local" value="node$curnode.html">

</OBJECT>\n#;

}

# Fix local urls that got messed up in the dump

s#"https://infoqubeim\.com/index\.php\?q=#"https://infoqubeim.com/drupal5/index.php?q=#;

# fix internal links

# format is <a href="https://infoqubeim.com/drupal5/index.php?q=node/864" class="link-node">5.3 Sorting</a>

# the g option makes the match in the while condition continue, effectively looping over all occurences in the string

# note: can be wrapped across multiple lines

my $temp = $_;

while ($temp =~ m#"https://infoquebim\.com/drupal5/index\.php\?q=node\/(\d+)"#g) {

my $node = $1;

if (exists $nodes{$node}) {

s#"https://infoqubeim\.com/drupal5/index\.php\?q=node\/$node"#"node$node.html"#g;

}

}

# warn about input tags, since they are sometimes used in place of img tags

if (/<input /i) {

print "<input> tag warning in node$curnode.html\n";

}

# replace unicode characters with html entities

# there has to be a 'nicer' way of doing this

s/([\x80-\x{10ffff}])/"&#" . ord($1) . ";"/ge;

# print to node file if any

$nfile and print $nfile $_;

}

# finish up

print $cfile qq#<param name="ImageNumber" value="11"></OBJECT>\n#;

print $cfile "</UL>\n";

print $kfile "</UL>\n";

Pierre_Admin 2010/11/25 13:56

10 views

InfoQube's automatic (behind the scene) field treatment

InfoQube's automatic (behind the scene) field treatment

[To be completed. Just a sketch with some ideas.]

IQ manages fields in the background and there are a few cases where IQ will add data to a field or remove it automatically, depending on certain item

manipulation.

These automatic field data modification can be classified into 2 categories : 1) those which are hard coded into the system, 2) and those which are specified

by the user.

1- IQ's "hard coded" automatic field data modification

The idea here would be to explain what IQ automatically does to fields when :

1- an item is added to a grid,

2- an item is moved from one grid to another

3- a subitem is created

4- a subitem is promoted to top level or a TLI is demoted to a lower level

https://infoqubeim/
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All that in relationshion to

1- simple sources

2- complex sources using the AND operator

3- complex sources using the OR operator

4- complex sources using a mix of operators

etc.

  [NOTE : All these should be explained in details so that it's easier for the users to make database design choices in relation to filtering needs. E.g. : should a

user use inheritance or not ? A complex source or a simple one ?]

2. IQ's "user specified" automatic field data modification

Fields can be automatically updated, modified, etc. through certain choices of configuration :

Field inheritance -- set through the Field management dialog (-- link to nonexistent node ID 1072 -- and ... )

"auto assign the following fields"  -- set through the "Manage Grids" dialog's (-- link to nonexistent node ID 896 -- and -- link to nonexistent node ID --)

"auto assignment rules" equations  -- set through the Field management dialog ((-- link to nonexistent node ID 1071 -- and Field Management Dialog)

SQL requests (and other scripts ?) -- written in the options section of the Field management dialog (Smart Fields and Field Management Dialog)

VB scripts written in the VB editor (View -> Visual Basic editor)
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Item Copy & Paste - Selection - Drag & Drop

Contents:

�. Selecting

�. Copy and Paste

a) Copying the content of a range of cells

b) Copying a full items or portions of items, etc.

c) Pasting an item (or items) in a grid

Selecting an Item and moving it using Drag & Drop

�. Item Selection and moving via Drag & Drop

1.0 Selecting Text and Items

Range of cells: click on any non editable area (mouse cursor changes to Arrow)... and drag if necessary (for multiple selection)

Items: Click on the # column (left-most column) and drag if necessary (for multiple selection). As usual, Shift-click to extend, Ctrl-click to include /

exclude specific items. Again, you must use the # column if Grid >> Select Mode is Multi-Column (if select mode is Full Line, you can use other

columns)

Columns:

If the SortBar is not visible, you can click on a column header to select a column (or use the context menu). Ctrl-click to include / exclude a

column.

If the SortBar is visible, you must use Ctrl-click (or use the context menu), else you'll sort the items

2.0 Copy and Paste

Like most Windows Applications, all copying actions are performed by :

�. Selecting something with the mouse,

�. Ctrl+C OR mouse right-click -> Copy :

Pasting is done by :

�. Selecting a position (or a zone) with the mouse,

�. Ctrl+V OR mouse right-click -> Paste :

https://infoqubeim.com/1068
https://infoqubeim.com/986
https://infoqubeim.com/1068
https://infoqubeim.com/drupal5/index.php/pierre


 a) Copying the content of a range of cells

When the "tree" column is not part of the selected cell range, copying works like it would in a spreadsheet like Excel: It will instantly copy the contents of the

selected cell. It's then ready to be pasted anywhere.

(the tree column is the one showing the outline, and shows an expand/collapse button)

b) Copying items

When selecting items (either the whole item or at least the "tree" column), you'll always be presented with the dialog below.

Numbers 1 & 2 are intended for other applications; 3 & 4 are for pasting within IQ

1)  "Only the tree column will be copied" the tree column (the one with the bullets) is normally the Item field (this can be manually changed via the grid-

column-header's context menu)

The result of this copy will be a bulleted list which is indented for sub-items, also suitable for other outliners.

2)  Copies items in tab-delimited format : the content of the selected rows and colums and their headings.

3)  Copying in XML format copies all the filled fields & properties of the selected items - i.e. will make an identical copy.

Note that If you select an item and its subitems, IQ will preserve the hierarchical information.

4)  Same as #3 - but makes copies of  all the selected items' sub-items, whether they appear in the grid or not.

Note: if you don't want all sub-items to be copied, use option #3, and hand pick the sub-items you want to copy.

Pasting an item (or items) in a grid(when item has been copied using XML format -- see numbers 3 & 4 above)

Items will be pasted at the same level as the item that currently has focus

1- If a top-level item has focus you will normally **  see this dialog:



~ first option being to create a new item which will have exactly the same fields filled as the original item, but it will be a separate item (having a different

Item ID number)

~ second option involves showing the 'copied' item in this new location - i.e it will actually be the same item as the one you copied - it will be displayed here

as well as in it's original location(s) -- if you update this item in it's new location, it will be updated wherever else it is displayed.

Technically speaking: what the second option actually does here is to fill this grid's current source field for the item you have copied (presuming it is a simple

source, i.e. just one field)

** (as of 2010 03 11)  this paste dialog currently appears only if the grid has a simple source (i.e. : the source has only one field in it, or fields linked with the

AND operator). Why ? Simply because IQ cannot guess for the user what field should be filled for the pasted items to meet the current complex source and

be show in the grid. Eventually, a workaround will fix that issue.

2- If a sub-item has focus you will see this dialog:

again:

~ first option being to create a new item which will have exactly the same fields filled as the original item, but it will be a separate item (having a different

Item ID number)

~ second option involves showing the 'copied' item in this new location - i.e it will actually be the same item as the one you copied - it will be displayed here

as well as in it's original location(s) -- if you update this item in it's new location, it will be updated wherever else it is displayed.

Technically speaking: what the second option actually does here is to give the item a new parent (items can have as many parents as you like)

Item Selection and moving via Drag & Drop

For simple mouse actions,  there are three simple principles to remember :

1)  to drag & drop : click on any editable area and drag. In editable areas the mouse pointer changes to caret (text-cursor) 

2)  for simple or multiple contiguous (adjacent) cell selection: click on any non editable area (mouse cursor changes to Arrow)... and drag if necessary (for

multiple selection)

3)  selecting a full item (all cells at once) can be done by clicking on the # column or using the left arrow key

Note: Full Item Selection is only necessary if you want to delete or copy the item (deletion can also be done via Crtl+E when the item has focus, the full item

row does not need to be selected)

With only one cell in an item selected, you can move the item (with mouse or with keyboard shortcuts)

See Drag-and-drop and other common UI operations for Tips and tricks on Drag & Drop

______________________________________________

Related forum threads:

Request re moving item using # column

help with 4.40.30 Item Copy & Paste

And from the manual:

Grid/Items keyboard shortcuts

-- link to nonexistent node ID 1125 --

-- link to nonexistent node ID 278 --

https://infoqubeim.com/524
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Drag-and-drop and other common UI operations
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KatMouse: Configuring to use with IQ

KatMouse is a great little utility to maximize the use of the mouse wheel

With Windows 10, KatMouse is no longer useful as there is a built-in setting for this (Scroll inactive windows when I hover over them)

[quote] KatMouse web site:

The prime purpose of the KatMouse utility is to enhance the functionality of mice with a scroll wheel, offering 'universal' scrolling: moving the mouse wheel

will scroll the window directly beneath the mouse cursor (not the one with the keyboard focus, which is default on Windows OSes). This is a major increase in

the usefullness of the mouse wheel.

[/quote]

To make KatMouse work with InfoQube, simply:

�. Start InfoQube with a grid open

�. Open KatMouse settings

�. Click the tab Classes

�. Drag the icon left of the Remove button to the grid (not the main window)

�. You should see a new entry in the list: Exontrol.G2antt.WindowList

�. With the Gantt chart showing (i.e. can use the sample IQBase Project grid), drag the icon left of the Remove button to the Gantt (not the main window)

�. You should see a new entry in the list: Exontrol.G2antt.Chart

�. Open the Calendar

�. Drag the icon left of the Remove button to the Calendar

��. You should see a new entry in the list: Exontrol.Schedule

��. Click OK

Now, no need to bring the focus to the current window to scroll:

    * Scroll the mouse wheel to move the grid up and down

    * Hold the Shift key to move the grid or Gantt left and right

    * Hold the Ctrl key to zoom in/out the grid or Gantt
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Managing Projects using InfoQube. Mark's draft - under active development, March 2015

Managing Projects using InfoQube. Mark's draft - under active development, March 2015

Managing projects using InfoQube

NB: This documentation is based on Mantis entries: 

0053 Gantt Chart (first version)

0331 Task Dependencies

0574 Gantt chart enhancements (hours view, better date header display)

0594 Gantt: Switching between tasks and milestones

0642 Gantt: Add option to set non working days

0705 Gantt: Scale not saved

0768 Add overload capabilities to the Gantt

0803 Gantt enhancements

0873 Gantt charts - Show overview and histogram checkbox

1004 Gantt chart: No need to set the End Date and Duration fields

1036
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Grid: Item color: add option to select which columns are shown in that color

1037 Gantt chart: add option to set bar colors

It also incorporates material from the Wikipedia articles on project management and on work breakdown structure.

What is Project Management anyway?

InfoQube is often used in the planning and monitoring of activities made up of constituent individual actions. An example of an activity is a simple one-off

task, such as "sell car". The activity is fairly clear in scope, and any associated planning is probably quite simple. A typical way of doing this in InfoQube is to

create an item called "Sell car", and to create child items – individual actions – in a hierarchy below that item, such as "Service car", "Advertise car", etc.

Sometimes activities, made up of interdependent actions, are sufficiently complicated to merit being treated as:

�. Either ongoing processes or operations - these are activities which are frequently repeated following a more-or-less well-defined process design or

template. Thus if you collect cars and sell lots of them, it might be worthwhile to define an InfoQube form as a template for the repeated activity.

�. Or as a one-off but perhaps complicated project.

As a working definition of a project, Wikipedia suggests:

"

A project is a temporary endeavour, having a defined beginning and end (usually constrained by date, although it can be by funding or deliverables),

undertaken to meet unique goals and objectives, usually to bring about beneficial change or added value. The temporary nature of projects stands in

contrast to business as usual (or operations), which are repetitive, permanent or semi-permanent functional work to produce products or services. In

practice, the management of these two systems is often found to be quite different, and as such requires the development of distinct technical skills and the

adoption of separate management.

The primary challenge of project management is to achieve all of the project goals and objectives while honoring the preconceived project constraints.

Typical constraints are scope, time, and budget. The secondary—and more ambitious—challenge is to optimize the allocation and integration of inputs

necessary to meet pre-defined objectives.

"

Wikipedia discusses project management in general terms. The scope of a project which can effectively be managed using InfoQube is restricted to projects

carried out only by a small number of people - usually one. Furthermore, IQ provides no explicit support for PERT or CPM approaches.

The diagram illustrates the main stages in managing a project:

Source: Wikipedia Commons http://en.wikipedia.org/wiki/File:Project_Management_%28phases%29.png

Planning and designing projects

The management of any project should be planned in two stages. These are:

�. Identify the Work Breakdown Structure – in essence, what are the outputs, the deliverables, required from the project.

�. Plan the Project Schedule – how and when the various actions required to create the outputs will be carried out.

The Work Breakdown Structure (WBS)

The first stage in the planning of a project should be the identification of its work breakdown structure (WBS). The Work Breakdown Structure is a tree

structure, which shows a subdivision of the outputs required to achieve an objective; for example a program, project, or contract. The WBS tells us WHAT

http://mantis.sqlnotes.net/view.php?id=1037
http://en.wikipedia.org/wiki/File:Project_Management_%28phases%29.png


elements ("deliverables") are necessary to plan, execute, control and close a project, while the (subsequent) project schedule will tell us HOW we plan on

creating each of those deliverables. In this context, the WBS should always represent exactly 100% of the approved scope (deliverables) of any project.

It is important to understand that the WBS shows only WHAT the deliverables are. It does not (or should not) show the structure of the deliverables, that is

HOW they are individually constructed. It makes perfect sense to do that too using IQ, but the WBS should not be confused with that product structure. Nor

should the initial creation of the WBS be confused with the subsequent stage of project scheduling, which identifies the schedule of tasks and their

interdependencies – the WHEN. It is considered poor practice to construct a project schedule before designing a proper WBS. So the WBS is neither a

project plan, nor a schedule, nor a chronological listing.

In a project or contract, the WBS is developed by starting with the end objective and successively subdividing it into manageable components in terms of

size, duration, and responsibility (e.g., systems, subsystems, components, tasks, subtasks, and work packages). Thus it includes all deliverables necessary to

achieve the objective. This may take the form of a tree structure.

The most obvious way in which to model a tree structure in InfoQube is of course as a hierarchical outline. However, this is not actually necessary in order to

plan a project nor – subsequently - to represent it as a Gantt chart.

The Work Breakdown Structure provides a common framework for the natural development of the overall planning and control of a project or contract and

is the basis for dividing work into definable increments from which the statement of work can be developed and technical, schedule, cost, and labour hour

reporting can be established.

A work breakdown structure permits summing of subordinate costs for tasks, materials, etc., into their successively higher level “parent” tasks, materials, etc.

For each element of the work breakdown structure, a description of the task to be performed is generated. This technique is used to define and organize the

total scope of a project.

The WBS should initially be organised around the primary products of the project (or planned outcomes) instead of the work needed to produce the

products (planned actions). Since the planned outcomes are the desired ends of the project, they form a relatively stable set of categories in which the costs

of the planned actions needed to achieve them can be collected.

The Project Schedule

An outcome determines a so-called terminal element of the project, that is, an activity which delivers that outcome. A well-designed WBS makes it easier

to assign each project activity to one and only one terminal element of the WBS, which is desirable in phased projects which deliver multiple outcomes and

for which – for example – separate costings / billing items are required or desirable as part of the process of accounting for project costs.

A Gantt chart is a type of bar chart that illustrates a project schedule. InfoQube has a Gantt view, which includes a Gantt chart.

Gantt charts illustrate the start and finish dates of the terminal elements and summary elements (intermediate elements) of a project. Terminal elements

and summary elements derive from the work breakdown structure of the project. Gantt charts can also show the dependency (i.e. precedence network)

relationships between activities. Gantt charts can be used to show current schedule status using percent-complete shadings. Gantt charts have become a

common technique for representing the phases and activities of a project which carries out a work breakdown structure (WBS), so they can be understood

by an audience which is wider than the person who is planning the work.

Assumptions and Limitations

InfoQube cannot pretend to the advanced project management capabilities present in dedicated project management software such as Microsoft Project.

However, IQ does include powerful work management capabilities which, crucially, can easily be integrated with the other information management needs of

individuals. This documentation assumes that InfoQube is being used to manage the activities associated with one person carrying out a complete project.

The size of an action is measured in person-days of effort (although the Gantt view supports all of hours, days, weeks and months). Normally, its duration is

determined by its start date and its end date; however, it is no longer required to set the Gantt chart End Date and Duration field. An action which takes zero

time is called in IQ a milestone; it is represented not as a line in Gantt view, but as a lozenge.

In a project schedule, dependencies between actions are identified. Where one action cannot start until one or other earlier actions have been completed,

the action has a dependency upon those actions.

Projects in InfoQube

The implementation of projects in IQ usually involves a combination of specific IQ features. These are:

�. Gantt View. This can be enabled for any grid, although typically it is used with a Projects grid. To toggle Gantt view on or off for a given grid, used Grid

/ View Gantt. To set the Gantt-related properties for a grid, use Grid / Properties and open the Gantt Chart properties for that grid.

�. A set of system fields.

These are together used intended to represent Projects. 

The system fields include:

Field

N°.

Field name Type Caption in grids Notes on field behaviour

90 TaskActStart Date TaskActStart

91 TaskActEnd Date TaskActEnd



93 NextTaskDelay Number

94 TaskDuration Number Nb Days

95 Task%Complete Number % Done

96 TaskEffort Number TaskEffort

97 TaskID Number TaskID

98 NextTaskID Text NextTaskID

99 TaskBarColor Text

100 TaskIsSummary Yes/No

101 TaskBarCaption Text

Part of the flexibility of IQ is that it is not necessary to stick to a strictly hierarchical breakdown of work. Thus an element of one project may equally be used

as an element of a second project. 

One thing which is essential to effective project planning in IQ is grouping together tasks which together constitute a project. It might therefore be sensible

to represent the project as a tree structure of hierarchically-linked tasks and their sub- and sub-sub- tasks. However, this is not in fact the way in which IQ

shows how tasks are related. Instead, IQ permits task dependencies to be represented and stored explicitly. One task can depend on more than one other

task, and one task can precede more than one subsequent, dependent, tasks. Thus, it is only by convention that tasks and sub-tasks are represented as a

hierarchy, and IQ ignores the tree structure when considering dependencies. Instead, it relies upon the use of the two system fields TaskID and NextTaskID to

show how each task relates to others.

Traditionally in project management, project tasks are labelled using letters. However, IQ uses the numerical system field TaskID to identify individual tasks

which participate in dependencies and the system field NextTaskID to store dependencies. In fact, the NextTaskID field can be used to identify several “next”

(dependent) tasks since it takes the form of a comma separated list. It should be noted that when a dependency is established, completely new values are

created for TaskID and NextTaskID - they have nothing to do with the IDItem field associated with all IQ information items.

An example of an IQ project

The standard sample database contains a project called Somiro. The screenshot which follows is taken from such a sample database.

In the screenshot we can see the following elements:

�. A TLI (top level item) ‘Project Somiro’ and its constituent tasks, here labelled 1.1 to 1.11; this grid shows the principal fields needed to implement a Gantt

chart in IQ; these fields are discussed below.

�. Above the grid is shown the project overview – this extends over the whole length of the project, which is here all of May and most of June 2008; it is

shown if the Gantt Chart property Show Overview is set; the scale of the display can be set to one of Min, Hr, Day, Wk, Mo (minutes, hours, days, weeks,

months).

�. To the right of the main grid is shown the magnified detail Gantt view of the tasks which are active in a particular seventeen day period; the part of the

project which is currently displayed is indicated by orange shading in the project overview described in the previous element.

�. Below the detail Gantt view is the resource utilisation histogram; it is shown if the Gantt Chart property Show Histogram is set.

Right-clicking the date line at the top of the Gantt view displays a menu which permits the Show Overview, Show Histogram and Zoom parameters to be

changed; Gantt properties are also accessible from this menu.

Using Gantt View in IQ

Gantt charts are good for project management, but they can also be used for other things, since:



   The amount of scaling is under user control.

    The current time is shown as a green vertical bar in the minute, hour and day scales.

    If you double-click on the header, the chart is centred to the current date/time.

    If you double-click on the chart on an item line, the chart is centred on that item bar.

    Using the mouse-wheel when over the Gantt scrolls the chart 

left-right if Ctrl is held simultaneously

zoom in-out if shift is held simultaneously;

the page scroll buttons makes larger up and down movements.

you are using a tablet, when over the Gantt scrolls the chart 

left-right if Ctrl is held simultaneously

zoom in-out if shift is held simultaneously;

the page scroll buttons makes larger up and down movements.

    As the user moves the mouse (just below the date headers), a Date Ticker is shown.

Manipulating items in Gantt views

Moving items: To move items, you must be very careful to select the bar in the middle and move left or right, etc...

Linking items: In order to link one item to another so that it becomes a precessor, you press the Shift when you first click on a bar:

�. Press Shift

�. Click on the first bar

�. Let go Shift (if you hold the Shift key too long, it stops linking)

�. Drag to the second bar

Formatting items in Gantt views

Grid: Item colour: an option has been added to select which columns are shown in that colour.

Currently, the item back colour is set to all columns. This is sometimes not desired (in particular with the new Gantt chart bar colour). The new option

permits setting the list of fields which show the color; it should be left blank to color the whole item:

Grid>>Properties>>Options>>Item color applies to fields:

Additionally, in a Gantt chart:  an option has been added to set Gantt item bar colours. The steps necessary are these:

   Grid>>Properties>>Gantt Chart>>Bar color field : set it to field containing the color (by default, the ItemColor field is used)

    Set the values for the bar colours (using ItemColor field is easy because IQ has context menus to set this field)

The bars will be coloured.

Setting Grid Properties

These are set using Grid / Properties, then opening the Gantt Chart properties, which are:

Field Default values Notes

Start Date Field TaskActStart

End Date Field TaskActEnd

Duration Field TaskDuration

Percent Done Field Task%Complete

Bar caption field TaskBarCaption

Effort (in days) Field
TaskEffort

Bar color field TaskBarColor

Bar default color &H00FB9492& Light gray-blue

Show Overview Yes Determines whether the

Overview element of Gantt

view is displayed

Show Overview zoom

buttons

Yes Determines whether zoom

buttons (displacement left,



earlier; or right, later) are

displayed; this option is only

available if Show Overview is

set

Show Histogram Yes Determines whether the

Histogram element of Gantt

view is displayed. The

Histogram shows the extent

to which the individual

whose work is being planned

is committed; if the figure

exceeds 100%, it indicates

that, for example, it will be

necessary to work overtime

Non Working Days
Used to select days of the

week which are not worked

(e.g. Saturday and Sunday)

Non Working Hours
Used to select hours of the

day which are not worked

(e.g. 12AM to 08AM,

implying that the working

day starts at 09:00)

If you set your grid source to your Gantt Start date field (normally TaskActStart), the DateFilter toolbar can then be used to limit the items displayed. This is

useful to view just what you want, to reduce crowding in the overview area and it also helps when printing.

How to use InfoQube to Plan, Schedule and Monitor a Project

Section to follow!
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Selective HTML export

When doing an HTML Export (Table with Columns and Bullet List), it is possible to specify HTML tags that should be excluded from the HTML export, i.e.

{private}

To mark sections of text, first select the text you wish to "hide" from the HTML export, then use the Doc pane function  Menu > Edit > Enclose text with (Ctrl

+ Shift + T)

Alternately,  you may manually enter the tags, for example {private} before the text block, and {/private} after the text block

You will be prompted for a tag:

The selected text will then be enclosed with this tag (yellow highlight was added)

https://infoqubeim.com/drupal5/index.php/pierre


When doing an HTML Export, enter the HTML tags to hide:

Notes:

This works with HTML text only, not MHT
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Settings for best IQ experience

1. Performance

�. Make sure Memory integrity is check is off (in Windows Defender > Device Security > Core isolation)

�. Run as Administrator: Grid refresh (F5) : 0.37 sec --> 0.30 sec (190 items + Gantt)

Drag-drop files / URL from Explorer / Web browser no longer work however (security level). Use Copy / Paste from Explorer instead

�. Grid scrolling is faster when not showing grid lines. Use alternating colors instead

�. Grid scrolling is also faster when outline labels and cell text word-wrap are turned off

�. For very large databases with complex filters Windows may flag the app as "not responding". You can increase the delay using this Registry tweek

2. Text Quality

2.1 1080p displays

On 15 in screens:

Display scaling to 100%

Font: Segoe UI  Size 10

On 13 in screens:

2 options:

Display scaling set to 100%, Font: Segoe UI  Size 10.5 (UI), 11 (Grids)

Display scaling set to 125% (from the dropdown list, not from the Custom scaling setting)

Font: Segoe UI  Size 9

2.2 High DPI displays (2K, 4K)

Display scaling set to 200% or above (from the dropdown list, not from the Custom scaling setting)

Font: Segoe UI  Size 9

2.3 System Enhanced Scaling Setting

If the Display scaling is 150% or greater, the following setting can greatly enhance the text and icon quality:

In Tools > Options > Program > Other > System Enhanced Scaling

There are however currently some issues with this setting, some of which will be addressed in future program updates:

�. Grid lines are not as thick and dark. Perhaps favor alternating row colors to separate items

�. The Surface and Card Views have some display issues when the zoom is not 100%

�. Some dialog have minor display peculiarities 

2.4 Other Fonts Related Settings

Font face is most often a personal preference. A particularly nice font, recently available to Windows 10, is a font developed by Microsoft for Windows 11:

Segoe UI Variable. The 'Display' sub-font renders particularly well inside IQ. Download it from here and give it a try ! (unzip, right-click and select Install)

https://infoqubeim.com/drupal5/index.php/pierre
https://forum.thresholdx.net/topic/230-how-to-delay-x-planeexe-is-not-responding/
https://aka.ms/SegoeUIVariable


It is also quite beneficial to adjust the Windows Clear Type setting. Press the Windows key and type Clear. Go through the wizard selecting the darkest, most

legible text for each step.

3. Pointing Devices

A "good-old" mouse is probably the most common pointing device and IQ is well tuned for these.

Portable PCs have built-in touchpad which sort of behave like a mouse. There are differences however, and these depend on the touchpad type. To date, we

encountered 3 types of touchpad

Mouse

Each mouse wheel step equals 120 scrolling units

In Tools > Options > Program > Grid > Touchpad scroll ratio, enter 100 (i.e. mouse normalized)

Touchpad

ClickLock (Mouse Properties > Buttons > ClickLock): Turning on this really helps move and drag-drop operations

Click the Settings button and reduce the delay

Hint: A double-tap will also lock when ClickLock is enabled

OEM Fixed scroll steps

2-finger scrolls by steps, each 120 scrolling units

No horizontal scroll. Hold the shift key to do horizontal scrolling

In Tools > Options > Program > Grid > Touchpad scroll ratio, enter a number between 20 and 40

OEM Variable scroll steps

2-finger scrolls by steps with a step size proportional to the scroll speed.

Range is variable between devices but typically between 10 and 5,000

No horizontal scroll. Hold the shift key to do horizontal scrolling

In Tools > Options > Program > Grid > Touchpad scroll ratio, enter 100

Microsoft Precision

2-finger scrolls by steps with a step size proportional to the scroll speed.

Range is variable between devices but typically between 10 and 1,000

Horizontal scroll support

In Tools > Options > Program > Grid > Touchpad scroll ratio, enter a number between 100 and 300

 4. Pen Use

These tricks and settings will enhance your experience when using an active pen:

Open writing app in full-screen (i.e. handwriting app Write, integrated into InfoQube): to ensure palm touches do not activate another app

Disable screen left-right swipe gestures: Swiping from the left screen edge to the right will show task view (desktops, opened apps, timeline, etc).

Similarly, right screen edge swipe will show the action center

To avoid activating these features with your palm, disable swipe gestures. Details here

When horizontal swipes are disabled, you can click on the notification icon on the taskbar to show the action center

Pierre_Admin 2020/05/13 13:19
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Showing item in multiple grids

Reference discussion in Showing item in multiple grids

This is one way to show item in multiple grids: I made a "Most_used" form, and put the 10 or so fields I use most in it. So then I go to the Inbox, for example,

and can uncheck from this form Inbox, and check IQ, pc, research, whatever.

https://www.tenforums.com/tutorials/48507-enable-disable-edge-swipe-screen-windows-10-a.html
https://infoqubeim.com/drupal5/index.php/pierre
https://infoqubeim.com/240
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Task Reminders and Alarms

1. Reminder Implementations

There are very many apps available to manage events, tasks and reminders

As InfoQube does not have a mobile app nor does it natively manage reminders and alarms, how can it be configured to leverage other tools to achieve it ?

Let's first look at the current / probable integrations:

�. Google Calendar Sync

�. Google Tasks Sync

�. Microsoft To Do Sync (planned)

The first choice "should" be using Google Tasks as it is a simple task app readily available. It however suffers from 3 major issues: (1) slow dev by Google, (2)

poor repeat handling, and (3) no support for task time. Only the task date is accessible through the API

Microsoft To Do as an app is more advanced than Google Tasks and Microsoft seems more committed to improving it. However Due dates do not have a

time component. One must add a separate Reminder to set a time. The API is complete and robust. InfoQube does not however currently sync with it

So we're left with Google Calendar. While at first glance, it seems like an overkill, it is quite possible to use its infrastructure to provide effective reminders.

Note that the term reminders is considered the same as notifications and as alarms. How reminders are handled, viewed, heard can vary, but the concept is

something to bring your attention to.

2. Google Calendar for Reminders

Pros

Synchs with IQ

With and without a time setting

Extensive repeat patterns

Notifications: Multiple per event, both email and pop-up

Can receive a daily email with items on the agenda

Cons

Visually, the calendar is often not the best UI:

Tasks  (i.e. events) with a time have associated duration, which may not be pertinent

Tasks with no time are shown as all-day events

Overlapping tasks can be hard to view

https://infoqubeim.com/drupal5/index.php/pierre


Google calendar does however have a list view which is somewhat better

Repeat patterns are not perfectly suited to tasks (i.e. "water the plants" scenarios)

Neither Google Tasks nor MS To Do have such repeat pattern for that matter. Outlook has it

No carry forward of uncompleted tasks

3. InfoQube Setup for Reminders

For this setup, we'll use a separate Reminder date field with an AdvanceWarning numeric field which will hold the reminder advance warning (in minutes).

Full setup has 4 steps:

�. Google Calendar

�. InfoQube Fields and Grid

�. Phone Calendar (optional)

�. Desktop Notifications

n.b.

If reminders are to be the same for all tasks, then a simpler setup is possible:

�. Create a Google calendar (IQDueDate) and enable notifications

�. In IQ, sync this calendar with the DueDate field

To implement this simpler setup, follow the detailed setup but omit all references to AdvanceWarning and all equations.

Google Calendar Setup

In Google Calendar:

�. Create a new calendar, name it IQReminders

�. In the calendar settings, add a notification of type Notification, 0 minutes before event

�. Add a notification of type Email for all-day events for the day before, 6PM (or something suitable)

�. If you want to receive daily email with the day's reminders, select that option (under Other notifications heading)

�. Close settings and return to the calendar view. In the left pane, check the IQReminders calendar to show it in the calendar

Phone Calendar Setup

(Instruction are for a Samsung phone, others should be similar)  

�. Open the Calendar app

�. Click Synchronize Now

�. Open the Google Calendar account and ensure that the IQReminders calendar is checked

InfoQube Setup

�. In Tools > Manage Fields:

�. Create a new date field named DateReminder. In General > Properties, check "in Calendar by default".

Set the Format to Short Time (format dropdown)

�. Create a new number field, named AdvanceWarning. In Equation > Auto-assign, enter:

AM:[DateReminder] = CalcReminder([DueDate] , [AdvanceWarning])  

E: [DateReminder]=.

At the end of that section, uncheck "For row and ... treat No values as 0"

�. Select field DueDate. In Equations > Auto-assign rules, enter:

AME:[DateReminder] = CalcReminder([DueDate],[AdvanceWarning]).

�. In Visual Basic Editor, select tab "This database". Add the following code:

Function CalcReminder(DueDate,Advance) 

  dim d 
  if isNull(Advance) or isNull(DueDate) then 
    d = null 
  else 
    if DueDate=int(DueDate) then ' case no time 
      d = DueDate - 6/24. ' if no time, set warning the previous day at 18h00 
    else 
      d = DueDate - (Advance / 60. / 24) 
    end if 
  end if 
  CalcReminder = d 

End Function 

�. Click Validate. If there is a typo, a warning message will point to where the issue is. Click Save and Close

�. In Google Connect:

https://infoqubeim.com/drupal5/index.php/node/4085


Connect to Google if not already connected. Details here

Click on the Refresh icon

Select the IQCalendar item in the list

Click the >> button to set the options for this calendar

Set the Sync type to "Full"

Set the date field to DateReminder

�. Create a new grid, name it ToDo. It will automatically use field ToDo. Another grid name can be used, but then manually set the source to field ToDo

�. In this grid, add columns Todo, DueDate, AdvanceWarning, DateReminder and Done

Desktop Notifications Setup

In your browser, enabled desktop notifications block exception for https://calendar.google.com/  (required browser setting if set to block notifications

In Windows 10 settings app > System > Notifications & actions:

Check "Allow notifications to play sound"

In app list, for your browser, allow notifications with sounds

4. Using Reminders

In the ToDo grid, enter items, one for each task to do

For each task, enter a DueDate (unless it has none)

For each task that needs a reminder, enter a number in the AdvancedWarning column, in minutes (i.e. 10 would give a 10 minute advance warning,

0=warning exactly at the task due date)

Unless AdvancedWarning is empty, the DateReminder will show the notification date / time

Open the Google Calendar web page and leave it open to get desktop notifications

If the phone setup was done, it will also receive notifications.

On the phone, if new tasks are created under the IQReminder calendar, these will appear appear in InfoQube (if grid source includes DateReminder)

Desktop notifications can be delayed for 5 minutes at a time

Items / Tasks can be arranged in hierarchies

5. Options

�. If you want to be able to enter tasks on your phone, change the grid source to ToDo OR DateReminder

�. Grid can be fine-tuned to show done items for x days after done, or until done

�. Grid allow sorting by DueDate, priority, Done, etc

�. Grid support multiple displays, depending on the need. Details here
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Tips for EverNote (2.x) users

Transition for EverNote 2.x users

EverNote feature set is a subset of what InfoQube can do. This page has 2 purposes:

�. How-to information: How to do EverNote-type tasks in InfoQube

�. How to go forward in using the other features of InfoQube

Moving from Evernote 2.x to InfoQube

Create an Evernote 2.x export file (*.enx), then import it via the menu: File>Import>Evernote Export File

Categories -> Fields of type Yes/No. To add a field, go to Field Management > New.

Category icon: add <img>IconName</img>CategoryName in Field Management > Caption (in Properties) (A UI is coming)

Category hierarchy: Use the Parent ID property in Field Management (Drag-drop will be implemented)

Using the InfoQube specific features

1. How to highlight text.

Highlighting, a much-requested Evernote feature, is available in InfoQube

To "highlight" in InfoQube, select the text, and use the "background color" function of the HTML pane.

On the standard HTML toolbar: menu, format, background color

On the formatting HTML toolbar: enable the "background color" icon

https://infoqubeim.com/drupal5/index.php/node/4085
https://calendar.google.com/
https://infoqubeim.com/drupal5/index.php/node/261
https://infoqubeim.com/drupal5/index.php/pierre


On the edit context HTML toolbar: enable the "background color". (Then you will be also able to right-click in the HTML pane and pick the "background

color" icon.

To highlight, select the text, choose the icon or menu for "background color", choose the (highlighting) color, and OK.
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Using IQ with Scrapbook

You can use the FireFox extension Scrapbook with IQ. This is really convenient to grab pages behind logins (such as GMail). To do so:

Initial Setup:

�. Scrapbook > Tools > Options > Organize > Enable multi-scrapbook: checked

�. Scrapbook > Multi-Scrapbook > Manage > Add: Add your IQBase .SNDB..files folder. Name it

�. Scrapbook > Multi-Scrapbook > Switch to the Named Scrapbook

Grabbing content:

�. Capture content using Scrapbook

�. In IQ, create a new item, give it a description (item field)

�. In the HTML pane, File > Open and navigate to the .SNDB.Files\data\CurrentDateID\index.html  (CurrentDateID is the Current date / time)

�. In the HTML pane, File > Save (required to index the content)

�. The same can be done by drag-drop, as described in Link to Files, Folders and URLs

This process creates a link between the two applications (Scrapbook and IQ). Any change in one will be reflected in the other. (i.e. you can edit your

scrapbook clipping with IQ!)

p.s. For GMail, ensure you capture the Printer friendly version of your email
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Using InfoQube without a keyboard

Information management systems, and InfoQube in particular, are keyboard-centric applications. That is one reason why IQ has a wide range of keyboard

shortcuts, most of which are user customizable.

However, with the advent of touch-based operating systems, PCs are evolving and their form-factors are changing.

Convertible, detachable and 2-in-1 devices (such as the Microsoft Surface Pro) are more and more popular and sometimes used as tablets (i.e. without their

keyboard).

InfoQube provides a number of features to ease information management on devices without a full, always connected, keyboard:

Customizable toolbars (list of commands, larger buttons)

Scrolling by touch (most UIs)

Handwriting input panel (Popup Editor)

Handwriting using Ink documents (Doc pane)

Function keys toolbar ( + Shift / Ctrl / Alt modifier keys)

Windows built-in Touch keyboard

Command to show the On-Screen keyboard

Tips:

Having an active pen is an excellent accessory to have, as alternative input method

There are currently a few incompatible standards, N-trig, Wacom, Synaptic, but the coming Universal Stylus Initiative will help clean this up, eventually...

The Touch keyboard and the On-Screen keyboard are not the same thing...

The Touch keyboard is shown by tapping on the keyboard icon of the taskbar.

It is not re-sizable but has a few layouts and supports a handwriting input panel with predictive word suggestions.

Also, activating the Touch keyboard will resize the IQ window so it fits just above the touch keyboard 

(the IQ main window must not be maximized, and the Touch keyboard must be in Dock mode)

https://infoqubeim.com/drupal5/index.php/pierre
https://addons.mozilla.org/en-US/firefox/addon/427
https://infoqubeim.com/116
https://infoqubeim.com/drupal5/index.php/pierre
https://universalstylus.org/


Closing the Touch keyboard restores the IQ window to its previous size. Quite handy

The On-Screen keyboard is also a virtual keyboard, but re-sizable and with a more complete set of keys. 

Some users prefer it to the Touch keyboard. Also worth noting, it can show a small panel above the keys with predictive word suggestions.

Some notebook PCs either have no function keys, or have function keys, but these are assigned to system function (such as raise / lower volume) and

to use these as "legacy" function keys, one my simultaneous press a Fn modifier key. It can require quite the finger gymnastic to use some keyboard

shortcuts. 

The Function keys toolbar can be useful for those PCs.
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WikiTag Hyperlinks

What are they ?

A WikiTag is basically a name, a category that helps creating a reference, a hyperlink

to an other item. Each item can have several WikiTags (have several categories), and each item can

have links to other items' WikiTags (more about that later).

WikiTags can be used as replacements for yes/no fields. The advantage is that there is no need to create the field before using it. Also, all the tags

are displayed in a single cell. The disadvantage is that they are more difficult to use, filter for, etc. A better UI is planned.

Where are they?

In InfoQube, WikiTags are put into a specific column/field.

If you can't see the WikiTag column/field in your grid you can either..

1- Add the column to the grid : right click on the columns heading and choose -> display column. Tick

the WikiTag field. (Alternatively you can also drag and drop the WikiTag field from the properties pane

(F4 or view -> properties) to where you want it in your currently opened grid)

OR

2- Just use the properties pane (F4 or view -> properties) : find the currently selected item(s)’ WikiTag

field in the available fields section (in the properties pane, you could create a form including the WikiTags field.

How do I use WikiTags?

1- Enter terms in the item’s WikiTag's column/field — the terms must be bracketed

(with curly brackets) : {example1} {example2}.

(Note that you can have one or many WikiTags in the same field cell)

This means that the WikiTagged item can now be reached/hyperlinked through its {example} tag.

2- Create a link to your WikiTagged item (similar process for many types of links):

a. Right click on an other item and select the hyperlink icon (the icon looks like a "chain link")

b. In the Hyperlink window : 1- enter the text you want to see in your item field ("My new WikiTag link"), 2- in the “file, grid…” text box, enter the {example1} or

{example2}  tag (with the curly brackets please -- and note that you can only reference to one WikiTag at a time).

c. select OK... That’s it.

If you click on the newly created hyperlink, and the Wikitagged item(s) is (are) not in the current grid,

you’ll be brought to the Scratch Grid, where all items that have the {example} WikiTag will be shown.

Try it... (Alternatively, you could use html syntax directly in the items field : <a {example}>My new wikitag link</a>

https://infoqubeim.com/drupal5/index.php/pierre




Index terms: Wikitag
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Working with Grids and Tabs

Grids can be opened using the Grids sub-menu inside the View menu (which can also be placed as a toolbar, with a button for each grid, shown vertically in

the figure below.). The Grids menu can also be shown using the ctrl-shift-O shortcut and the user can navigate through the grids by typing the first letter of

the wanted grid, or even using arrows) and pressing enter when the right one is reached.

Opened grids are organized in tab groups (shown horizontally in the figure bellow : Welcome, ,Inbox, etc.).

(More explanations below the drawing.)

https://infoqubeim.com/drupal5/index.php/pierre


Tab groups allow you to display windows side-by-side OR one above the other

They are called tab groups because each group can contain multiple tabs. i.e. if you have 5 grids open, you can have 2 in one group and 3 in the other.

You can now compare the information in the visible grids, or drag and drop items from one grid into the other - along the lines of a dual-pane file



manager.

Another great strength of this is that you can open two instances of the same grid and move/copy items around within the same grid.

To do this: Right click grid tab > Select "New Window" (or Shift-click on a specific grid toolbar button) - opens a second copy of the grid

Right click grid tab of either copy of grid and as shown in screenshot select either Vertical or Horizontal "Tab Groups"

You now have two copies of one grid side by side or one above the other - use to view different areas of the same grid, etc.

You can also drag tabs from one group to the other, or you can right-click a tab to move its window from one group to another (select "Move to

next/previous tab group")

Also See

-- link to nonexistent node ID 809 --

6. Manage Grids Dialog
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Working with multiple instances of the same IQ Base

Is it possible to open 2 or more instances of InfoQube to work on the same IQBase file?

(i.e. You see 2 or more "InfoQube.exe" in the task manager)

The short answer is : YES.

More details :

�. IQ uses Microsoft JET 4.0 as its database engine which is fully multi-user. Also, each field value is a separate database record, hence reducing the data

corruption risk. So the bottom line is that you won't run the risk of corrupting your data by working on your database with 2 or more IQ instances.

The only possible situation is that the second instance gets an inconsistent / outdated set of field-values. Nothing that a refresh would not solve...

�. Note that all grid changes are saved on a refresh, so the other IQ instance grids will behave exactly as when you have the same grid opened more

than once : that last refreshed/saved one "wins". To have two independent view of the the same data, save the grid under a new name (Grid > Save As...)

and open one grid in one instance and the other in the other instance

�. In Tools > Options, set 2.4.9 (Multi-user check) to 60 seconds or so, so data changes are seen by the other instance (UI changes do not auto-sync, only

data)

�. Concerning the VB scripts : The user code is loaded on startup (system, user) or when opening file (DB specific), so changes in one IQ instance is not

updated in the other.

�. To open a second instance of the same file, open IQ and do File > Open and select the file

(See also that related thread from the user forum Can opening 2 instances of IQ loading the same DB eventually increase the risk of Data corruption ? )
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Pane manipulation in IQ:

Panes are windows which can be moved around, grouped, float or docked to a side:

Resize a docked or floating pane

Undock a pane to make it float

Dock a pane to the left or right

Dock a pane to the top or bottom

Dock a pane under or above

Group windows under the same pane (as a tab)

Auto-hide a docked pane

Auto-hide a floating pane

In general, you first select the pane you wish to manipulate, and start a drag operation.

As shown, the HTML pane is being dragged, and a cross-shaped cursor appears, as well as the various docking boxes.

https://infoqubeim.com/269
https://infoqubeim.com/drupal5/index.php/pierre
https://en.wikipedia.org/wiki/Access_Database_Engine
https://infoqubeim.com/1820
https://infoqubeim.com/drupal5/index.php/pierre


This dragged pane can be dropped to either floating, or to one of the docking boxes. Once dropped, it can be resized.
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1) Pane Movement -- Undocking a pane

Undocking a pane

There are 2 ways to undock a docked pane (i.e. detach, float):

�. Double-click on the pane caption

�. Do View > Layout > Floating Pane (Shift + F11)

�. Use Drag-drop

To Drag-drop, select the docked pane you wish to undock. In this case, the HTML pane will be moved from a docked position to a floating position:

The arrow cursor indicates this pane may be dragged in any direction:

https://infoqubeim.com/drupal5/index.php/pierre


Drag the HTML pane out to a "floating" position, by not dragging it over any of the movement boxes:

Drop the pane, and it will be in a floating position (not docked).

Once undocked, it can be resized by dragging one of the 4 corners. The new window size will  be saved so the next time the pane is detached, it will have this size.



The floating pane still has a "pin" in the top-right corner of the window.

Pressing the "pin" puts the pane in auto-hide (a floating auto-hide pane) showing only the pane caption. Move the mouse over the caption to show the pane content

To reattach (i.e. dock) a pane, you can

Press Shift + F11 or double-click the caption to return it to its previous position or,

Use drag-drop (See 3) Pane Movement - dock a pane (node 1920)) to dock it anywhere

Pierre_Admin 2016/09/03 21:25

6 views

3) Pane Movement - dock a pane (node 1920)

3) Pane Movement - dock a pane (node 1920)

Move a pane into a docked position:

In this example, a pane presently docked to the right-hand side will be docked at the bottom.

This could similarly be done with a pane that is floating.

--

Select the HTML pane:

-

--

 Drag the pane towards the bottom box as shown:

--

https://infoqubeim.com/1920
https://infoqubeim.com/drupal5/index.php/pierre


--

Hold the pane over the "box" and notice the shadow preview of where the pane is about to dock.

--

--

Drop the window (let up on the mouse): The pane docks into place at the bottom. Similarly it could be moved to the top, or right side, or left side. Since there

is only one pane open, the middle group of boxes work like the outer group of boxes.

The middle group of boxes will be covered later--they are applicable when there is more than one pane open.

 --



--
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4) Pane movement- dock under or above (node 1923)

With the Proper�es pane shown (and fairly wide), Dock-bo�om to Dock-under the Proper�es pane

Here we have a second pane, the properties pane, open and docked to the right. (View>Properties to open it).

We will dock it "under" the HTML pane

--

--
Select the pane and start dragging towards the middle of the HTML pane:

--

https://infoqubeim.com/drupal5/index.php/pierre


---

The group of 4 boxes appears in the HTML pane area. Drag the pane until the cursor is over the lower box (the "under") position. Note that the highlighting

this time is the lower area of the HTML pane, and not the overall window. You could similarly drag it the top, left or right of the HTML pane.

--

--

 Drop the window, and note that the Properties pane is not docked "under" the HTML pane.

--



--

Notice the difference if you had docked to the bottom--the Properties pane would span across the bottom of the overall InfoQube window as shown:

--

--
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5) Pane movement - Dock to a tab (node 1924)

5) Pane movement - Dock to a tab (node 1924)

Dock to tab:

--
Now drag the Properties pane to the center section of the group of boxes as shown, and note the highlighting encompasses the entire HTML pane:

--

--
Notice the Properties pane fills the HTML pane area, and is the currently shown pane. If you click the HTML: (ID=1656), the HTML pane becomes the active

pane.

--



--

You may now drag either of these panes out to a floating position, by dragging as shown:

--

--
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6) Pane Autohide (node 1915)

Autohide Panes

You can auto-hide panes using the 'Pin' icon in the titlebar of the pane.

These panes can be shown again by using the mouse or the relevant shortcuts: F4 key for the Properties pane; F12 key for the HTML pane.

Circled here are the autohide icons on the HTML and Properties panes.

Clicking on the pin icon will autohide the pane on the right-hand-side of the IQ window.

In the following screenshot I have 'autohidden' or 'pinned' the Properties pane:



Below - I have clicked on the Properties pane's tab on the right hand side in order to show the pane - just holding the mouse over it's tab will

also show the pane (but without focus). When the pane shows itself here it actually overlies the HTML pane.

It stays visible until the focus is moved elsewhere - it then autohides again.

Below I have pinned both panes:

Summary:

To hide the pane:

click the pin icon in panes titlebar to autohide the pane

To show the pane:



hover mouse over the tab on the right-hand-side of the IQ window to temporarily show the pane

click the mouse over the tab on the right-hand-side of the IQ window to show the pane (until it loses focus)

use the relevant shortcut to restore the pane - F4 key for the Properties pane; F12 key for the HTML pane. Press same key again to get focus back to the

grid

To restore the pane to a permanent display

Show the pane, then click on the pin icon again - the pane will no longer autohide.
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